Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
bd5d2b32
Commit
bd5d2b32
authored
3 years ago
by
Sören Tempel
Browse files
Options
Downloads
Patches
Plain Diff
community/libvirt: fix build with meson 0.58
parent
f9962b39
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/libvirt/0001-meson-Fix-compatibility-with-Meson-0.58.patch
+42
-0
42 additions, 0 deletions
...ibvirt/0001-meson-Fix-compatibility-with-Meson-0.58.patch
community/libvirt/APKBUILD
+6
-2
6 additions, 2 deletions
community/libvirt/APKBUILD
with
48 additions
and
2 deletions
community/libvirt/0001-meson-Fix-compatibility-with-Meson-0.58.patch
0 → 100644
+
42
−
0
View file @
bd5d2b32
From c607266619c5ab78ad5d4179b3ea93cfb6348391 Mon Sep 17 00:00:00 2001
From: Andrea Bolognani <abologna@redhat.com>
Date: Mon, 3 May 2021 09:06:34 +0200
Subject: [PATCH] meson: Fix compatibility with Meson 0.58
Builds failed with
tests/meson.build:690:0: ERROR: List item must be one
of <class 'str'>, not <class 'list'>
before this change.
https://gitlab.com/libvirt/libvirt/-/issues/158
Signed-off-by: Andrea Bolognani <abologna@redhat.com>
Reviewed-by: Peter Krempa <pkrempa@redhat.com>
Reviewed-by: Pavel Hrdina <phrdina@redhat.com>
---
tests/meson.build | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/tests/meson.build b/tests/meson.build
index 05c3e90195..9900983d0c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -687,12 +687,12 @@
foreach name : test_scripts
test(name, script, env: tests_env)
endforeach
+testenv = runutf8
+testenv += 'VIR_TEST_FILE_ACCESS=1'
+
add_test_setup(
'access',
- env: [
- 'VIR_TEST_FILE_ACCESS=1',
- runutf8,
- ],
+ env: testenv,
exe_wrapper: [ python3_prog, check_file_access_prog.path() ],
)
This diff is collapsed.
Click to expand it.
community/libvirt/APKBUILD
+
6
−
2
View file @
bd5d2b32
...
...
@@ -37,6 +37,7 @@ source="https://libvirt.org/sources/libvirt-$pkgver.tar.xz
stderr-fix.patch
libvirt-fork-exec-deadlock.patch
libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch
0001-meson-Fix-compatibility-with-Meson-0.58.patch
"
if
[
"
$CARCH
"
=
"x86_64"
]
;
then
subpackages
=
"
$subpackages
$pkgname
-xen"
...
...
@@ -187,7 +188,8 @@ _common_drivers() {
"
$subpkgdir
"
/etc/libvirt/
}
sha512sums
=
"f6bb26ca7cb5a8d342f1f39afd051ed76b71414e1b934557cf50784da17e4f2fb3301c2ace3b593fcdeb6a18ad559a007ad594111c2c348b9157d3a59d475928 libvirt-7.2.0.tar.xz
sha512sums
=
"
f6bb26ca7cb5a8d342f1f39afd051ed76b71414e1b934557cf50784da17e4f2fb3301c2ace3b593fcdeb6a18ad559a007ad594111c2c348b9157d3a59d475928 libvirt-7.2.0.tar.xz
c3647366e589f2134599baefcbd7ec480cbc0830c71f95cd903cacb28e463d4cd8d972fbd1db81aa17eef81c1f701bd3937c9b8eb71d56ee630e1ed8b89887e9 libvirt.confd
95debe7600826a6783334f5bf042fde81d0a01f2c599eb8d2f66e0597cf52116c13d4d5cf173784a360d134a7c44d9bf828e8f78f7e10a1ad9dada537aead480 libvirt.initd
78f419a89de7aabaad860903c24f1c070786fc1296d987e61dd537705b0e7f71a46c315888028f3826c3417e42861ca8471788be4ec5695e98427c5f18ae63fc libvirt-guests.confd
...
...
@@ -197,4 +199,6 @@ d8ef64d76e8be521a6551893cc7c6aa7e5d8c627a9aed87beefefc126798dc0f98bf420609b6afc0
dfe042c596028125bf8548115de2922683829c4716f6b0efb8efc38518670e3e848481661b9714bb0664c1022b87e8f3c0773611fe10187b0bc588e2336ada0c musl-fix-includes.patch
d32551d56eae2c33bab7571964f76421336967918c293cd1d18fc66626a7ead3551b5672a9e3fc3d8b7bca82cc0abb17e428ee8271d04d73bc06fd16309918b3 stderr-fix.patch
ec1ff051331bee88b868275cc01a613c6b30bca6014c6dd74f0d48c40980615152497bce94b11c9f0e0644c92b937c949c3e52e023fbd865ab53c020e120cbc4 libvirt-fork-exec-deadlock.patch
dc80c9fc459207dd1ff77548054ea5a51c41a2d36e1b8917eca5f69293a86168af3da47466d8ff954a8b2e0ead9f28ed7d6c2c3671cf67d0ebb4039003a0dde2 libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch"
dc80c9fc459207dd1ff77548054ea5a51c41a2d36e1b8917eca5f69293a86168af3da47466d8ff954a8b2e0ead9f28ed7d6c2c3671cf67d0ebb4039003a0dde2 libvirt-6.0.0-fix_paths_in_libvirt-guests_sh.patch
753f2feaab0169d2866b9864cf5a605fa5257007a3726f271a97abc72d7c9449d674d00b3ba47514a073fd7bf449fbf29cb1a491a02a98d3e5373bbd01c55c43 0001-meson-Fix-compatibility-with-Meson-0.58.patch
"
This diff is collapsed.
Click to expand it.
Sören Tempel
@nmeum
mentioned in merge request
!21656 (closed)
·
3 years ago
mentioned in merge request
!21656 (closed)
mentioned in merge request !21656
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment