Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
bbd01d41
Commit
bbd01d41
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/dbus: upgrade to 1.12.24
parent
4d3e7ab1
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/dbus/APKBUILD
+10
-6
10 additions, 6 deletions
main/dbus/APKBUILD
main/dbus/avoid-opendir-between-fork-exec.patch
+0
-18
0 additions, 18 deletions
main/dbus/avoid-opendir-between-fork-exec.patch
with
10 additions
and
24 deletions
main/dbus/APKBUILD
+
10
−
6
View file @
bbd01d41
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
dbus
pkgver
=
1.12.2
0
pkgrel
=
1
pkgver
=
1.12.2
4
pkgrel
=
0
pkgdesc
=
"Freedesktop.org message bus system"
options
=
"!check"
# Introduces circular dependency with xorg-server (xvfb-run -> xvfb)
url
=
"https://www.freedesktop.org/Software/dbus"
...
...
@@ -23,11 +23,14 @@ checkdepends="xvfb-run"
install
=
"
$pkgname
.pre-install
$pkgname
.post-install"
source
=
"https://dbus.freedesktop.org/releases/dbus/dbus-
$pkgver
.tar.gz
0001-_dbus_generate_random_bytes-use-getrandom-2.patch
avoid-opendir-between-fork-exec.patch
$pkgname
.initd
"
# secfixes:
# 1.12.24-r0:
# - CVE-2022-42010
# - CVE-2022-42011
# - CVE-2022-42012
# 1.12.18-r0:
# - CVE-2020-12049
# 1.12.16-r0:
...
...
@@ -87,7 +90,8 @@ x11() {
mv
"
$pkgdir
"
/usr/bin/dbus-launch
"
$subpkgdir
"
/usr/bin/
}
sha512sums
=
"0964683bc6859374cc94e42e1ec0cdb542cca67971c205fcba4352500b6c0891665b0718e7d85eb060c81cb82e3346c313892bc02384da300ddd306c7eef0056 dbus-1.12.20.tar.gz
sha512sums
=
"
70e0b7c3f1071860b4243c945d640a1bab95fb83a7cbcf072cdd236def1310693f9bea07d406677d6673c53a6bedbdb02b51fe861aa6f686457dcfb4ee74b703 dbus-1.12.24.tar.gz
3db35499361e84d8e2469b88b033f49813b179188ac25f1841a989988c352af398a56dfd94383813626c6dfd032194f7a9fcdba001ccc3e005e7cd22dae7a7ed 0001-_dbus_generate_random_bytes-use-getrandom-2.patch
cdd01f51882be4f388515441237aa6318888db6e88a4d980bafbf9b790945e4d959c6633d6d002274c0a617ac919f9355ba628c9b502b355f73fed602f997791 avoid-opendir-between-fork-exec.patch
4c6beba2382416e60a3adfa85ef843d90d93ca5f38c23f573e058ffca6d4fc3850d11d40938c74383bba61599569b7fdfb1fcf3b9d2f1463e6b2e2cc81097c84 dbus.initd
"
4c6beba2382416e60a3adfa85ef843d90d93ca5f38c23f573e058ffca6d4fc3850d11d40938c74383bba61599569b7fdfb1fcf3b9d2f1463e6b2e2cc81097c84 dbus.initd
"
This diff is collapsed.
Click to expand it.
main/dbus/avoid-opendir-between-fork-exec.patch
deleted
100644 → 0
+
0
−
18
View file @
4d3e7ab1
Author: Rasmus Thomsen <oss@cogitri.dev>
Upstream: No
Reason: The code inside the `#ifdef __linux__` calls opendir. This can
lead to deadlocks when act_on_fds_3_and_up is called between fork&exec since
opendir mallocs which isn't async signal safe
diff --git a/dbus/dbus-sysdeps-unix.c b/dbus/dbus-sysdeps-unix.c
index 0288dbc9..e585136f 100644
--- a/dbus/dbus-sysdeps-unix.c
+++ b/dbus/dbus-sysdeps-unix.c
@@ -4742,7 +4742,7 @@
act_on_fds_3_and_up (void (*func) (int fd))
{
int maxfds, i;
-#ifdef __linux__
+#if defined(__linux__) && defined(__GLIBC__)
DIR *d;
/* On Linux we can optimize this a bit if /proc is available. If it
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment