Skip to content
Snippets Groups Projects
Commit bba165d6 authored by Hugo Wang's avatar Hugo Wang
Browse files

community/cicada: upgrade to 1.0.3

parent b7cacfb8
No related branches found
No related tags found
1 merge request!74146community/cicada: upgrade to 1.0.3
# Contributor: Hugo Wang <w@mitnk.com>
# Maintainer: Hugo Wang <w@mitnk.com>
pkgname=cicada
pkgver=1.0.2
pkgver=1.0.3
pkgrel=0
pkgdesc="A bash-like Unix shell"
url="https://github.com/mitnk/cicada"
......@@ -13,7 +13,6 @@ checkdepends="xz"
install="$pkgname.post-install $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mitnk/cicada/archive/v$pkgver.tar.gz
ulimit.patch
unbundle-sqlite.patch
"
......@@ -38,7 +37,6 @@ package() {
}
sha512sums="
a8609a73c34035463e5724c7dbad01f00c76297f6a6626d9e73f1fcf03b2629c914f5ee8ba57d677c1dacd1e7ed8b087a69b0fff988dea55000469acebd8ec4e cicada-1.0.2.tar.gz
39cfbbccb7526418746bc6d4725bf4997065ed833da5001c9778f781c065b3f19fd9983f91474010327ba3a51ebf89524c07d17045e1a1646482f13550ce53d6 ulimit.patch
6418a168e37dc4a1cb75a53aef248d63f840b6ac21beb2a2466822a846a75a0b4fa9b0a6820ed7762affa5b2814d136fcc901706f608d75c020f99b7d0a60b5e unbundle-sqlite.patch
c025f7c1816638791e9e2ca759ed1989ec5ea07b62f48246ca0c4c868aa364f8847cc73073cb7675f61c387192f0417262d83c909ffd500eebae2420af96884a cicada-1.0.3.tar.gz
1a6a9eeb4477b6d434760c1c1cda97423f71957306d8ae3e0e0dc5fd32baf4e106c95b51adedef20aa995e96f0070430bf58ee51b59143985c32c80748041986 unbundle-sqlite.patch
"
On armv7-unknown-linux-gnueabihf systems like RPi 3, The values needed are u32.
However for Alpine 32bit systems (using musl), u64 is needed.
diff --git a/src/builtins/ulimit.rs b/src/builtins/ulimit.rs
index d528e10..d72510e 100644
--- a/src/builtins/ulimit.rs
+++ b/src/builtins/ulimit.rs
@@ -79,15 +79,9 @@ fn set_limit(limit_name: &str, value: u64, for_hard: bool) -> String {
// to support armv7-unknown-linux-gnueabihf
if for_hard {
- #[cfg(target_pointer_width = "32")]
- { rlp.rlim_max = value as u32; }
- #[cfg(target_pointer_width = "64")]
- { rlp.rlim_max = value; }
+ rlp.rlim_max = value;
} else {
- #[cfg(target_pointer_width = "32")]
- { rlp.rlim_cur = value as u32; }
- #[cfg(target_pointer_width = "64")]
- { rlp.rlim_cur = value; }
+ rlp.rlim_cur = value;
}
unsafe {
diff --git a/Cargo.lock b/Cargo.lock
index 38195e9..3df98c7 100644
index 06abc96..c6fcdc1 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -410,7 +410,6 @@ version = "0.30.1"
......@@ -11,10 +11,10 @@ index 38195e9..3df98c7 100644
"vcpkg",
]
diff --git a/Cargo.toml b/Cargo.toml
index 1a06cd4..cb04d96 100644
index abcd466..8db8fda 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -47,7 +47,6 @@ features = ["std", "derive", "help"]
@@ -48,7 +48,6 @@ features = ["std", "derive", "help"]
[dependencies.rusqlite]
version = "0.32"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment