Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
bb81dd63
Commit
bb81dd63
authored
10 months ago
by
Sören Tempel
Committed by
Sören Tempel
10 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/libsurvive: add support for sciplot-0.3.0
parent
106f0bdd
No related branches found
No related tags found
1 merge request
!65398
community/libsurvive: add support for sciplot-0.3.0
Pipeline
#231833
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/libsurvive/APKBUILD
+3
-1
3 additions, 1 deletion
community/libsurvive/APKBUILD
community/libsurvive/sciplot-0.3.0.patch
+42
-0
42 additions, 0 deletions
community/libsurvive/sciplot-0.3.0.patch
with
45 additions
and
1 deletion
community/libsurvive/APKBUILD
+
3
−
1
View file @
bb81dd63
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
libsurvive
pkgname
=
libsurvive
pkgver
=
1.01
pkgver
=
1.01
pkgrel
=
4
pkgrel
=
5
pkgdesc
=
"Open Source Lighthouse Tracking System"
pkgdesc
=
"Open Source Lighthouse Tracking System"
url
=
"https://github.com/cntools/libsurvive"
url
=
"https://github.com/cntools/libsurvive"
arch
=
"all"
arch
=
"all"
...
@@ -22,6 +22,7 @@ makedepends="$depends_dev
...
@@ -22,6 +22,7 @@ makedepends="$depends_dev
subpackages
=
"
$pkgname
-static
$pkgname
-dev
$pkgname
-bash-completion
$pkgname
-web::noarch"
subpackages
=
"
$pkgname
-static
$pkgname
-dev
$pkgname
-bash-completion
$pkgname
-web::noarch"
source
=
"https://github.com/cntools/libsurvive/releases/download/v
$pkgver
/libsurvive-v
$pkgver
-source.zip
source
=
"https://github.com/cntools/libsurvive/releases/download/v
$pkgver
/libsurvive-v
$pkgver
-source.zip
off64_t.patch
off64_t.patch
sciplot-0.3.0.patch
"
"
options
=
"!check"
# Requires live test data
options
=
"!check"
# Requires live test data
builddir
=
"
$srcdir
/
$pkgname
"
builddir
=
"
$srcdir
/
$pkgname
"
...
@@ -56,4 +57,5 @@ web() {
...
@@ -56,4 +57,5 @@ web() {
sha512sums
=
"
sha512sums
=
"
6033d2524581bdefb0e1ed6e27c8044ba6ff32aa997845124c0b29d1a5a3f082a50605b2b654a642051ad0f22c6c8ad4ea8ca98888e28443d52ab68eb566effc libsurvive-v1.01-source.zip
6033d2524581bdefb0e1ed6e27c8044ba6ff32aa997845124c0b29d1a5a3f082a50605b2b654a642051ad0f22c6c8ad4ea8ca98888e28443d52ab68eb566effc libsurvive-v1.01-source.zip
35ec5f53027fcf69ce335794f5b3e01421bb9d2ffbfec571703cdd136216f3f85794774b788cccd844ca9a803a605b5d6d7124b9d49767ea0614c6b2c869791b off64_t.patch
35ec5f53027fcf69ce335794f5b3e01421bb9d2ffbfec571703cdd136216f3f85794774b788cccd844ca9a803a605b5d6d7124b9d49767ea0614c6b2c869791b off64_t.patch
c838efca5cdaabac903b435a50859232903723cc30a992755029e4c2fac3a2793f6eb866a1c95650c075c1da0ba9def917cffddb7ce10948aa213ed1cb79d8ac sciplot-0.3.0.patch
"
"
This diff is collapsed.
Click to expand it.
community/libsurvive/sciplot-0.3.0.patch
0 → 100644
+
42
−
0
View file @
bb81dd63
diff -upr libsurvive.orig/libs/cnkalman/include/cnkalman/ModelPlot.h libsurvive/libs/cnkalman/include/cnkalman/ModelPlot.h
--- libsurvive.orig/libs/cnkalman/include/cnkalman/ModelPlot.h 2024-05-04 23:56:53.101787459 +0200
+++ libsurvive/libs/cnkalman/include/cnkalman/ModelPlot.h 2024-05-04 23:57:03.865002250 +0200
@@ -13,8 +13,8 @@
namespace cnkalman {
std::string name;
int cnt = 0;
#ifdef HAS_SCIPLOT
- sciplot::Plot plot;
- sciplot::Plot map;
+ sciplot::Plot2D plot;
+ sciplot::Plot2D map;
#endif
ModelPlot(const std::string &name = "plot", bool show = false);
diff -upr libsurvive.orig/libs/cnkalman/src/ModelPlot.cc libsurvive/libs/cnkalman/src/ModelPlot.cc
--- libsurvive.orig/libs/cnkalman/src/ModelPlot.cc 2024-05-04 23:56:53.105123856 +0200
+++ libsurvive/libs/cnkalman/src/ModelPlot.cc 2024-05-04 23:58:30.067476028 +0200
@@ -62,13 +62,19 @@
namespace cnkalman {
map.xrange(range[0], range[1]);
map.yrange(range[2], range[3]);
+ sciplot::Figure plot_fig = {{plot}};
+ sciplot::Canvas plot_canvas = {{plot_fig}};
+ sciplot::Figure map_fig = {{map}};
+ sciplot::Canvas map_canvas = {{map_fig}};
+
if (show) {
- plot.show();
- map.show();
+ plot_canvas.show();
+ map_canvas.show();
}
- plot.save(name + "-plot.svg");
- map.save(name + ".svg");
- map.save(name + ".png");
+
+ plot_canvas.save(name + "-plot.svg");
+ map_canvas.save(name + ".svg");
+ map_canvas.save(name + ".png");
#endif
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment