Skip to content
Snippets Groups Projects
Commit ba01e78d authored by Rasmus Thomsen's avatar Rasmus Thomsen
Browse files

community/cogl: upgrade to 1.22.8

parent eb57e5df
No related branches found
No related tags found
3 merge requests!11958community/rclone: upgrade to 1.52.3,!9763[3.12] community/znc: upgrade to 1.8.1,!8860community/cogl: upgrade to 1.22.8
Upstream: Yes, https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
From 9c4764224aded552fb855b1c2b85b26d2b894adf Mon Sep 17 00:00:00 2001
From: Alexander Tsoy <alexander@tsoy.me>
Date: Tue, 29 Oct 2019 18:17:51 +0300
Subject: [PATCH] Fix building against libglvnd-provided EGL headers
Add missing EGL/eglmesaext.h include. When building against mesa-provided
headers, this header is included indirectly via EGL/eglext.h.
Also fix typo COGL_EGL_INCLUDE -> COGL_EGL_INCLUDES
---
configure.ac | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index da188edd..b0b0c94d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -670,10 +670,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
AC_SUBST([COGL_EGL_INCLUDES])
AC_CHECK_HEADERS([EGL/eglext.h],
- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
#include <EGL/eglext.h>"],
[],
[$COGL_EGL_INCLUDES])
+ AC_CHECK_HEADERS([EGL/eglmesaext.h],
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
+#include <EGL/eglmesaext.h>"],
+ [],
+ [$COGL_EGL_INCLUDES])
# Check for a GLES 1.x Common Profile library with/without EGL.
#
@@ -1178,6 +1183,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
[],
[AC_MSG_ERROR([Unable to locate required EGL headers])],
[#include <EGL/egl.h>])
+ AC_CHECK_HEADERS(
+ [EGL/eglmesaext.h],
+ [],
+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
+ [#include <EGL/egl.h>
+#include <EGL/eglext.h>])
AC_CHECK_LIB(EGL, [eglInitialize],
[COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
@@ -1188,7 +1199,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
)
COGL_EGL_INCLUDES="#include <EGL/egl.h>
-#include <EGL/eglext.h>"
+#include <EGL/eglext.h>
+#include <EGL/eglmesaext.h>"
AC_SUBST([COGL_EGL_INCLUDES])
])
--
2.24.1
......@@ -3,7 +3,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=cogl
pkgver=1.22.6
pkgver=1.22.8
pkgrel=0
pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer"
options="!check" # All tests fail for unknown reasons
......@@ -28,8 +28,7 @@ makedepends="
# gst-plugins-base-dev
# "
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz
17.patch"
source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz"
prepare() {
default_prepare
......@@ -62,5 +61,4 @@ package() {
make DESTDIR="$pkgdir" install
}
sha512sums="b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483 cogl-1.22.6.tar.xz
5320cfe16eaa419aac155d86f77826076b3dfe3a018d7173220c35ba2f1a4f15254bab7336229349aa25e708f0792132572d166de5745992a4e98f662b6df0fc 17.patch"
sha512sums="702d5b1b22dc34bffaa82c9c57021caf036ee3a13fa7ca24a90cca1ebc0f8b7a86070cc1fe5125757132b02774fa874bb55675c96d1ccbc233fac0e6132da65f cogl-1.22.8.tar.xz"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment