Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
b902c5bd
Commit
b902c5bd
authored
7 years ago
by
A. Wilcox
Committed by
Ariadne Conill
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/strace: add check, fix license
parent
5fae44da
Loading
Loading
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
main/strace/APKBUILD
+13
-3
13 additions, 3 deletions
main/strace/APKBUILD
main/strace/disable-fortify.patch
+39
-0
39 additions, 0 deletions
main/strace/disable-fortify.patch
main/strace/nlattr-fix.patch
+21
-0
21 additions, 0 deletions
main/strace/nlattr-fix.patch
with
73 additions
and
3 deletions
main/strace/APKBUILD
+
13
−
3
View file @
b902c5bd
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
strace
pkgver
=
4.19
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"A useful diagnositic, instructional, and debugging tool"
url
=
"https://strace.io/"
arch
=
"all"
license
=
"BSD"
options
=
"!checkroot"
license
=
"BSD-3-Clause"
depends
=
""
makedepends
=
"linux-headers autoconf automake"
subpackages
=
"
$pkgname
-doc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/strace/
$pkgname
/archive/v
$pkgver
.tar.gz
disable-fortify.patch
fix-ppc-pt-regs-collision.patch
nlattr-fix.patch
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
...
@@ -45,10 +48,17 @@ build() {
make
}
check
()
{
cd
"
$builddir
"
make check
}
package
()
{
cd
"
$builddir
"
make
-j1
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"fbf953d64b43785648e2df0eb6beee409c6b6f6c6a4d227b54c02a049031c5ff3a3a6af52a68a2980d89eb06dcafc36be5f8784728e9a28348145cdb4a7764f9 strace-4.19.tar.gz
b70cee89dd49a2b5a69dc2a56c3a11169d3306e1a73981155188b574486965c034aa52b4ac1c6edff5ef55c9d52f27750acb242fac095a8a9f69689b51b3fad1 fix-ppc-pt-regs-collision.patch"
273b92ebf0069f19bef7ec26c7860e2af7ef01e782255c70ded1ae5e967f8f6bf031ecba96612c6083bf58f46278ba4ab3ec0fb35b08c8c8d668191f97adee52 disable-fortify.patch
b70cee89dd49a2b5a69dc2a56c3a11169d3306e1a73981155188b574486965c034aa52b4ac1c6edff5ef55c9d52f27750acb242fac095a8a9f69689b51b3fad1 fix-ppc-pt-regs-collision.patch
44b1872cf996caa4970fa6c2875a3a2cffe4a38455e328d968bd7855ef9a05cf41190794dc137bc8667576635f5271057cf0e6cde9a6c7aee66afd1dba9bdba0 nlattr-fix.patch"
This diff is collapsed.
Click to expand it.
main/strace/disable-fortify.patch
0 → 100644
+
39
−
0
View file @
b902c5bd
Subject: [PATCH] don't use fortify-headers on netlink test sources
From: A. Wilcox <AWilcox@Wilcox-Tech.com>
We can't use fortify-headers on netlink tests because it tests what happens
when a buffer overrun occurs.
--- strace-4.18/tests/netlink_protocol.c.old 2017-07-05 07:08:09.000000000 +0000
+++ strace-4.18/tests/netlink_protocol.c 2017-08-17 01:09:45.822502012 +0000
@@ -28,6 +28,8 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
+#define _FORTIFY_SOURCE 0
+
#include "tests.h"
#ifdef HAVE_SYS_XATTR_H
--- strace-4.18/tests/netlink_sock_diag.c.old 2017-07-05 07:08:09.000000000 +0000
+++ strace-4.18/tests/netlink_sock_diag.c 2017-08-17 01:10:00.935807300 +0000
@@ -27,6 +27,8 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
+#define _FORTIFY_SOURCE 0
+
#include "tests.h"
#include <stdio.h>
#include <string.h>
--- strace-4.18/tests/nlattr.c.old 2017-07-05 07:08:09.000000000 +0000
+++ strace-4.18/tests/nlattr.c 2017-08-17 01:10:11.862453682 +0000
@@ -28,6 +28,8 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
+#define _FORTIFY_SOURCE 0
+
#include "tests.h"
#include <stdio.h>
This diff is collapsed.
Click to expand it.
main/strace/nlattr-fix.patch
0 → 100644
+
21
−
0
View file @
b902c5bd
--- strace-4.18/tests/nlattr.c.old 2017-07-05 07:08:09.000000000 +0000
+++ strace-4.18/tests/nlattr.c 2017-08-17 00:25:26.734218699 +0000
@@ -61,7 +61,7 @@
};
struct msg *msg;
struct nlattr *nla;
- unsigned int msg_len;
+ uint32_t msg_len;
long rc;
/* fetch fail: len < sizeof(struct nlattr) */
@@ -259,7 +259,7 @@
};
struct msg *msg;
struct nlattr *nla;
- unsigned int msg_len;
+ uint32_t msg_len;
long rc;
msg_len = NLMSG_SPACE(sizeof(msg->udm)) + sizeof(*nla);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment