Skip to content
Snippets Groups Projects
Commit b4c8e84f authored by Taras Zaporozhets's avatar Taras Zaporozhets Committed by Leo
Browse files

testing/openv2g: fix library build

* add missing SONAME
* fix headers installation
* bump pkgrel
parent 25617bb7
No related branches found
No related tags found
1 merge request!16713testing/openv2g: fix openv2g libary
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
# Maintainer: Olliver Schinagl <oliver@schinagl.nl> # Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=openv2g pkgname=openv2g
pkgver=0.9.4 pkgver=0.9.4
pkgrel=3 pkgrel=4
pkgdesc="Implements ISO IEC 15118 and also the DIN 70121 vehicle to grid (V2G) communication interface" pkgdesc="Implements ISO IEC 15118 and also the DIN 70121 vehicle to grid (V2G) communication interface"
url="https://openv2g.org/" url="https://openv2g.org/"
arch="all" arch="all"
...@@ -45,6 +45,6 @@ package() { ...@@ -45,6 +45,6 @@ package() {
sha512sums="0d055188801e0724b78f935bd3de72ad7b673dab894577f255eb895a4871f1e775476adf6c55427c293e85f488140cad51d7ce85a626dbba6bb87c96a3866064 0001-Enable-XMLDSIG-codec-support.patch sha512sums="0d055188801e0724b78f935bd3de72ad7b673dab894577f255eb895a4871f1e775476adf6c55427c293e85f488140cad51d7ce85a626dbba6bb87c96a3866064 0001-Enable-XMLDSIG-codec-support.patch
6737110c91830f9d93fbce1cc54a73d0a86d12ddefb69cbe1a91ffdb478626b0aa8d0ccdc3392fd2213747a5eef5da948a0249e9e3c8844953d36118dc28425c 0002-Violate-the-spec-less-by-downgrading-to-ASCII-for-UT.patch 6737110c91830f9d93fbce1cc54a73d0a86d12ddefb69cbe1a91ffdb478626b0aa8d0ccdc3392fd2213747a5eef5da948a0249e9e3c8844953d36118dc28425c 0002-Violate-the-spec-less-by-downgrading-to-ASCII-for-UT.patch
5c4e8df3033a9ebed412a004efdb812528e3d7c7e8d126dc1a1139c106391eeba58a7b13f88a21d4addd176b6f65dee3d1e2243cb46177628c5dd2b6e3f59f33 makefiles.patch d19033d7a42503c11e8d59518896a14d31da0aed2f60707e6eaafe72cc818a4650c2001989a8f260b0656f6271a4c044e109bac8af419b9d0ef5c87924eb372f makefiles.patch
94d1f15c33ae7327d76320d5ba35febd6068393e70667729953edfc3a54eb1dc91513bec8abf11b14b53154594746123cca8db00cb31d5a5d139b38054d8a986 openv2g.pc.in 94d1f15c33ae7327d76320d5ba35febd6068393e70667729953edfc3a54eb1dc91513bec8abf11b14b53154594746123cca8db00cb31d5a5d139b38054d8a986 openv2g.pc.in
0fe088bc3ae0f0dc6af8c9c3a989301e5e155a9406b80cb9025ceb5b548dc94202dde37993711c589fac6eddf626897c7ef003b73e01cb1c5b20b7b73365b930 openv2g-0.9.4.zip" 0fe088bc3ae0f0dc6af8c9c3a989301e5e155a9406b80cb9025ceb5b548dc94202dde37993711c589fac6eddf626897c7ef003b73e01cb1c5b20b7b73365b930 openv2g-0.9.4.zip"
...@@ -10,7 +10,7 @@ index f30e46e..2cd455f 100644 ...@@ -10,7 +10,7 @@ index f30e46e..2cd455f 100644
# All of the sources participating in the build are defined here # All of the sources participating in the build are defined here
-include sources.mk -include sources.mk
@@ -30,19 +31,62 @@ endif @@ -30,19 +31,58 @@ endif
# Add inputs and outputs from these tool invocations to the build variables # Add inputs and outputs from these tool invocations to the build variables
# All Target # All Target
...@@ -25,7 +25,7 @@ index f30e46e..2cd455f 100644 ...@@ -25,7 +25,7 @@ index f30e46e..2cd455f 100644
- gcc -o "OpenV2G.exe" $(OBJS) $(USER_OBJS) $(LIBS) - gcc -o "OpenV2G.exe" $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'objs: $(OBJS) userobjs: $(USER_OBJS) libs: $(LIBS)' + @echo 'objs: $(OBJS) userobjs: $(USER_OBJS) libs: $(LIBS)'
+ ar rcs 'libopenv2g.a' $(OBJS) $(USER_OBJS) + ar rcs 'libopenv2g.a' $(OBJS) $(USER_OBJS)
+ gcc -shared -o 'libopenv2g.so' $(OBJS) $(USER_OBJS) $(LIBS) + gcc -shared -Wl,-soname,libopenv2g.so.0 -o 'libopenv2g.so' $(OBJS) $(USER_OBJS) $(LIBS)
+ gcc -o 'openv2g' $(BIN_OBJS) $(OBJS) $(USER_OBJS) $(LIBS) + gcc -o 'openv2g' $(BIN_OBJS) $(OBJS) $(USER_OBJS) $(LIBS)
@echo 'Finished building target: $@' @echo 'Finished building target: $@'
@echo ' ' @echo ' '
...@@ -36,11 +36,10 @@ index f30e46e..2cd455f 100644 ...@@ -36,11 +36,10 @@ index f30e46e..2cd455f 100644
+ @ln -s 'libopenv2g.so.0.9.4' '$(DESTDIR)/lib/libopenv2g.so.0' + @ln -s 'libopenv2g.so.0.9.4' '$(DESTDIR)/lib/libopenv2g.so.0'
+ @ln -s 'libopenv2g.so.0' '$(DESTDIR)/lib/libopenv2g.so' + @ln -s 'libopenv2g.so.0' '$(DESTDIR)/lib/libopenv2g.so'
+ @install -D -m 644 -t '$(DESTDIR)/lib' 'libopenv2g.a' + @install -D -m 644 -t '$(DESTDIR)/lib' 'libopenv2g.a'
+ @install -D -m 644 -t '$(DESTDIR)/include/openv2g/appHandshake' \ + @install -D -m 644 -t '$(DESTDIR)/include/openv2g' \
+ ../src/appHandshake/appHandEXIDatatypes.h \ + ../src/appHandshake/appHandEXIDatatypes.h \
+ ../src/appHandshake/appHandEXIDatatypesDecoder.h \ + ../src/appHandshake/appHandEXIDatatypesDecoder.h \
+ ../src/appHandshake/appHandEXIDatatypesEncoder.h + ../src/appHandshake/appHandEXIDatatypesEncoder.h \
+ @install -D -m 644 -t '$(DESTDIR)/include/openv2g/codec' \
+ ../src/codec/BitInputStream.h \ + ../src/codec/BitInputStream.h \
+ ../src/codec/BitOutputStream.h \ + ../src/codec/BitOutputStream.h \
+ ../src/codec/ByteStream.h \ + ../src/codec/ByteStream.h \
...@@ -52,8 +51,7 @@ index f30e46e..2cd455f 100644 ...@@ -52,8 +51,7 @@ index f30e46e..2cd455f 100644
+ ../src/codec/EXITypes.h \ + ../src/codec/EXITypes.h \
+ ../src/codec/EncoderChannel.h \ + ../src/codec/EncoderChannel.h \
+ ../src/codec/ErrorCodes.h \ + ../src/codec/ErrorCodes.h \
+ ../src/codec/MethodsBag.h + ../src/codec/MethodsBag.h \
+ @install -D -m 644 -t '$(DESTDIR)/include/openv2g/din' \
+ ../src/din/dinEXIDatatypes.h \ + ../src/din/dinEXIDatatypes.h \
+ ../src/din/dinEXIDatatypesDecoder.h \ + ../src/din/dinEXIDatatypesDecoder.h \
+ ../src/din/dinEXIDatatypesEncoder.h \ + ../src/din/dinEXIDatatypesEncoder.h \
...@@ -62,10 +60,8 @@ index f30e46e..2cd455f 100644 ...@@ -62,10 +60,8 @@ index f30e46e..2cd455f 100644
+ ../src/iso1/iso1EXIDatatypesEncoder.h \ + ../src/iso1/iso1EXIDatatypesEncoder.h \
+ ../src/iso2/iso2EXIDatatypes.h \ + ../src/iso2/iso2EXIDatatypes.h \
+ ../src/iso2/iso2EXIDatatypesDecoder.h \ + ../src/iso2/iso2EXIDatatypesDecoder.h \
+ ../src/iso2/iso2EXIDatatypesEncoder.h + ../src/iso2/iso2EXIDatatypesEncoder.h \
+ @install -D -m 644 -t '$(DESTDIR)/include/openv2g/transport' \ + ../src/transport/v2gtp.h \
+ ../src/transport/v2gtp.h
+ @install -D -m 644 -t '$(DESTDIR)/include/openv2g/xmldsig' \
+ ../src/xmldsig/xmldsigEXIDatatypes.h \ + ../src/xmldsig/xmldsigEXIDatatypes.h \
+ ../src/xmldsig/xmldsigEXIDatatypesDecoder.h \ + ../src/xmldsig/xmldsigEXIDatatypesDecoder.h \
+ ../src/xmldsig/xmldsigEXIDatatypesEncoder.h + ../src/xmldsig/xmldsigEXIDatatypesEncoder.h
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment