Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
b2c5b5e6
Commit
b2c5b5e6
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/sipp: upgrade to 3.7.0
parent
1d066f32
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
main/sipp/APKBUILD
+6
-10
6 additions, 10 deletions
main/sipp/APKBUILD
main/sipp/gtest.patch
+15
-0
15 additions, 0 deletions
main/sipp/gtest.patch
main/sipp/libtinfo.patch
+9
-9
9 additions, 9 deletions
main/sipp/libtinfo.patch
with
30 additions
and
19 deletions
main/sipp/APKBUILD
+
6
−
10
View file @
b2c5b5e6
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Contributor: Robert Boisvert <rdboisvert@gmail.com>
# Contributor: Robert Boisvert <rdboisvert@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname
=
sipp
pkgname
=
sipp
pkgver
=
3.
6.1
pkgver
=
3.
7.0
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"A test tool / traffic generator for the SIP protocol"
pkgdesc
=
"A test tool / traffic generator for the SIP protocol"
url
=
"https://github.com/SIPp/sipp"
url
=
"https://github.com/SIPp/sipp"
...
@@ -18,15 +18,10 @@ makedepends="
...
@@ -18,15 +18,10 @@ makedepends="
samurai
samurai
"
"
source
=
"https://github.com/SIPp/sipp/releases/download/v
$pkgver
/sipp-
$pkgver
.tar.gz
source
=
"https://github.com/SIPp/sipp/releases/download/v
$pkgver
/sipp-
$pkgver
.tar.gz
gtest.patch
libtinfo.patch
libtinfo.patch
"
"
options
=
"!check"
# no tests
options
=
"!check"
# tests have no direct target
prepare
()
{
default_prepare
mv
version.h include/
}
build
()
{
build
()
{
cmake
-B
build
-G
Ninja
-Wno-dev
\
cmake
-B
build
-G
Ninja
-Wno-dev
\
...
@@ -45,6 +40,7 @@ package() {
...
@@ -45,6 +40,7 @@ package() {
}
}
sha512sums
=
"
sha512sums
=
"
58504c56ca0c14363fafc5d0598fd93857ef33cc5856f579a225fd0e38238f7d2c409127a18a368e22355cc3912758d4dba07bac7eaa3e8a0d2943ea5fdec602 sipp-3.6.1.tar.gz
a4c6d4ca3b7871e47f05a7bd0ddc3ab30dee567128f1db87fc55a29c58fbdb07c504321a1155f20a9b4f13c3735abda02977d81ac06bfd32d4750f91de8c1339 sipp-3.7.0.tar.gz
5c1362ad7e68647e2e95f1c5d0af03caa09600fecdb49eab9c41f0f053fbb663b4a3d6a203b603aa6dee35d30749589ec790e416822ef9b0415a65b9af8b9131 libtinfo.patch
12857e01710d7faec565de7394286c44750c8748ec512a9597d89a045ab846f29b07cd905729fa3baab9c0f4a88462e00a48be788c4f5ba48e47f16c474483d1 gtest.patch
92b62f605b92a81ed56ba3f992d126ee70b06f3b08d5c30a3a6614f0844d6ebf1d9e0094ac93dd8c80271414ff414b3efb22117ab2c8eb5ff76fc49327a1dea0 libtinfo.patch
"
"
This diff is collapsed.
Click to expand it.
main/sipp/gtest.patch
0 → 100644
+
15
−
0
View file @
b2c5b5e6
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ef0cf9..1c8329e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,9 +127,8 @@
target_compile_features(sipp PUBLIC cxx_auto_type cxx_range_for)
add_executable(sipp_unittest EXCLUDE_FROM_ALL
${all_SRCS}
"${PROJECT_SOURCE_DIR}/src/sipp_unittest.cpp"
- "${PROJECT_SOURCE_DIR}/gtest/googletest/src/gtest-all.cc"
- "${PROJECT_SOURCE_DIR}/gtest/googlemock/src/gmock-all.cc"
)
+target_link_libraries(sipp_unittest gtest gmock)
target_compile_features(sipp_unittest PUBLIC cxx_auto_type cxx_range_for)
target_compile_definitions(sipp_unittest PUBLIC "-DGTEST")
target_include_directories(sipp_unittest SYSTEM PUBLIC
This diff is collapsed.
Click to expand it.
main/sipp/libtinfo.patch
+
9
−
9
View file @
b2c5b5e6
diff --git a/CMakeLists.txt b/CMakeLists.txt
diff --git a/CMakeLists.txt b/CMakeLists.txt
index
7c4257e..4976b47
100644
index
9ef0cf9..1ac7131
100644
--- a/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,7 +136,7 @@
if(CURSES_LIBRARY)
@@ -180,7 +180,7 @@
endif()
if(CURSES_LIBRARY)
target_link_libraries(sipp dl ${CURSES_LIBRARY} pthread)
target_link_libraries(sipp dl ${CURSES_LIBRARY} pthread)
target_link_libraries(sipp_unittest dl ${CURSES_LIBRARY} pthread gtest gmock)
target_link_libraries(sipp_unittest dl ${CURSES_LIBRARY} pthread)
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- if(NOT BUILD_STATIC)
+ if(false)
+ if(false)
if(TINFO_LIBRARY)
if(TINFO_LIBRARY)
target_link_libraries(sipp ${TINFO_LIBRARY})
target_link_libraries(sipp dl ${TINFO_LIBRARY})
target_link_libraries(sipp_unittest ${TINFO_LIBRARY})
target_link_libraries(sipp_unittest dl ${TINFO_LIBRARY})
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment