Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
ae8adcb8
Commit
ae8adcb8
authored
6 years ago
by
Timo Teräs
Browse files
Options
Downloads
Patches
Plain Diff
main/xf86-video-intel: fix build on x86
parent
f0acfebf
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/xf86-video-intel/APKBUILD
+4
-2
4 additions, 2 deletions
main/xf86-video-intel/APKBUILD
main/xf86-video-intel/fix-build-on-i686.patch
+49
-0
49 additions, 0 deletions
main/xf86-video-intel/fix-build-on-i686.patch
with
53 additions
and
2 deletions
main/xf86-video-intel/APKBUILD
+
4
−
2
View file @
ae8adcb8
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
xf86-video-intel
pkgver
=
2.99.917_git20170325
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"X.Org driver for Intel cards"
url
=
"https://xorg.freedesktop.org"
arch
=
"x86 x86_64"
...
...
@@ -14,6 +14,7 @@ makedepends="xorg-server-dev libxi-dev libdrm-dev mesa-dev libxvmc-dev
_ver
=
${
pkgver
%_git*
}
source
=
"https://www.x.org/releases/individual/driver/
$pkgname
-
$_ver
.tar.bz2
git.patch
fix-build-on-i686.patch
"
builddir
=
"
$srcdir
"
/
$pkgname
-
$_ver
...
...
@@ -50,4 +51,5 @@ package() {
chmod
o-x
"
$pkgdir
"
/usr/libexec/xf86-video-intel-backlight-helper
}
sha512sums
=
"cbf4d46ad1ad5e5587c0f1f620ff534ef0645270517b60056b9f03e83d8216e2f456de46352a06c37c0c46963cc4ed20b71b815b20ec1bf680ff046e535f580f xf86-video-intel-2.99.917.tar.bz2
0fe4e455dcbc4ae6622dca483ef3ddc765c43009fdb0fef82bdaa835a737796a6caf8afa9c6630919f43c977a6f736770c3779f04d8c823da4fc9cee17d16f19 git.patch"
0fe4e455dcbc4ae6622dca483ef3ddc765c43009fdb0fef82bdaa835a737796a6caf8afa9c6630919f43c977a6f736770c3779f04d8c823da4fc9cee17d16f19 git.patch
289930c10ba0278d6dde544311ca4381bdcc046e15b2abf3d17b7eb1a7ab8f54274b40f95fe6143aee5d02cc07aea7560dd1d4e3b0e9deca9f8334a56b287e1b fix-build-on-i686.patch"
This diff is collapsed.
Click to expand it.
main/xf86-video-intel/fix-build-on-i686.patch
0 → 100644
+
49
−
0
View file @
ae8adcb8
From a414d4e24461da1cb4cef8ee910bc57bab360ceb Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Tue, 6 Mar 2018 12:07:46 -0500
Subject: [PATCH] Fix build on i686
Presumably this only matters for i686 because amd64 implies sse2, but:
BUILDSTDERR: In file included from gen4_vertex.c:34:
BUILDSTDERR: gen4_vertex.c: In function 'emit_vertex':
BUILDSTDERR: sna_render_inline.h:40:26: error: inlining failed in call to always_inline 'vertex_emit_2s': target specific option mismatch
BUILDSTDERR: static force_inline void vertex_emit_2s(struct sna *sna, int16_t x, int16_t y)
BUILDSTDERR: ^~~~~~~~~~~~~~
BUILDSTDERR: gen4_vertex.c:308:25: note: called from here
BUILDSTDERR: #define OUT_VERTEX(x,y) vertex_emit_2s(sna, x,y) /* XXX assert(!too_large(x, y)); */
BUILDSTDERR: ^~~~~~~~~~~~~~~~~~~~~~~~
BUILDSTDERR: gen4_vertex.c:360:2: note: in expansion of macro 'OUT_VERTEX'
BUILDSTDERR: OUT_VERTEX(dstX, dstY);
BUILDSTDERR: ^~~~~~~~~~
The bug here appears to be that emit_vertex() is declared 'sse2' but
vertex_emit_2s is merely always_inline. gcc8 decides that since you said
always_inline you need to have explicitly cloned it for every
permutation of targets. Merely saying inline seems to do the job of
cloning vertex_emit_2s as much as necessary.
So to reiterate: if you say always-inline, it won't, but if you just say
maybe inline, it will. Thanks gcc, that's helpful.
- ajax
---
src/sna/compiler.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/sna/compiler.h b/src/sna/compiler.h
index 3c176a16..bc447c7a 100644
--- a/src/sna/compiler.h
+++ b/src/sna/compiler.h
@@ -32,7 +32,7 @@
#define likely(expr) (__builtin_expect (!!(expr), 1))
#define unlikely(expr) (__builtin_expect (!!(expr), 0))
#define noinline __attribute__((noinline))
-#define force_inline inline __attribute__((always_inline))
+#define force_inline inline
#define fastcall __attribute__((regparm(3)))
#define must_check __attribute__((warn_unused_result))
#define constant __attribute__((const))
--
2.16.2
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment