Skip to content
Snippets Groups Projects
Commit ae0512e6 authored by Patrycja Rosa's avatar Patrycja Rosa :cat: Committed by alice
Browse files

community/py3-lark-parser: upgrade to 1.1.7

parent f3884b2f
No related branches found
No related tags found
1 merge request!49010community/py3-lark-parser: upgrade to 1.1.7
Pipeline #171163 skipped
# Contributor: Russ Webber <russ@rw.id.au> # Contributor: Russ Webber <russ@rw.id.au>
# Maintainer: Russ Webber <russ@rw.id.au> # Maintainer: Russ Webber <russ@rw.id.au>
pkgname=py3-lark-parser pkgname=py3-lark-parser
pkgver=1.1.5 pkgver=1.1.7
pkgrel=0 pkgrel=0
pkgdesc="modern parsing library for Python, implementing Earley & LALR(1) and an easy interface" pkgdesc="modern parsing library for Python, implementing Earley & LALR(1) and an easy interface"
url="https://github.com/lark-parser/lark" url="https://github.com/lark-parser/lark"
...@@ -9,23 +9,31 @@ arch="noarch" ...@@ -9,23 +9,31 @@ arch="noarch"
license="MIT" license="MIT"
options="!check" # requires python dependency js2py options="!check" # requires python dependency js2py
depends="python3" depends="python3"
makedepends="py3-setuptools" makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
subpackages="$pkgname-pyc" subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lark-parser/lark/archive/$pkgver.tar.gz" source="$pkgname-$pkgver.tar.gz::https://github.com/lark-parser/lark/archive/$pkgver.tar.gz
package-data.patch
"
builddir="$srcdir/lark-$pkgver" builddir="$srcdir/lark-$pkgver"
build() { build() {
python3 setup.py build gpep517 build-wheel \
--wheel-dir .dist \
--output-fd 3 3>&1 >&2
} }
check() { check() {
python3 setup.py test python3 -m venv --clear --without-pip --system-site-packages .testenv
.testenv/bin/python3 -m installer .dist/*.whl
.testenv/bin/python3 -m pytest
} }
package() { package() {
python3 setup.py install --skip-build --root="$pkgdir" python3 -m installer -d "$pkgdir" \
.dist/*.whl
} }
sha512sums=" sha512sums="
bf9a9892eb5e6da4c8129b4c23c5663d7cb1feaf947db629fe97887093eb6e51de59f2078422611af4eeef5c548cd63c86132970412609a95288d0df7c01c0a6 py3-lark-parser-1.1.5.tar.gz 83c8acc147d9649762b1300d19f0819e61dfd4756c81eb973e2c6e82dcf887daef03fe47fb490f8135c806aeb3abb7d0322132f72e472ee71b54b09a3581826b py3-lark-parser-1.1.7.tar.gz
97dae149e19e37f00ca35b5b2569924194432dc3c661d3e14a3851f771569e7bd57e3f4caa9a045c92b75c422188d059085b93576070f2a1af68a7d94138c53e package-data.patch
" "
diff --git a/pyproject.toml b/pyproject.toml
index d49a9f6..fa9b5c6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -68,6 +68,7 @@ packages = [
include-package-data = true
[tool.setuptools.package-data]
+"*" = ["*.lark"]
lark = ["py.typed"]
[tool.setuptools.dynamic]
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment