Skip to content
Snippets Groups Projects
Commit a82cb13a authored by TBK's avatar TBK Committed by Leo
Browse files

testing/debconf: upgrade to 1.5.73

parent 33ea734e
No related merge requests found
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=debconf
pkgver=1.5.71
pkgver=1.5.73
pkgrel=0
pkgdesc="A configuration management system for Debian packages."
url="https://packages.debian.org/debconf"
......@@ -9,17 +9,22 @@ arch="noarch"
license="BSD-2-Clause"
options="!check" # Test suite is broken. CopyDBTestSetup is missing new method
depends="perl"
makedepends="coreutils findutils po4a"
makedepends="coreutils diffutils findutils po4a"
checkdepends="perl-freezethaw perl-ldap perl-test-unit"
subpackages="$pkgname-doc $pkgname-lang $pkgname-utils $pkgname-bash-completion:bashcomp:noarch"
source="https://deb.debian.org/debian/pool/main/d/debconf/debconf_$pkgver.tar.xz
fix-makefile_destdir.patch
"
builddir="$srcdir/$pkgname"
builddir="$srcdir/work"
build() {
make
}
check() {
./test_debconf.pl --all
}
package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install-i18n install-doc install-rest
}
......@@ -44,5 +49,5 @@ bashcomp() {
ln -s debconf debconf-show
}
sha512sums="ec6115a6aea78233e28f932f3eb6af62576b55211187a4253791c540ac74629029af01d95b5b382d01d51e1ae218760188a1eb865c04cc4d59a0006d8aa4c45b debconf_1.5.71.tar.xz
86c8c0995921a15b67881a7f68f8db4fc785ebc05a03619f597bd71e3cfb628c0c5678b263d42715eded50c3c8b80a7e49a9671949a5f423936fc8801b262b9a fix-makefile_destdir.patch"
sha512sums="fa2e240842f4f020df031ef37803c22a680372b996302372dfd3377bf21723f2e949167f9ea13ebad5c1c516052c26adcd627d152a62110ccddd3a9e2b892bdc debconf_1.5.73.tar.xz
17094b77ccf7922daf28dbf2eba84a322ac8ca265a41403b963d97ea4c1c16d8e530bcb3414f9b1bca88cbc5f726d2401376ee20674547d7b528c52d8f496f8c fix-makefile_destdir.patch"
......@@ -5,7 +5,7 @@
MUNGE=xargs perl -i.bak -ne ' \
print $$_."\# This file was preprocessed, do not edit!\n" \
if m:^\#!/usr/bin/perl:; \
@@ -24,20 +25,24 @@
@@ -24,60 +25,64 @@
# Anything that goes in the debconf-utils package.
install-utils:
......@@ -14,11 +14,11 @@
find . -maxdepth 1 -perm /100 -type f -name 'debconf-*' | grep -v debconf-set-selections | grep -v debconf-show | grep -v debconf-copydb | grep -v debconf-communicate | grep -v debconf-apt-progress | grep -v debconf-escape | \
- xargs -i install {} $(prefix)/usr/bin
+ xargs -i install {} $(DESTDIR)$(PREFIX)/bin
+
+# Installs only english man pages
+install-doc:
+ $(MAKE) -C doc PREFIX=$(PREFIX) DESTDIR=$(DESTDIR) install
+
# Anything that goes in the debconf-i18n package.
install-i18n:
- $(MAKE) -C po install
......@@ -27,15 +27,6 @@
PERL := perl
PERL_VENDORLIB := $(shell $(PERL) -MConfig -e 'print $$Config{vendorlib}')
# This would probably be easier if we used setup.py ...
PYTHON2_SUPPORTED := $(shell pyversions -s)
-PYTHON_SITEDIR = $(prefix)/usr/lib/$(1)/$(if $(filter 2.0 2.1 2.2 2.3 2.4 2.5,$(patsubst python%,%,$(1))),site-packages,dist-packages)
+PYTHON_SITEDIR = $(DESTDIR)$(PREFIX)/lib/$(1)/$(if $(filter 2.0 2.1 2.2 2.3 2.4 2.5,$(patsubst python%,%,$(1))),site-packages,dist-packages)
# The Python 2 package.
install-python2:
@@ -48,47 +53,47 @@
# The Python 3 package.
install-python3:
- install -d $(prefix)/usr/lib/python3/dist-packages
......@@ -94,13 +85,11 @@
- find $(prefix)/$(PERL_VENDORLIB)/ $(prefix)/usr/sbin \
- $(prefix)/usr/share/debconf/frontend \
- $(prefix)/usr/share/debconf/*.pl $(prefix)/usr/bin \
- -name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
- -name 'debconf-*' -or -name 'frontend' | \
+ find $(DESTDIR)/$(PERL_VENDORLIB)/ $(DESTDIR)$(PREFIX)/sbin \
+ $(DESTDIR)$(PREFIX)/share/debconf/frontend \
+ find $(DESTDIR)/$(PERL_VENDORLIB)/ $(DESTDIR)$(PREFIX)/sbin \
+ $(DESTDIR)$(PREFIX)/share/debconf/frontend \
+ $(DESTDIR)$(PREFIX)/share/debconf/*.pl $(DESTDIR)$(PREFIX)/bin \
+ -name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
+ -name 'debconf-*' -or -name 'frontend' | \
-name '*.pl' -or -name '*.pm' -or -name 'dpkg-*' -or \
-name 'debconf-*' -or -name 'frontend' | \
grep -v Client/ConfModule | $(MUNGE)
- find $(prefix) -name '*.bak' | xargs rm -f
+ find $(DESTDIR) -name '*.bak' | xargs rm -f
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment