Skip to content
Snippets Groups Projects
Commit a803e4ce authored by J. Neuschäfer's avatar J. Neuschäfer Committed by Natanael Copa
Browse files

main/cgdb: fix in-program help

The APKBUILD installs the help file (cgdb.txt) to an unusual location,
making cgdb unable to find it. Add a one-line patch to fix that.
parent 3d619d45
No related branches found
No related tags found
2 merge requests!79570community/firefox-esr: upgrade to 128.7.0,!78797main/cgdb: fix in-program help
Pipeline #293162 skipped
......@@ -2,14 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cgdb
pkgver=0.8.0
pkgrel=3
pkgrel=4
pkgdesc="The Curses Debugger"
arch="all"
license="GPL-2.0-or-later"
url="https://cgdb.github.io/"
depends="gdb"
makedepends="flex bison texinfo help2man ncurses-dev readline-dev"
source="http://cgdb.me/files/cgdb-$pkgver.tar.gz"
source="http://cgdb.me/files/cgdb-$pkgver.tar.gz
doc-path.patch"
subpackages="$pkgname-doc"
prepare() {
......@@ -42,4 +43,5 @@ package() {
sha512sums="
0f53798707f20508a8ea564d5ed3f82e223edf4b246468c9a99c929c043b2b2eb333e96395b66672a38da1e517efb7c7dec011a29ea774d873ddf81fb56e4d9a cgdb-0.8.0.tar.gz
89bb741d7b8f0570c566af91c747abba35289b2b77abe6453a8aea0aa7c24b97dc0ace669d776abe35cdcf88856f046595685538c6d68abb1f2beca4e6692ac6 doc-path.patch
"
Alpine-specific patch; Look for cgdb.txt where it's packaged.
--- a/cgdb/interface.cpp
+++ b/cgdb/interface.cpp
@@ -1566,7 +1566,7 @@
char cgdb_help_file[FSUTIL_PATH_MAX];
int ret_val = 0;
- fs_util_get_path(PKGDATADIR, "cgdb.txt", cgdb_help_file);
+ fs_util_get_path("/usr/share/doc/cgdb", "cgdb.txt", cgdb_help_file);
/* File doesn't exist. Try to find cgdb.txt in the build dir in case
* the user is running a built cgdb binary directly. */
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment