Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a6429ac8
Commit
a6429ac8
authored
5 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
main/py-setuptools: switch to python2
parent
2af4c207
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/py-setuptools/APKBUILD
+4
-27
4 additions, 27 deletions
main/py-setuptools/APKBUILD
with
4 additions
and
27 deletions
main/py-setuptools/APKBUILD
+
4
−
27
View file @
a6429ac8
# Contributor: Andrew Manison <amanison@anselsystems.com>
# Contributor: Andrew Manison <amanison@anselsystems.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname
=
py-setuptools
pkgname
=
py
2
-setuptools
_pkgname
=
${
pkgname
#py-
}
_pkgname
=
${
pkgname
#py
2
-
}
pkgver
=
44.0.0
pkgver
=
44.0.0
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"
A c
ollection of enhancements to the Python distutils"
pkgdesc
=
"
C
ollection of enhancements to the Python
2
distutils"
url
=
"https://pypi.python.org/pypi/setuptools"
url
=
"https://pypi.python.org/pypi/setuptools"
arch
=
"noarch"
arch
=
"noarch"
license
=
"MIT"
license
=
"MIT"
depends
=
"python2"
depends
=
"python2"
makedepends
=
"python3"
provides
=
"py2-setuptools=
$pkgver
-r
$pkgrel
"
options
=
"!check"
#no testsuite
options
=
"!check"
#no testsuite
subpackages
=
"py3-
$_pkgname
:_py3"
source
=
"
$_pkgname
-
$pkgver
.tar.gz::https://github.com/pypa/
$_pkgname
/archive/v
$pkgver
.tar.gz"
source
=
"
$_pkgname
-
$pkgver
.tar.gz::https://github.com/pypa/
$_pkgname
/archive/v
$pkgver
.tar.gz"
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
prepare
()
{
prepare
()
{
python2 bootstrap.py
python2 bootstrap.py
python3 bootstrap.py
}
}
build
()
{
build
()
{
python2 setup.py build
python2 setup.py build
python3 setup.py build
}
}
package
()
{
package
()
{
...
@@ -32,22 +27,4 @@ package() {
...
@@ -32,22 +27,4 @@ package() {
rm
-f
"
$pkgdir
"
/usr/bin/easy_install
rm
-f
"
$pkgdir
"
/usr/bin/easy_install
}
}
_py
()
{
local
python
=
"
$1
"
pkgdesc
=
"
$pkgdesc
(for
$python
)"
depends
=
"
$python
"
install_if
=
"
$pkgname
=
$pkgver
-r
$pkgrel
$python
"
cd
"
$builddir
"
$python
setup.py
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
# we don't provide a non-suffixed easy_install
rm
-f
"
$subpkgdir
"
/usr/bin/easy_install
}
_py3
()
{
replaces
=
"python3"
_py python3
}
sha512sums
=
"48febee840612a56c7f4cb0bc3983bf61a6a08c53dfcb95403f6631061481ba391fc0472d608ea6c0078fda8bcc7bb9f6dd8b73d473f5e4349d6eaeb2ab0050b setuptools-44.0.0.tar.gz"
sha512sums
=
"48febee840612a56c7f4cb0bc3983bf61a6a08c53dfcb95403f6631061481ba391fc0472d608ea6c0078fda8bcc7bb9f6dd8b73d473f5e4349d6eaeb2ab0050b setuptools-44.0.0.tar.gz"
This diff is collapsed.
Click to expand it.
Natanael Copa
@ncopa
mentioned in merge request
!8533 (merged)
·
4 years ago
mentioned in merge request
!8533 (merged)
mentioned in merge request !8533
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment