Skip to content
Snippets Groups Projects
Commit a371bc67 authored by alice's avatar alice
Browse files

testing/clementine: rebuild against protobuf-23.3.0

parent a0ac9046
No related branches found
No related tags found
1 merge request!44306main/protobuf: upgrade to 23.0
......@@ -2,7 +2,7 @@
# Maintainer: knuxify <knuxify@gmail.com>
pkgname=clementine
pkgver=1.4.0_git20220324
pkgrel=7
pkgrel=8
_tag=1.4.0rc1-814-g2b340da79
pkgdesc="A modern music player and library organizer"
url="https://clementine-player.org"
......@@ -36,7 +36,9 @@ makedepends="alsa-lib-dev
taglib-dev
"
checkdepends="gtest-dev"
source="https://github.com/clementine-player/Clementine/releases/download/$_tag/clementine-$_tag.tar.xz"
source="https://github.com/clementine-player/Clementine/releases/download/$_tag/clementine-$_tag.tar.xz
cxx17.patch
"
builddir="$srcdir/clementine-$_tag"
build() {
......@@ -47,7 +49,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-error=format" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -std=c++17 -Wno-error=format" \
-DBUNDLE_PROJECTM_PRESETS=OFF \
-DUSE_SYSTEM_PROJECTM=ON \
-DUSE_SYSTEM_TAGLIB=ON \
......@@ -70,4 +72,5 @@ package() {
sha512sums="
38c826e91a23f3d23c30ad9cc34e84c141b4a09badfb08149eff7c6a2ded6e4dabd5a08671a8a82385ba56a2a2d3830ee96e839f86261e0e60180481db4b240a clementine-1.4.0rc1-814-g2b340da79.tar.xz
7cf24bc057c17188084cc252ec2b049e66d27b272b7cfd50d99e1627a80800b5f81b7e5aa57fd551d70f32f864dbfcf13c19f945bfadbdce71a2671dd4b21cb9 cxx17.patch
"
diff --git a/3rdparty/libprojectm/CMakeLists.txt b/3rdparty/libprojectm/CMakeLists.txt
index ce58344..a70f8a2 100644
--- a/3rdparty/libprojectm/CMakeLists.txt
+++ b/3rdparty/libprojectm/CMakeLists.txt
@@ -24,8 +24,6 @@ set(BUILD_PROJECTM_STATIC ON)
set(DISABLE_NATIVE_PRESETS ON)
set(DISABLE_MILKDROP_PRESETS OFF)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
-
pkg_check_modules(GLEW glew)
if(DISABLE_NATIVE_PRESETS)
diff --git a/3rdparty/qtsingleapplication/CMakeLists.txt b/3rdparty/qtsingleapplication/CMakeLists.txt
index 7825ab9..c405256 100644
--- a/3rdparty/qtsingleapplication/CMakeLists.txt
+++ b/3rdparty/qtsingleapplication/CMakeLists.txt
@@ -1,5 +1,4 @@
cmake_minimum_required(VERSION 3.0.0)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
set(SINGLEAPP-SOURCES
qtlocalpeer.cpp
diff --git a/ext/libclementine-common/CMakeLists.txt b/ext/libclementine-common/CMakeLists.txt
index ad35a51..5aff49a 100644
--- a/ext/libclementine-common/CMakeLists.txt
+++ b/ext/libclementine-common/CMakeLists.txt
@@ -2,8 +2,6 @@ include_directories(${PROTOBUF_INCLUDE_DIRS})
include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
-
set(SOURCES
core/closure.cpp
core/latch.cpp
diff --git a/ext/libclementine-remote/CMakeLists.txt b/ext/libclementine-remote/CMakeLists.txt
index 70761b4..5f860fb 100644
--- a/ext/libclementine-remote/CMakeLists.txt
+++ b/ext/libclementine-remote/CMakeLists.txt
@@ -1,7 +1,5 @@
include_directories(${PROTOBUF_INCLUDE_DIRS})
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
-
set(MESSAGES
remotecontrolmessages.proto
)
diff --git a/ext/libclementine-tagreader/CMakeLists.txt b/ext/libclementine-tagreader/CMakeLists.txt
index d7ae9f6..c51dbaf 100644
--- a/ext/libclementine-tagreader/CMakeLists.txt
+++ b/ext/libclementine-tagreader/CMakeLists.txt
@@ -3,8 +3,6 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-common)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")
-
set(MESSAGES
tagreadermessages.proto
)
diff --git a/gst/moodbar/CMakeLists.txt b/gst/moodbar/CMakeLists.txt
index 636ef9f..8828674 100644
--- a/gst/moodbar/CMakeLists.txt
+++ b/gst/moodbar/CMakeLists.txt
@@ -1,7 +1,6 @@
cmake_minimum_required(VERSION 3.0.0)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall --std=c++0x")
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment