Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a32f0e79
Commit
a32f0e79
authored
4 years ago
by
Kevin Daudt
Browse files
Options
Downloads
Patches
Plain Diff
community/apenwarr-redo: upgrade to 0.42a
parent
0b4fa2a4
Loading
Loading
1 merge request
!6412
community/apenwarr-redo: upgrade to 0.42a
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/apenwarr-redo/APKBUILD
+7
-4
7 additions, 4 deletions
community/apenwarr-redo/APKBUILD
community/apenwarr-redo/fix-env-python.patch
+50
-0
50 additions, 0 deletions
community/apenwarr-redo/fix-env-python.patch
with
57 additions
and
4 deletions
community/apenwarr-redo/APKBUILD
+
7
−
4
View file @
a32f0e79
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname
=
apenwarr-redo
pkgver
=
0.42
pkgver
=
0.42
a
pkgrel
=
0
pkgdesc
=
"Smaller, easier, more powerful, and more reliable than make"
url
=
"https://redo.readthedocs.io/en/latest/"
arch
=
"noarch"
license
=
"Apache-2.0"
depends
=
"python
2
"
depends
=
"python
3
"
makedepends
=
"perl"
checkdepends
=
"cpio"
subpackages
=
"
$pkgname
-doc"
source
=
"https://github.com/apenwarr/redo/archive/redo-
$pkgver
.tar.gz"
source
=
"https://github.com/apenwarr/redo/archive/redo-
$pkgver
.tar.gz
fix-env-python.patch
"
provides
=
"redo"
provider_priority
=
50
...
...
@@ -39,4 +41,5 @@ cleanup_srcdir() {
default_cleanup_srcdir
}
sha512sums
=
"41b8417136f98d12edf3c62f027f2459ae3fb92f6c5464553d79c3a52344de57220a5c64b565118da0a99c1544eaa153a468ffcdcfbf7193c76c896bcd40e900 redo-0.42.tar.gz"
sha512sums
=
"8473bd8168c8e70b59a573560f8f725c8538061ee15eabeb63e467a363fa6869aa8088e8ce324726da4e2f7115e2ddf72cbb657703e9090f4f93c05f42bb67cb redo-0.42a.tar.gz
8b01a70e0812bf6c90c8447d110eac91639c35e3e3c20a083d4ed68fe0b3a3524081ad94fa1fd504525b7ebf5ef1fd5aff9fe3b933fe9f0aa2a404426ed96471 fix-env-python.patch"
This diff is collapsed.
Click to expand it.
community/apenwarr-redo/fix-env-python.patch
0 → 100644
+
50
−
0
View file @
a32f0e79
diff --git a/docs/cookbook/container/default.sha256.do b/docs/cookbook/container/default.sha256.do
index d3007e9..b414d02 100644
--- a/docs/cookbook/container/default.sha256.do
+++ b/docs/cookbook/container/default.sha256.do
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Calculate the sha256 digest of a given file."""
import hashlib, os, subprocess, sys
diff --git a/docs/cookbook/container/dockjson.py b/docs/cookbook/container/dockjson.py
index 11a4bec..133a55f 100755
--- a/docs/cookbook/container/dockjson.py
+++ b/docs/cookbook/container/dockjson.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Generate a docker 1.0-style manifest for a docker image."""
import json, os, sys, time
diff --git a/docs/cookbook/container/fileids.py b/docs/cookbook/container/fileids.py
index 68d9982..667c54c 100755
--- a/docs/cookbook/container/fileids.py
+++ b/docs/cookbook/container/fileids.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
import hashlib, os, stat, sys
for name in sys.stdin:
diff --git a/docs/cookbook/container/memcalc.py b/docs/cookbook/container/memcalc.py
index 2301874..7c43e11 100755
--- a/docs/cookbook/container/memcalc.py
+++ b/docs/cookbook/container/memcalc.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
import os, sys
st = os.stat(sys.argv[1])
megabytes = st.st_size // 1024 // 1024
diff --git a/docs/cookbook/defaults/test.py b/docs/cookbook/defaults/test.py
index fa679d2..868cae5 100644
--- a/docs/cookbook/defaults/test.py
+++ b/docs/cookbook/defaults/test.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
"""Test program for auto-generated version.py"""
import version
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment