Skip to content
Snippets Groups Projects
Commit a3107a9d authored by Michał Polański's avatar Michał Polański
Browse files

testing/lswt: upgrade to 1.0.3

parent 43afbc70
No related branches found
No related tags found
No related merge requests found
Pipeline #106199 passed
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=lswt
pkgver=1.0.1
pkgver=1.0.3
pkgrel=0
pkgdesc="List Wayland toplevels"
url="https://git.sr.ht/~leon_plickat/lswt"
license="GPL-3.0"
arch="all"
options="!check" # no test suite
makedepends="wayland-dev wayland-protocols"
makedepends="wayland-dev"
subpackages="$pkgname-doc $pkgname-bash-completion"
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~leon_plickat/lswt/archive/v$pkgver.tar.gz
makefile.patch
"
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~leon_plickat/lswt/archive/v$pkgver.tar.gz"
builddir="$srcdir/lswt-v$pkgver"
options="!check" # no test suite
build() {
make
......@@ -24,6 +22,5 @@ package() {
}
sha512sums="
2c68be801f81d585c105b173cc12a4617b2f9f5b153f243ca9190ad3b0bc9aa38d4034a7db20cf0fd4b2c4d4c32a5864e679ca8a07c349f564aa81c982c5c590 lswt-1.0.1.tar.gz
8dd07cd38129ff40639d8b2e150ac3520db69edce9968e1cbc87dc7ccb65ca6e029d7f2aa80d1f50fbbd835ad017f92679a845dd6bb5cf1f29f6bd5941184cd6 makefile.patch
5577f50929fe2ed339d4cb8530c99525394b81e1f13c3e70192c74056b34d950d0dcfa202c25f1ec96a1f661bb35d8dc2f66021dfaacc06562b2ab25a58a0e57 lswt-1.0.3.tar.gz
"
From ac8b8af3a814453e50474025bb19eeef981e7c12 Mon Sep 17 00:00:00 2001
From: Lennard Hofmann <lennard.hofmann@web.de>
Date: Tue, 15 Jun 2021 14:43:42 +0000
Subject: [PATCH] make: remove misplaced dolar sign
If LDFLAGS is set to "foo", the build will fail because the command "ccfoo" does not exist (notice there is no space between "cc" and "foo")
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index b0abc4b..846a265 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ OBJ=lswt.o wlr-foreign-toplevel-management-unstable-v1.o xdg-output-unstable-v1.
GEN=wlr-foreign-toplevel-management-unstable-v1.c wlr-foreign-toplevel-management-unstable-v1.h xdg-output-unstable-v1.c xdg-output-unstable-v1.h
lswt: $(OBJ)
- $(CC)$ $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
$(OBJ): $(GEN)
--
2.32.0
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment