Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a30a931b
Commit
a30a931b
authored
1 month ago
by
achill (fossdd)
Committed by
Natanael Copa
1 month ago
Browse files
Options
Downloads
Patches
Plain Diff
main/py3-gobject3: upgrade to 3.52.3
https://gitlab.gnome.org/GNOME/pygobject/-/blob/3.52.2/NEWS
parent
92a0f624
No related branches found
Branches containing commit
No related tags found
Loading
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/py3-gobject3/APKBUILD
+4
-7
4 additions, 7 deletions
main/py3-gobject3/APKBUILD
main/py3-gobject3/pygi-info-rm-invalid-error-check.patch
+0
-47
0 additions, 47 deletions
main/py3-gobject3/pygi-info-rm-invalid-error-check.patch
with
4 additions
and
54 deletions
main/py3-gobject3/APKBUILD
+
4
−
7
View file @
a30a931b
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: team/gnome <fossdd@pwned.life>
pkgname
=
py3-gobject3
pkgver
=
3.52.
2
pkgrel
=
1
pkgver
=
3.52.
3
pkgrel
=
0
pkgdesc
=
"Python bindings for the GObject library"
url
=
"https://pygobject.gnome.org"
arch
=
"all"
...
...
@@ -20,9 +20,7 @@ checkdepends="py3-pytest gtk+3.0-dev xvfb-run ibus font-dejavu"
depends
=
"python3"
subpackages
=
"
$pkgname
-dev:_dev
$pkgname
-pyc"
options
=
"!check"
# Need ibus which is in community/
source
=
"https://download.gnome.org/sources/pygobject/
${
pkgver
%.*
}
/pygobject-
$pkgver
.tar.gz
pygi-info-rm-invalid-error-check.patch
"
source
=
"https://download.gnome.org/sources/pygobject/
${
pkgver
%.*
}
/pygobject-
$pkgver
.tar.gz"
builddir
=
"
$srcdir
"
/pygobject-
$pkgver
replaces
=
"py-gobject3"
# Backwards compatibility
...
...
@@ -53,6 +51,5 @@ _dev() {
}
sha512sums
=
"
4289542d1fa7690cc6684379a0f0f45f0f373d43741f8067c27edbf1355bd706e4373caff2469f3635cc62ea7fac603d47f55523422595a931ecf01871c9f00d pygobject-3.52.2.tar.gz
ec6a92b43ad6adad22b5cbb6d2746dc6e7b7c8ef96e04ccfaf8104687b6f6ddd6039cf1332489880166ff936f6eafb43e4949766504dc6fb24f0279afdae48dd pygi-info-rm-invalid-error-check.patch
06085df458076120017ace7a029ac6c00757ae1882a2a50041aadd7f4c2a329a0fb4d18dde02a481c1f4d3acecbc9d8f473f4ae23fbbfc4f885f75bbc7847f24 pygobject-3.52.3.tar.gz
"
This diff is collapsed.
Click to expand it.
main/py3-gobject3/pygi-info-rm-invalid-error-check.patch
deleted
100644 → 0
+
0
−
47
View file @
92a0f624
Patch-Source: https://gitlab.gnome.org/GNOME/pygobject/-/merge_requests/417
---
From cf88f6ecdd8d3510658cd38f8e8c7a8385f0a478 Mon Sep 17 00:00:00 2001
From: Christoph Reiter <reiter.christoph@gmail.com>
Date: Thu, 13 Mar 2025 19:06:59 +0100
Subject: [PATCH] pygi-info: remove invalid error check for
gi_constant_info_get_value
Starting with 585578a82811769e182e accessing Gst.BUFFER_COPY_ALL
started to fail with "RuntimeError: unable to get value". This leads
to importing Gst fail in general since the Gst overrides access that
constant.
Downstream issue:
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/4301
https://gitlab.gnome.org/GNOME/glib/-/commit/14e5844f3d290feea9ab6fc5
changed gi_constant_info_get_value to correctly return unsigned, which
likely led to 585578a82811769e182e. Likely the confusion was that
gi_constant_info_get_value() returns 0 on invalid input, but it's not
documented that 0 is an error return value.
Since gi_constant_info_get_value() doesn't have an error return just
remove the check.
---
gi/pygi-info.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/gi/pygi-info.c b/gi/pygi-info.c
index 4861fb2d..d2b2f8aa 100644
--- a/gi/pygi-info.c
+++ b/gi/pygi-info.c
@@ -1656,10 +1656,7 @@
_wrap_gi_constant_info_get_value (PyGIBaseInfo *self)
PyObject *py_value;
gboolean free_array = FALSE;
- if (gi_constant_info_get_value ( (GIConstantInfo *) self->info, &value) == 0) {
- PyErr_SetString (PyExc_RuntimeError, "unable to get value");
- return NULL;
- }
+ gi_constant_info_get_value ( (GIConstantInfo *) self->info, &value);
type_info = gi_constant_info_get_type_info ( (GIConstantInfo *) self->info);
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment