Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a2d0b593
Commit
a2d0b593
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
community/docker-cli-buildx: upgrade to 0.11.2
parent
41339b98
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/docker-cli-buildx/APKBUILD
+4
-7
4 additions, 7 deletions
community/docker-cli-buildx/APKBUILD
community/docker-cli-buildx/cli-vendor.patch
+0
-78
0 additions, 78 deletions
community/docker-cli-buildx/cli-vendor.patch
with
4 additions
and
85 deletions
community/docker-cli-buildx/APKBUILD
+
4
−
7
View file @
a2d0b593
# Contributor: Jake Buchholz Göktürk <tomalok@gmail.com>
# Maintainer: Jake Buchholz Göktürk <tomalok@gmail.com>
pkgname
=
docker-cli-buildx
_commit
=
687feca9e8dcd1534ac4c026bc4db5a49de0dd6e
pkgver
=
0.11.0
pkgrel
=
2
pkgver
=
0.11.2
pkgrel
=
0
pkgdesc
=
"A Docker CLI plugin for extended build capabilities"
url
=
"https://docs.docker.com/engine/reference/commandline/buildx_build"
arch
=
"all"
license
=
"Apache-2.0"
makedepends
=
"go"
options
=
"net"
source
=
"buildx-
$pkgver
.tar.gz::https://github.com/docker/buildx/archive/v
$pkgver
.tar.gz
cli-vendor.patch"
source
=
"buildx-
$pkgver
.tar.gz::https://github.com/docker/buildx/archive/v
$pkgver
.tar.gz"
_buildx_installdir
=
"/usr/libexec/docker/cli-plugins"
...
...
@@ -41,6 +39,5 @@ package() {
}
sha512sums
=
"
ae4bf5def3cd81815cdf5824ce8f4269fd5f386025435b956aa124a66665a82f4890135fd1be5e16d7c1a992731274cd208752920ed6507283cd7ec256af2aa6 buildx-0.11.0.tar.gz
648d5ca9f3a36c1a25bafb9bdc452e92fe7c4c6e73bf70cb6afdda56e1478e464019fa06652e1bf5b8d0fd40a9e946ffc9672e07a56ec6544b0034a5a74924d6 cli-vendor.patch
6f3718edf1e86c4422e1419580e4c38cf378a59555067be2aa6fac3e7f8878afe39d777765ace274cd9c47630f39cbacfacfdc4ecadd6ff46d5ee37d8f9bc75c buildx-0.11.2.tar.gz
"
This diff is collapsed.
Click to expand it.
community/docker-cli-buildx/cli-vendor.patch
deleted
100644 → 0
+
0
−
78
View file @
41339b98
diff --git a/vendor/github.com/docker/docker/client/client.go b/vendor/github.com/docker/docker/client/client.go
index 1c081a5..54fa36c 100644
--- a/vendor/github.com/docker/docker/client/client.go
+++ b/vendor/github.com/docker/docker/client/client.go
@@ -56,6 +56,36 @@
import (
"github.com/pkg/errors"
)
+// DummyHost is a hostname used for local communication.
+//
+// It acts as a valid formatted hostname for local connections (such as "unix://"
+// or "npipe://") which do not require a hostname. It should never be resolved,
+// but uses the special-purpose ".localhost" TLD (as defined in [RFC 2606, Section 2]
+// and [RFC 6761, Section 6.3]).
+//
+// [RFC 7230, Section 5.4] defines that an empty header must be used for such
+// cases:
+//
+// If the authority component is missing or undefined for the target URI,
+// then a client MUST send a Host header field with an empty field-value.
+//
+// However, [Go stdlib] enforces the semantics of HTTP(S) over TCP, does not
+// allow an empty header to be used, and requires req.URL.Scheme to be either
+// "http" or "https".
+//
+// For further details, refer to:
+//
+// - https://github.com/docker/engine-api/issues/189
+// - https://github.com/golang/go/issues/13624
+// - https://github.com/golang/go/issues/61076
+// - https://github.com/moby/moby/issues/45935
+//
+// [RFC 2606, Section 2]: https://www.rfc-editor.org/rfc/rfc2606.html#section-2
+// [RFC 6761, Section 6.3]: https://www.rfc-editor.org/rfc/rfc6761#section-6.3
+// [RFC 7230, Section 5.4]: https://datatracker.ietf.org/doc/html/rfc7230#section-5.4
+// [Go stdlib]: https://github.com/golang/go/blob/6244b1946bc2101b01955468f1be502dbadd6807/src/net/http/transport.go#L558-L569
+const DummyHost = "api.moby.localhost"
+
// ErrRedirect is the error returned by checkRedirect when the request is non-GET.
var ErrRedirect = errors.New("unexpected redirect in response")
diff --git a/vendor/github.com/docker/docker/client/hijack.go b/vendor/github.com/docker/docker/client/hijack.go
index 6bdacab..db9b02e 100644
--- a/vendor/github.com/docker/docker/client/hijack.go
+++ b/vendor/github.com/docker/docker/client/hijack.go
@@ -64,7 +64,10 @@
func fallbackDial(proto, addr string, tlsConfig *tls.Config) (net.Conn, error) {
}
func (cli *Client) setupHijackConn(ctx context.Context, req *http.Request, proto string) (net.Conn, string, error) {
- req.Host = cli.addr
+ if cli.proto == "unix" || cli.proto == "npipe" {
+ // For local communications, it doesn't matter what the host is.
+ req.URL.Host = DummyHost
+ }
req.Header.Set("Connection", "Upgrade")
req.Header.Set("Upgrade", proto)
diff --git a/vendor/github.com/docker/docker/client/request.go b/vendor/github.com/docker/docker/client/request.go
index c799095..8f43553 100644
--- a/vendor/github.com/docker/docker/client/request.go
+++ b/vendor/github.com/docker/docker/client/request.go
@@ -98,12 +98,12 @@
func (cli *Client) buildRequest(method, path string, body io.Reader, headers hea
req = cli.addHeaders(req, headers)
if cli.proto == "unix" || cli.proto == "npipe" {
- // For local communications, it doesn't matter what the host is. We just
- // need a valid and meaningful host name. (See #189)
- req.Host = "docker"
+ // For local communications, it doesn't matter what the host is.
+ req.URL.Host = DummyHost
+ } else {
+ req.URL.Host = cli.addr
}
- req.URL.Host = cli.addr
req.URL.Scheme = cli.scheme
if expectedPayload && req.Header.Get("Content-Type") == "" {
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment