Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a275abf7
Commit
a275abf7
authored
5 months ago
by
znley
Committed by
Natanael Copa
5 months ago
Browse files
Options
Downloads
Patches
Plain Diff
main/rtapd: fix build with gcc14
parent
2e79de61
No related branches found
No related tags found
1 merge request
!70763
main/rtapd: fix build with gcc14
Pipeline
#254335
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/rtapd/APKBUILD
+2
-0
2 additions, 0 deletions
main/rtapd/APKBUILD
main/rtapd/gcc14.patch
+26
-0
26 additions, 0 deletions
main/rtapd/gcc14.patch
with
28 additions
and
0 deletions
main/rtapd/APKBUILD
+
2
−
0
View file @
a275abf7
...
...
@@ -13,6 +13,7 @@ subpackages="$pkgname-dbg $pkgname-openrc"
source
=
"https://downloads.sourceforge.net/rtnppd/rtapd-
$pkgver
.tar.gz
musl-strtoq.patch
Makefile.patch
gcc14.patch
$pkgname
.initd
$pkgname
.confd"
builddir
=
"
$srcdir
"
/
$pkgname
...
...
@@ -36,6 +37,7 @@ sha512sums="
a4759b5af9710e8658f38494f88cfd727e6697b4793655fd80555405dd7fd04e69aaef63692991653f75ff7e2702ec068547d82778bf1cb51c3aa3d8a1178f63 rtapd-1.7.tar.gz
57d7c6fe5530bcd6c2c27dfa8c2cf473d27cc6cde4e8eb50e302b5c13ffec180523ba93179586cf031a50abb8274383245c41dc20beb35765f7ce42300845e10 musl-strtoq.patch
77d0fadea46c610e9b4de3b95f5d4c8b596637fff9501c1eddbdb4e23d49869692a223c75dc7a7f2c9ea057972dc6f0fffe477ea88e7fbbc9af010b29e7cb922 Makefile.patch
eb636723fdb2648cd9a6f192d06f4c370f387002d5544ce285cbe6ec3b8b7ec6beab493bdf9bf7874936a05f10f3451635ab587989bb20dae262113937a8042a gcc14.patch
5452ae881b1d88fdab95b8987f550ef6d26cb60d6697e38b8ab81010aa40dfb9fa4bee8c053069a882fd9f749882cb96777e3a4866299a6651f1e213e6a4448c rtapd.initd
77c3c5bb295b2f3a8c7271ec52a9d4c02bdebc45d7830cb3b0b64b100a2b2649fb28a3e6b615385f9c50f5c847c12064caf981b1dcca2f78432d230649b326fd rtapd.confd
"
This diff is collapsed.
Click to expand it.
main/rtapd/gcc14.patch
0 → 100644
+
26
−
0
View file @
a275abf7
diff --git a/rtapd.c b/rtapd.c
index 4da7384..31c84e1 100644
--- a/rtapd.c
+++ b/rtapd.c
@@ -347,7 +347,7 @@
int send_tnpp_packet(int fd, struct sockaddr_un *sun, unsigned char *data,
int length, crc;
if (len > (MAX_PACKET_SIZE - 14))
- return;
+ return 0;
serial++;
if (serial > 255)
serial = 1;
diff --git a/vsnppd.c b/vsnppd.c
index e0f83e2..4089e28 100644
--- a/vsnppd.c
+++ b/vsnppd.c
@@ -64,7 +64,7 @@
int send_tnpp_packet(int fd, struct sockaddr_un *sun, unsigned char *data,
int length, crc;
if (len > (MAX_PACKET_SIZE - 14))
- return;
+ return 0;
snprintf(buf, sizeof(buf) - 1, "%c%04X%02X%04X%02X%c", '\01', tnpp_to, 20,
tnpp_from, 0, '\02');
length = strlen(buf);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment