Skip to content
Snippets Groups Projects
Commit a0042344 authored by Lindsay Zhou's avatar Lindsay Zhou Committed by Natanael Copa
Browse files

community/freerdp: fix tracing plugin library failed

parent adb2527f
No related branches found
No related tags found
1 merge request!74072community/freerdp: fix tracing plugin library failed
Pipeline #271122 skipped
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67f34372a..c1c280c99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -992,13 +992,10 @@ else (APPLE)
if (NOT FREEBSD)
if (NOT BUILTIN_CHANNELS)
if (NOT DEFINED WITH_PLUGIN_RPATH_ONLY)
- set(CMAKE_INSTALL_RPATH "\$ORIGIN/../${CMAKE_INSTALL_LIBDIR}:\$ORIGIN/..:\$ORIGIN/../${FREERDP_PLUGIN_PATH}")
- else()
- # we need to supply this run path, even if not using RPATH in general
- set(CMAKE_INSTALL_RPATH "\$ORIGIN/../${FREERDP_PLUGIN_PATH}")
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}/..:${CMAKE_INSTALL_PREFIX}/${FREERDP_PLUGIN_PATH}")
endif()
else()
- set(CMAKE_INSTALL_RPATH "\$ORIGIN/../${CMAKE_INSTALL_LIBDIR}:\$ORIGIN/..")
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}/..")
endif()
endif()
endif(APPLE)
......@@ -2,7 +2,7 @@
pkgname=freerdp
_pkgname=FreeRDP
pkgver=2.11.7
pkgrel=0
pkgrel=1
pkgdesc="FreeRDP client"
url="https://www.freerdp.com/"
arch="all"
......@@ -38,6 +38,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/$pkg
0006-client-wayland-fix-const-correctness.patch
0007-warnings-fix-Wincompatible-pointer-types.patch
0008-server-proxy-deactivate-capture-module.patch
0009-switch-to-absolute-rpath.patch
"
builddir="$srcdir"/$_pkgname-$pkgver
......@@ -139,4 +140,5 @@ a9f6f00b990ced8e26ea15fcfa7f1bef311fa9b16e80ab709ffe6e5edac1f07b6713fa7f3ceb5e81
0846449e113f942e55dd3aa4a74e935e4ec8d70284b6311f094140e275e526034dfb3c1dec3bc3da15037034dad60ba77a9198e3dd2e1800fc9be107046da04d 0006-client-wayland-fix-const-correctness.patch
474316fe10abc51babf12ce993ff2331145bca1e339c68cfb002cfdce2565deadff5aeed5d4098f5378f8042bd918e8f875d76b13ac8e5b30ab03db0c34832cd 0007-warnings-fix-Wincompatible-pointer-types.patch
e3ee2d7c98fe78b51d0a9e174a56439d5035bfad437246415777c2047c6fd9f6a2acee386fef311ea57a1f0e99aab009660cf6c6c7943f90ff20bf7633e812a3 0008-server-proxy-deactivate-capture-module.patch
147b96feb90cb5abb48d2ae568015cd3f47859603b21bbf7a196718937d18d26eb53054f2b8f07fa038e8e55f038cc6fb451197c7cbc29ec14d2090d21fbd170 0009-switch-to-absolute-rpath.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment