Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
9ccebbf7
Commit
9ccebbf7
authored
4 years ago
by
TBK
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/fwknop: fix for -fno-common
parent
591be632
No related branches found
No related tags found
1 merge request
!15868
community/fwknop: fix for -fno-common
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/fwknop/APKBUILD
+8
-5
8 additions, 5 deletions
community/fwknop/APKBUILD
community/fwknop/gcc10.patch
+22
-0
22 additions, 0 deletions
community/fwknop/gcc10.patch
with
30 additions
and
5 deletions
community/fwknop/APKBUILD
+
8
−
5
View file @
9ccebbf7
# Maintainer: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname
=
fwknop
pkgname
=
fwknop
pkgver
=
2.6.10
pkgver
=
2.6.10
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"
A
Single Packet Authorization (SPA) implementation"
pkgdesc
=
"Single Packet Authorization (SPA) implementation"
url
=
"http://www.cipherdyne.org/fwknop/"
url
=
"http://www.cipherdyne.org/fwknop/"
arch
=
"all"
arch
=
"all"
license
=
"GPL-2.0-or-later"
license
=
"GPL-2.0-or-later"
...
@@ -10,7 +10,9 @@ depends="iptables"
...
@@ -10,7 +10,9 @@ depends="iptables"
makedepends
=
"libpcap-dev gpgme-dev"
makedepends
=
"libpcap-dev gpgme-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-libs
$pkgname
-openrc
$pkgname
-server"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-libs
$pkgname
-openrc
$pkgname
-server"
source
=
"http://cipherdyne.org/fwknop/download/fwknop-
$pkgver
.tar.gz
source
=
"http://cipherdyne.org/fwknop/download/fwknop-
$pkgver
.tar.gz
fwknopd.initd"
fwknopd.initd
gcc10.patch
"
build
()
{
build
()
{
./configure
\
./configure
\
...
@@ -41,11 +43,12 @@ package() {
...
@@ -41,11 +43,12 @@ package() {
}
}
server
()
{
server
()
{
pkgdesc
=
"
A
Single Packet Authorization (SPA) server"
pkgdesc
=
"Single Packet Authorization (SPA) server"
mkdir
-p
"
$subpkgdir
"
/usr
mkdir
-p
"
$subpkgdir
"
/usr
mv
"
$pkgdir
"
/usr/sbin
"
$subpkgdir
"
/usr/
\
mv
"
$pkgdir
"
/usr/sbin
"
$subpkgdir
"
/usr/
\
&&
mv
"
$pkgdir
"
/etc
"
$subpkgdir
"
/
&&
mv
"
$pkgdir
"
/etc
"
$subpkgdir
"
/
}
}
sha512sums
=
"3b3e35eda574abd1759431c88677eea7078c54cb3252c0ee0e1019b5b8224ed8844d30760da70a952e1cd92b04715a547f6effabda54678f791fff9afa32cd80 fwknop-2.6.10.tar.gz
sha512sums
=
"3b3e35eda574abd1759431c88677eea7078c54cb3252c0ee0e1019b5b8224ed8844d30760da70a952e1cd92b04715a547f6effabda54678f791fff9afa32cd80 fwknop-2.6.10.tar.gz
e3558c4a1579ea66b19451acc476f3cfec782b052f6d96a57ffc520169db755739e2bf3a815802cc5958a7b2fdeb9b39cf2182e5d89882cf4502985401352465 fwknopd.initd"
e3558c4a1579ea66b19451acc476f3cfec782b052f6d96a57ffc520169db755739e2bf3a815802cc5958a7b2fdeb9b39cf2182e5d89882cf4502985401352465 fwknopd.initd
e045c0936ea03e0f472e3bee7911c01e6ec16b51231f572ec943e1bff5a7e8e5d57739c040affe4d77f6b463d29e52bbe035e9f84a1e03c9a1de9b4c50b27e21 gcc10.patch"
This diff is collapsed.
Click to expand it.
community/fwknop/gcc10.patch
0 → 100644
+
22
−
0
View file @
9ccebbf7
From a8214fd58bc46d23b64b3a55db023c7f5a5ea6af Mon Sep 17 00:00:00 2001
From: Francois Marier <francois@debian.org>
Date: Fri, 24 Jul 2020 21:22:47 -0700
Subject: [PATCH] Fix compilation with GCC's -fno-common flag (fixes #305)
---
client/log_msg.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/client/log_msg.h b/client/log_msg.h
index cc17716b..3dda1614 100644
--- a/client/log_msg.h
+++ b/client/log_msg.h
@@ -38,7 +38,7 @@
enum
LOG_VERBOSITY_INFO, /*!< Constant to define a INFO message */
LOG_VERBOSITY_DEBUG, /*!< Constant to define a DEBUG message */
LOG_LAST_VERBOSITY
-} log_level_t;
+};
#define LOG_DEFAULT_VERBOSITY LOG_VERBOSITY_NORMAL /*!< Default verbosity to use */
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment