Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
9b17d607
Commit
9b17d607
authored
5 years ago
by
Russ
Committed by
Leo
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/crypto++: upgrade to 8.2.0
parent
80672302
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
testing/crypto++/APKBUILD
+10
-17
10 additions, 17 deletions
testing/crypto++/APKBUILD
with
10 additions
and
17 deletions
testing/crypto++/APKBUILD
+
10
−
17
View file @
9b17d607
...
...
@@ -2,35 +2,28 @@
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname
=
crypto++
_pkgname
=
cryptopp
pkgver
=
5.6.5
pkgver
=
8.2.0
_pkgver
=
${
pkgver
//./
}
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"A free C++ class library of cryptographic schemes"
url
=
"https://www.cryptopp.com/"
arch
=
"all"
license
=
"BSL-1.0"
depends
=
""
depends_dev
=
"
$pkgname
"
makedepends
=
""
subpackages
=
"
$pkgname
-dev"
subpackages
=
"
$pkgname
-static
$pkgname
-dev"
source
=
"https://www.cryptopp.com/
${
_pkgname
}${
_pkgver
}
.zip"
builddir
=
"
$srcdir
"
build
()
{
cd
"
$builddir
"
sed
-i
-e
's/^CXXFLAGS/#CXXFLAGS/'
GNUmakefile
||
return
1
export
CXXFLAGS
=
"
${
CXXFLAGS
}
-DNDEBUG -fPIC"
make
-f
GNUmakefile
||
return
1
make
libcryptopp.so
||
return
1
make
CXXFLAGS
=
"
${
CXXFLAGS
}
-DNDEBUG -fPIC"
-f
GNUmakefile dynamic libcryptopp.pc
}
check
()
{
make
-f
GNUmakefile check
}
package
()
{
cd
"
$builddir
"
install
-Dm644
libcryptopp.so
"
$pkgdir
"
/usr/lib/libcryptopp.so
||
return
1
install
-Dm644
License.txt
"
$pkgdir
"
/usr/share/licenses/
$pkgname
/LICENSE
||
return
1
mkdir
-p
"
$pkgdir
"
/usr/include/cryptopp/
||
return
1
install
-m644
*
.h
"
$pkgdir
"
/usr/include/cryptopp/
||
return
1
make
DESTDIR
=
"
$pkgdir
"
PREFIX
=
"/usr"
install-lib
}
sha512sums
=
"
f13718d02ca69b0129aaf9e767c9d2e0333aa7538355f9c63d9eaf1ff369062084a18dc01489439ebf37797b3ea81b01beb072057d47ec962bfb824ddc72abc7
cryptopp
565
.zip"
sha512sums
=
"
753513a4ec8dd0fff2f551853ce6bd265d82219c28b033565b565b5e567fbee17adb419f4cde58a97e62b7d6533f4099aa4996cd0ba4775c6a2e7ae63a879da5
cryptopp
820
.zip"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment