Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
99082e99
Commit
99082e99
authored
1 year ago
by
Patrycja Rosa
Browse files
Options
Downloads
Patches
Plain Diff
main/cmake: backport fix for pkgconfig version matching
parent
ff8edae2
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/cmake/APKBUILD
+5
-2
5 additions, 2 deletions
main/cmake/APKBUILD
main/cmake/pkgconfig-whitespace.patch
+37
-0
37 additions, 0 deletions
main/cmake/pkgconfig-whitespace.patch
with
42 additions
and
2 deletions
main/cmake/APKBUILD
+
5
−
2
View file @
99082e99
...
...
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
cmake
pkgver
=
3.27.7
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Cross-platform, open-source make system"
url
=
"https://www.cmake.org/"
arch
=
"all"
...
...
@@ -33,7 +33,9 @@ case $pkgver in
*
.
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*.*
}
;;
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*
}
;;
esac
source
=
"https://www.cmake.org/files/
$_v
/cmake-
$pkgver
.tar.gz"
source
=
"https://www.cmake.org/files/
$_v
/cmake-
$pkgver
.tar.gz
pkgconfig-whitespace.patch
"
options
=
"!check"
build
()
{
...
...
@@ -93,4 +95,5 @@ vim() {
sha512sums
=
"
2e9b83dee8f8c012be4219ab74ebaa8b8438ea55d5204237a1c9feba94c732afe7baceddb9c681672903112b1e40f7b1a86b284cfceed15f46ce8f90143dbb86 cmake-3.27.7.tar.gz
675c27a8ef1445381fdb20da354621f232964484e9806ba17f67b5840f2e132baf51db3007f8aa580bd68ef48ef76c0a10e155bb68890b3cbb821ffab660cd34 pkgconfig-whitespace.patch
"
This diff is collapsed.
Click to expand it.
main/cmake/pkgconfig-whitespace.patch
0 → 100644
+
37
−
0
View file @
99082e99
Patch-Source: https://gitlab.kitware.com/cmake/cmake/-/commit/9beb4dd8a752e3c9ea0e19152b85f68b0f96d7c6
From d47771bbb96a8435401950fb504b06003ec0babb Mon Sep 17 00:00:00 2001
From: Paul Zander <negril.nx@gmail.com>
Date: Sat, 9 Sep 2023 13:45:19 +0200
Subject: [PATCH] FindPkgConfig: ignore whitespace separators in version check
The regex used to split up the version if it contains an operator fails
if the string contains whitespaces. Resulting in an extra whitespace
after the package name and before the package version leading to
breakage in pkgconf and thus webkit-gtk.
See:
https://github.com/pkgconf/pkgconf/issues/317
https://bugs.webkit.org/show_bug.cgi?id=261125
https://bugs.gentoo.org/913644
---
Modules/FindPkgConfig.cmake | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
index 4d29f4505c..6e8b78441a 100644
--- a/Modules/FindPkgConfig.cmake
+++ b/Modules/FindPkgConfig.cmake
@@ -563,8 +563,8 @@
macro(_pkg_check_modules_internal _is_required _is_silent _no_cmake_path _no_cma
foreach (_pkg_check_modules_pkg ${_pkg_check_modules_list})
set(_pkg_check_modules_exist_query)
- # check whether version is given
- if (_pkg_check_modules_pkg MATCHES "(.*[^><])(=|[><]=?)(.*)")
+ # check whether version is given while ignoring whitespace
+ if (_pkg_check_modules_pkg MATCHES "(.*[^>< \t])[ \t]*(=|[><]=?)[ \t]*(.*)")
set(_pkg_check_modules_pkg_name "${CMAKE_MATCH_1}")
set(_pkg_check_modules_pkg_op "${CMAKE_MATCH_2}")
set(_pkg_check_modules_pkg_ver "${CMAKE_MATCH_3}")
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment