Skip to content
Snippets Groups Projects
Commit 9674a649 authored by Ariadne Conill's avatar Ariadne Conill
Browse files

main/abuild: add support for lzip source packages

parent f7b39d5f
No related branches found
No related tags found
No related merge requests found
From 5b7b1f80cbaa88849e2698d67bf2d72ac9addac4 Mon Sep 17 00:00:00 2001
From: Breno Leitao <breno.leitao@gmail.com>
Date: Wed, 5 Apr 2017 13:28:07 +0000
Subject: [PATCH] abuild: Add support for lzip source packages
Currently abuild does not understand .tar.lz packages, which blocks
the inclusion of certain packages in Alpine Linux.
I found this issue when adding 'ed' package to the repository. With
this change, abuild package will now depend on lzip package. I might
send a patch for abuild's APKBUILD.
---
abuild.in | 3 +++
1 file changed, 3 insertions(+)
diff --git a/abuild.in b/abuild.in
index c201eb2..843baab 100644
--- a/abuild.in
+++ b/abuild.in
@@ -418,6 +418,9 @@ default_unpack() {
*.tar.bz2)
msg "Unpacking $s..."
tar -C "$srcdir" -jxf "$s" || return 1;;
+ *.tar.lz)
+ msg "Unpacking $s..."
+ tar -C "$srcdir" --lzip -xf "$s" || return 1;;
*.tar.lzma)
msg "Unpacking $s..."
unlzma -c "$s" | tar -C "$srcdir" -x \
--
2.12.2
......@@ -2,13 +2,13 @@
pkgname=abuild
pkgver=3.0.0_rc2
_ver=${pkgver%_git*}
pkgrel=3
pkgrel=4
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
license="GPL2"
depends="fakeroot sudo pax-utils libressl apk-tools>=2.0.7-r1 libc-utils
attr tar pkgconf patch"
attr tar pkgconf patch lzip"
if [ "$CBUILD" = "$CHOST" ]; then
depends="$depends curl"
fi
......@@ -23,6 +23,7 @@ source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
0001-abuild-wrap-check-with-fakeroot.patch
0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
0001-abuild-Add-support-for-lzip-source-packages.patch
"
builddir="$srcdir/$pkgname-$_ver"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment