Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
9576e4b3
Commit
9576e4b3
authored
3 months ago
by
Sertonix
Committed by
Natanael Copa
3 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-pydantic: upgrade to 2.10.4
parent
b8a2d32e
No related branches found
No related tags found
2 merge requests
!79570
community/firefox-esr: upgrade to 128.7.0
,
!77412
community/py3-pydantic*: upgrade
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-pydantic/APKBUILD
+3
-7
3 additions, 7 deletions
community/py3-pydantic/APKBUILD
community/py3-pydantic/invalid_schema.patch
+0
-17
0 additions, 17 deletions
community/py3-pydantic/invalid_schema.patch
with
3 additions
and
24 deletions
community/py3-pydantic/APKBUILD
+
3
−
7
View file @
9576e4b3
# Contributor: Newbyte <newbyte@disroot.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
py3-pydantic
pkgver
=
2.
9.2
pkgver
=
2.
10.4
pkgrel
=
0
pkgdesc
=
"Data parsing and validation using Python type hints"
url
=
"https://github.com/pydantic/pydantic"
...
...
@@ -32,11 +32,8 @@ checkdepends="
py3-tzdata
"
subpackages
=
"
$pkgname
-pyc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/pydantic/pydantic/archive/refs/tags/v
$pkgver
.tar.gz
invalid_schema.patch
"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/pydantic/pydantic/archive/refs/tags/v
$pkgver
.tar.gz"
builddir
=
"
$srcdir
/pydantic-
$pkgver
"
patch_args
=
"-p1 --no-backup-if-mismatch"
build
()
{
gpep517 build-wheel
\
...
...
@@ -58,6 +55,5 @@ package() {
}
sha512sums
=
"
ca4efd3972fabff9be675e1f8bc39b4048e18b56db7d8985c560172aceb9f73818ede407d1b97a9069815c0cc7ce9b8dada0cbb43ba0f66a84be7700b48230b6 py3-pydantic-2.9.2.tar.gz
26712b861a0a564e18d3bad19fd87753f4c1643b728f6906857cfa84cab508b091f66c58db87415993a3a7c320facccf3952d5438d0b389a183aecf62c6d819d invalid_schema.patch
bc8e5d6af3d41dc72a65123db8159cb29b37c336bc20e31192e2622dcbf9b43d0184147b7852705b38d7293bd65a0c1a9196ba2d751a2fd18d44d03db65818d9 py3-pydantic-2.10.4.tar.gz
"
This diff is collapsed.
Click to expand it.
community/py3-pydantic/invalid_schema.patch
deleted
100644 → 0
+
0
−
17
View file @
b8a2d32e
Ref https://github.com/pydantic/pydantic/pull/10523
--- a/pydantic/json_schema.py
+++ b/pydantic/json_schema.py
@@ -589,6 +589,12 @@
def _sort_recursive(self, value: Any, parent_key: str | None = None) -> Any:
return value
# ### Schema generation methods
+
+ def invalid_schema(self, schema: core_schema.InvalidSchema) -> JsonSchemaValue:
+ """Placeholder - should never be called."""
+
+ raise RuntimeError('Cannot generate schema for invalid_schema. This is a bug! Please report it.')
+
def any_schema(self, schema: core_schema.AnySchema) -> JsonSchemaValue:
"""Generates a JSON schema that matches any value.
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment