Skip to content
Snippets Groups Projects
Commit 93868647 authored by Holger Jaekel's avatar Holger Jaekel :map:
Browse files

community/libqb3: new aport

https://github.com/lucianpls/QB3
Fast and efficient raster compression
parent a80b8baa
No related branches found
No related tags found
1 merge request!64681community/gdal: upgrade to 3.9.0
Author: Holger Jaekel <holger.jaekel@gmx.de>
Summary: set soversion of library
----
--- a/QB3lib/CMakeLists.txt
+++ b/QB3lib/CMakeLists.txt
@@ -32,6 +32,8 @@
PUBLIC_HEADER "QB3.h;${CMAKE_CURRENT_BINARY_DIR}/libqb3_export.h"
DEBUG_POSTFIX "d"
PREFIX ""
+ VERSION ${PROJECT_VERSION}
+ SOVERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}
)
include(GenerateExportHeader)
Author: Holger Jaekel <holger.jaekel@gmx.de>
Summary: set destination of cmake files
----
--- a/QB3lib/CMakeLists.txt
+++ b/QB3lib/CMakeLists.txt
@@ -53,7 +53,7 @@
install(EXPORT "${PROJECT_NAME}Targets"
FILE "${PROJECT_NAME}Targets.cmake"
NAMESPACE ${namespace}::
- DESTINATION cmake
+ DESTINATION lib/cmake
)
# generate the version file for the config file
@@ -65,13 +65,13 @@
# create config file
configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/Config.cmake.in
"${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
- INSTALL_DESTINATION cmake
+ INSTALL_DESTINATION lib/cmake
)
# install config files
install(FILES
"${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
"${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake"
- DESTINATION cmake
+ DESTINATION lib/cmake
)
# generate the export targets for the build tree
export(EXPORT "${PROJECT_NAME}Targets"
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=libqb3
pkgver=1.1.0
pkgrel=0
pkgdesc="Fast and efficient raster compression"
url="https://github.com/lucianpls/QB3"
arch="all !armhf !armv7 !x86 !s390x" # requires little endian, 64bit
license="Apache-2.0"
options="!check" # no tests
makedepends="clang cmake samurai"
subpackages="$pkgname-dev"
source="libqb3-$pkgver.tar.gz::https://github.com/lucianpls/QB3/archive/refs/tags/V$pkgver.tar.gz
10-soversion.patch
20-cmake_destination.patch"
builddir="$srcdir/QB3-$pkgver"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
local crossopts="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
CC=clang \
CXX=clang++ \
cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=None \
-DBUILD_CQB3=OFF \
$crossopts
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
75d428b38402383dc2744f9e529b52d04922c49e95eb1240542c80ded3969d175d47e7fd9000410091c1808cdb9311520cfdaba72834778849857627b0f6a9ef libqb3-1.1.0.tar.gz
e6322afb53ffefa4ea2e2bf5ba77d6d4685090a0b49ac3134bb9fda11b933645b13b75f64ba4ca76b4358a83a9cb639b2d0e8f98aab46f14d1bf3a0dde1a0fb8 10-soversion.patch
c263135219f8a156b011feacefe7fa29c4f4cbf7e1dc12faf2a2257fb177885ad92d786af8b8d0b0d423461d74a28f92063a4151ff219855207e67f32dfa6c5e 20-cmake_destination.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment