Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
91b2ed17
Commit
91b2ed17
authored
4 years ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
community/ruby-concurrent-ruby: build on all arches, except -java subpkg
parent
ff169fcd
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/ruby-concurrent-ruby/APKBUILD
+11
-12
11 additions, 12 deletions
community/ruby-concurrent-ruby/APKBUILD
community/ruby-concurrent-ruby/gemspecs.patch
+11
-3
11 additions, 3 deletions
community/ruby-concurrent-ruby/gemspecs.patch
with
22 additions
and
15 deletions
community/ruby-concurrent-ruby/APKBUILD
+
11
−
12
View file @
91b2ed17
...
...
@@ -6,29 +6,28 @@ pkgver=1.1.6
pkgrel
=
1
pkgdesc
=
"Modern concurrency tools for Ruby"
url
=
"http://www.concurrent-ruby.com"
# armhf, mips, mips64: requires 'jruby' and 'openjdk8'
# x86, armv7, ppc64le: requires 'java-jffi-native'
arch
=
"all !mips !mips64 !x86 !armv7 !ppc64le !armhf"
arch
=
"all"
license
=
"MIT"
depends
=
"ruby ruby-etc"
makedepends
=
"
jruby openjdk8
ruby-dev ruby-rake ruby-rake-compiler"
makedepends
=
"ruby-dev ruby-rake ruby-rake-compiler"
checkdepends
=
"ruby-rspec ruby-timecop"
subpackages
=
"
$pkgname
-java::noarch
$pkgname
-ext"
subpackages
=
"
$pkgname
-ext"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/ruby-concurrency/
$_gemname
/archive/v
$pkgver
.tar.gz
ungit-
gemspec.patch
gemspec
s
.patch
rakefile-remove-dock.patch
"
builddir
=
"
$srcdir
/
$_gemname
-
$pkgver
"
case
"
$CARCH
"
in
# XXX: Two test fail, see https://github.com/ruby-concurrency/concurrent-ruby/issues/689
armhf
)
options
=
"!check"
;;
esac
# limited by jruby and openjdk8
case
"
$CARCH
"
in
x86_64
|
aarch64
)
makedepends
=
"
$makedepends
jruby openjdk8"
subpackages
=
"
$subpackages
$pkgname
-java::noarch"
build
()
{
export
PATH
=
"/usr/lib/jvm/java-1.8-openjdk/bin:
$PATH
"
export
JRUBY_HOME
=
"/usr/share/jruby"
esac
build
()
{
rake repackage
RUBYLIB
=
"
$(
pwd
)
/lib"
gem
install
--local
\
...
...
@@ -95,5 +94,5 @@ ext() {
}
sha512sums
=
"45b841761ab7060e437b334f8a1a6bcc60e230483cbf3176d6224020b6f7232fe61b0364a7ebe95b80e895847675a5ba0ae075bafcc35b709a60e288c32f2db3 ruby-concurrent-ruby-1.1.6.tar.gz
4f464764072f8870a99c7b1ea263993f95e98edaf1c7f7ad350321ab74676d6511659eed779786d5dc9d31eae83c45651fc4a8895ea7082a7ebcf29398dd05d4 ungit-
gemspec.patch
2db9dbd791f52647c7ba66b6537575ccbaa402de0316169cfc887f8f25093f0507e144eca86a4f1baaefc9cd268474460ed1ea09713b5ffb354642c036bc46f0
gemspec
s
.patch
964384305dbe7d0578e80117587235acd2ab8e812aaa9353a13157ad92574b6db632fe96b144950e64377f94af26fa2ec1bad1c829493c48d379c0c91e1282b7 rakefile-remove-dock.patch"
This diff is collapsed.
Click to expand it.
community/ruby-concurrent-ruby/
ungit-
gemspec.patch
→
community/ruby-concurrent-ruby/gemspec
s
.patch
+
11
−
3
View file @
91b2ed17
Don't use git to filter files to be included.
Include Java files only when JRUBY_HOME is set.
--- a/concurrent-ruby.gemspec
+++ b/concurrent-ruby.gemspec
@@ -2,8 +2,6 @@
...
...
@@ -9,17 +12,22 @@
s.name = 'concurrent-ruby'
s.version = Concurrent::VERSION
s.platform = Gem::Platform::RUBY
@@ -13,
8
+11,
8
@@
@@ -13,
12
+11,
12
@@
s.summary = 'Modern concurrency tools for Ruby. Inspired by Erlang, Clojure, Scala, Haskell, F#, C#, Java, and classic concurrency patterns.'
s.license = 'MIT'
s.date = Time.now.strftime('%Y-%m-%d')
- s.files = [*Dir['lib/concurrent-ruby/**/*.rb'] & git_files,
- *Dir['ext/concurrent-ruby/**/*'] & git_files,
+ s.files = [*Dir['lib/concurrent-ruby/**/*.rb'],
+ *Dir['ext/concurrent-ruby/**/*'],
+ *
(
Dir['ext/concurrent-ruby/**/*']
if ENV['JRUBY_HOME'])
,
'Rakefile',
'Gemfile',
'lib/concurrent-ruby/concurrent/concurrent_ruby.jar'
- 'lib/concurrent-ruby/concurrent/concurrent_ruby.jar'
+ ('lib/concurrent-ruby/concurrent/concurrent_ruby.jar' if ENV['JRUBY_HOME']),
]
s.extra_rdoc_files = Dir['README*', 'LICENSE*', 'CHANGELOG*']
s.require_paths = ['lib/concurrent-ruby']
s.description = <<-TXT.gsub(/^ +/, '')
--- a/concurrent-ruby-edge.gemspec
+++ b/concurrent-ruby-edge.gemspec
@@ -2,8 +2,6 @@
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment