Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
915315f1
Unverified
Commit
915315f1
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/hostapd: modernise, fix manpage install, use lto
parent
b8e1fdc4
No related branches found
No related tags found
1 merge request
!39304
[3.16] main/expat: security upgrade to 2.4.9
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/hostapd/APKBUILD
+48
-41
48 additions, 41 deletions
main/hostapd/APKBUILD
with
48 additions
and
41 deletions
main/hostapd/APKBUILD
+
48
−
41
View file @
915315f1
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
hostapd
pkgver
=
2.10
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"daemon for wireless software access points"
url
=
"https://w1.fi/hostapd/"
arch
=
"all"
...
...
@@ -44,58 +44,65 @@ builddir="$srcdir"/$pkgname-$pkgver/hostapd
prepare
()
{
default_prepare
cd
"
$builddir
"
sed
-i
-e
"s:/etc/hostapd:/etc/hostapd/hostapd:g"
\
hostapd.conf
# toolchain setup
sed
\
-e
'/^#CONFIG_DRIVER_NL80211=y/s/^#//'
\
-e
'/^#CONFIG_RADIUS_SERVER=y/s/^#//'
\
-e
'/^#CONFIG_DRIVER_WIRED=y/s/^#//'
\
-e
'/^#CONFIG_DRIVER_NONE=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211N=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211R=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211AC=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211AX=y/s/^#//'
\
-e
'/^#CONFIG_FULL_DYNAMIC_VLAN=y/s/^#//'
\
-e
'/^#CONFIG_LIBNL32=y/s/^#//'
\
-e
'/^#CONFIG_ACS=y/s/^#//'
\
-e
'/^#CONFIG_WEP=y/s/^#//'
\
-e
'/^#CONFIG_SAE=y/s/^#//'
\
defconfig
>>
.config
echo
"CC ?=
${
CC
:-
gcc
}
"
>>
.config
echo
"CFLAGS += -I/usr/include/libnl3"
>>
.config
echo
"LIBS += -L/usr/lib"
>>
.config
{
sed
\
-e
'/^#CONFIG_DRIVER_NL80211=y/s/^#//'
\
-e
'/^#CONFIG_RADIUS_SERVER=y/s/^#//'
\
-e
'/^#CONFIG_DRIVER_WIRED=y/s/^#//'
\
-e
'/^#CONFIG_DRIVER_NONE=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211N=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211R=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211AC=y/s/^#//'
\
-e
'/^#CONFIG_IEEE80211AX=y/s/^#//'
\
-e
'/^#CONFIG_FULL_DYNAMIC_VLAN=y/s/^#//'
\
-e
'/^#CONFIG_LIBNL32=y/s/^#//'
\
-e
'/^#CONFIG_ACS=y/s/^#//'
\
-e
'/^#CONFIG_WEP=y/s/^#//'
\
-e
'/^#CONFIG_SAE=y/s/^#//'
\
defconfig
echo
"CC ?=
${
CC
:-
gcc
}
"
echo
"CFLAGS += -I/usr/include/libnl3"
echo
"LIBS += -L/usr/lib"
}
>>
.config
}
build
()
{
cd
"
$builddir
"
make
msg
"nt_password_hash"
make nt_password_hash
export
CFLAGS
=
"
$CFLAGS
-flto=auto"
make all nt_password_hash
}
package
()
{
cd
"
$builddir
"
install
-d
"
$pkgdir
"
/etc/hostapd
install
hostapd.conf hostapd.accept hostapd.deny hostapd.eap_user
\
hostapd.radius_clients hostapd.sim_db hostapd.wpa_psk
\
"
$pkgdir
"
/etc/hostapd/
install
-D
hostapd.conf
\
hostapd.accept
\
hostapd.deny
\
hostapd.eap_user
\
hostapd.radius_clients
\
hostapd.sim_db
\
hostapd.wpa_psk
\
-t
"
$pkgdir
"
/etc/hostapd/
install
-Dm755
hostapd
\
-t
"
$pkgdir
"
/usr/sbin/
install
-Dm755
hostapd_cli nt_password_hash
\
-t
"
$pkgdir
"
/usr/bin/
install
-Dm755
hostapd
"
$pkgdir
"
/usr/sbin/hostapd
\
&&
install
-Dm755
hostapd_cli
"
$pkgdir
"
/usr/bin/hostapd_cli
\
&&
install
-Dm755
nt_password_hash
\
"
$pkgdir
"
/usr/bin/nt_password_hash
\
&&
install
-Dm755
"
$srcdir
"
/hostapd.initd
\
"
$pkgdir
"
/etc/init.d/hostapd
\
&&
install
-Dm644
"
$srcdir
"
/hostapd.confd
\
"
$pkgdir
"
/etc/conf.d/hostapd
\
&&
install
-Dm644
hostapd.8
\
"
$pkgdir
"
/usr/share/man/man8/hostapd.8
\
&&
install
-Dm644
hostapd_cli.1
\
"
$pkgdir
"
/usr/share/man/man1/hostapd_cli
install
-Dm755
"
$srcdir
"
/hostapd.initd
\
"
$pkgdir
"
/etc/init.d/hostapd
install
-Dm644
"
$srcdir
"
/hostapd.confd
\
"
$pkgdir
"
/etc/conf.d/hostapd
install
-Dm644
hostapd.8
\
-t
"
$pkgdir
"
/usr/share/man/man8/
install
-Dm644
hostapd_cli.1
\
-t
"
$pkgdir
"
/usr/share/man/man1/
}
sha512sums
=
"
243baa82d621f859d2507d8d5beb0ebda15a75548a62451dc9bca42717dcc8607adac49b354919a41d8257d16d07ac7268203a79750db0cfb34b51f80ff1ce8f hostapd-2.10.tar.gz
b54b7c6aa17e5cb86a9b354a516eb2dbefb544df18471339c61d82776de447011a2ac290bea1e6c8beae4b6cebefafb8174683ea42fb773e9e8fe6c679f33ba3 hostapd.initd
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment