Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
8cd134a2
Commit
8cd134a2
authored
1 month ago
by
Hoang Nguyen
Committed by
J0WI
1 month ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/jaq: upgrade to 2.1.0
parent
85526fbf
No related branches found
Branches containing commit
No related tags found
1 merge request
!79441
testing/jaq: upgrade to 2.1.0
Pipeline
#296393
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/jaq/32bit-tests.patch
+0
-91
0 additions, 91 deletions
testing/jaq/32bit-tests.patch
testing/jaq/APKBUILD
+4
-8
4 additions, 8 deletions
testing/jaq/APKBUILD
with
4 additions
and
99 deletions
testing/jaq/32bit-tests.patch
deleted
100644 → 0
+
0
−
91
View file @
85526fbf
Patch-Source: https://github.com/01mf02/jaq/commit/18aa0a8ac81b8321a453680fecf03b78961fd7ce
From 18aa0a8ac81b8321a453680fecf03b78961fd7ce Mon Sep 17 00:00:00 2001
From: Simon Rupf <simon@rupf.net>
Date: Mon, 9 Dec 2024 19:08:43 +0100
Subject: [PATCH] Changing test to pass on 32 bit architecture.
Reduces large isize to remain below maximum for signed 32 bit int,
resolves #243
---
jaq-json/tests/funs.rs | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/jaq-json/tests/funs.rs b/jaq-json/tests/funs.rs
index 7aecdbe..d68ce55 100644
--- a/jaq-json/tests/funs.rs
+++ b/jaq-json/tests/funs.rs
@@ -81,7 +81,7 @@
fn tojson() {
#[test]
fn math_rem() {
// generated with this command with modification for errors and float rounding
- // cargo run -- -rn 'def f: -2, -1, 0, 2.1, 3, 4000000001; f as $a | f as $b | "give!(json!(null), \"\($a) / \($b)\", \(try ($a % $b) catch tojson));"'
+ // cargo run -- -rn 'def f: -2, -1, 0, 2.1, 3, 2000000001; f as $a | f as $b | "give!(json!(null), \"\($a) / \($b)\", \(try ($a % $b) catch tojson));"'
// TODO: use fail!()?
give(json!(null), "-2 % -2", json!(0));
give(json!(null), "-2 % -1", json!(0));
@@ -92,7 +92,7 @@
fn math_rem() {
);
give(json!(null), "-2 % 2.1", json!(-2.0));
give(json!(null), "-2 % 3", json!(-2));
- give(json!(null), "-2 % 4000000001", json!(-2));
+ give(json!(null), "-2 % 2000000001", json!(-2));
give(json!(null), "-1 % -2", json!(-1));
give(json!(null), "-1 % -1", json!(0));
give(
@@ -102,7 +102,7 @@
fn math_rem() {
);
give(json!(null), "-1 % 2.1", json!(-1.0));
give(json!(null), "-1 % 3", json!(-1));
- give(json!(null), "-1 % 4000000001", json!(-1));
+ give(json!(null), "-1 % 2000000001", json!(-1));
give(json!(null), "0 % -2", json!(0));
give(json!(null), "0 % -1", json!(0));
give(
@@ -112,13 +112,13 @@
fn math_rem() {
);
give(json!(null), "0 % 2.1", json!(0.0));
give(json!(null), "0 % 3", json!(0));
- give(json!(null), "0 % 4000000001", json!(0));
+ give(json!(null), "0 % 2000000001", json!(0));
give(json!(null), "2.1 % -2 | . * 1000 | round", json!(100));
give(json!(null), "2.1 % -1 | . * 1000 | round", json!(100));
give(json!(null), "2.1 % 0 | isnan", json!(true));
give(json!(null), "2.1 % 2.1", json!(0.0));
give(json!(null), "2.1 % 3", json!(2.1));
- give(json!(null), "2.1 % 4000000001", json!(2.1));
+ give(json!(null), "2.1 % 2000000001", json!(2.1));
give(json!(null), "3 % -2", json!(1));
give(json!(null), "3 % -1", json!(0));
give(
@@ -128,19 +128,19 @@
fn math_rem() {
);
give(json!(null), "3 % 2.1 | . * 1000 | round", json!(900));
give(json!(null), "3 % 3", json!(0));
- give(json!(null), "3 % 4000000001", json!(3));
- give(json!(null), "4000000001 % -2", json!(1));
- give(json!(null), "4000000001 % -1", json!(0));
+ give(json!(null), "3 % 2000000001", json!(3));
+ give(json!(null), "2000000001 % -2", json!(1));
+ give(json!(null), "2000000001 % -1", json!(0));
give(
json!(null),
- "try (4000000001 % 0) catch .",
- json!("cannot calculate 4000000001 % 0"),
+ "try (2000000001 % 0) catch .",
+ json!("cannot calculate 2000000001 % 0"),
);
give(
json!(null),
- "4000000001 % 2.1 | . * 1000 | round",
- json!(500),
+ "2000000001 % 2.1 | . * 1000 | round",
+ json!(1800), // 1000 in jq
);
- give(json!(null), "4000000001 % 3", json!(2));
- give(json!(null), "4000000001 % 4000000001", json!(0));
+ give(json!(null), "2000000001 % 3", json!(0));
+ give(json!(null), "2000000001 % 2000000001", json!(0));
}
--
2.47.1
This diff is collapsed.
Click to expand it.
testing/jaq/APKBUILD
+
4
−
8
View file @
8cd134a2
# M
aintainer
:
Hoang Nguyen <folliekazetani@protonmail.com>
m
aintainer
=
"
Hoang Nguyen <folliekazetani@protonmail.com>
"
pkgname
=
jaq
pkgver
=
2.
0.1
pkgver
=
2.
1.0
pkgrel
=
0
pkgdesc
=
"jq clone focused on correctness, speed and simplicity"
url
=
"https://github.com/01mf02/jaq"
...
...
@@ -8,10 +8,7 @@ arch="all"
license
=
"MIT"
makedepends
=
"cargo cargo-auditable"
subpackages
=
"
$pkgname
-doc"
source
=
"
https://github.com/01mf02/jaq/archive/v
$pkgver
/jaq-
$pkgver
.tar.gz
32bit-tests.patch
"
source
=
"https://github.com/01mf02/jaq/archive/v
$pkgver
/jaq-
$pkgver
.tar.gz"
prepare
()
{
default_prepare
...
...
@@ -33,6 +30,5 @@ package() {
}
sha512sums
=
"
1b062c613a10352c43b34c141986cb34fcf0e4ce74078327bef1028e3acb227c8c40de2231f20ecfae9f9e510fd736e9f73ec42ceba9a3bc19df52f1e9e77a81 jaq-2.0.1.tar.gz
218a3dbf547717ddf9d7d96756c0c90804e03782b8ae9094d3bbd917442520c4fe6f2423fca874f545c0fde9fb9e3caf87daedc776cfc583f13fa5f7401f1bb2 32bit-tests.patch
36cddd0d6868535f6c433460196ae215a357ca920f23febc29757d5a6d4b3d0b08235ecf016573f0fdcf95f88b7903ac3ebfa04ded7d400ecef2c46b90c71c56 jaq-2.1.0.tar.gz
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment