Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
8bd52d16
Commit
8bd52d16
authored
4 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
testing/b3sum: upgrade to 0.3.0
parent
7dd7293e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!6030
testing/b3sum: upgrade to 0.3.0
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
testing/b3sum/APKBUILD
+6
-8
6 additions, 8 deletions
testing/b3sum/APKBUILD
with
6 additions
and
8 deletions
testing/b3sum/APKBUILD
+
6
−
8
View file @
8bd52d16
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname
=
b3sum
pkgname
=
b3sum
pkgver
=
0.
2.3
pkgver
=
0.
3.0
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"Command line implementation of the BLAKE3 hash function"
pkgdesc
=
"Command line implementation of the BLAKE3 hash function"
url
=
"https://blake3.io"
url
=
"https://blake3.io"
...
@@ -11,22 +11,20 @@ makedepends="cargo"
...
@@ -11,22 +11,20 @@ makedepends="cargo"
source
=
"b3sum-
$pkgver
.tar.gz::https://crates.io/api/v1/crates/b3sum/
$pkgver
/download"
source
=
"b3sum-
$pkgver
.tar.gz::https://crates.io/api/v1/crates/b3sum/
$pkgver
/download"
case
"
$CARCH
"
in
case
"
$CARCH
"
in
arm
*
)
_features
=
"c_neon"
;;
arm
*
)
_features
=
"neon"
;;
x86_64
)
_features
=
"c"
;;
*
)
_features
=
""
;;
esac
esac
build
()
{
build
()
{
cargo build
--release
--locked
--no-default-features
--features
=
"
$_features
"
cargo build
--release
--locked
--no-default-features
${
_features
:+
--features
=
"
$_features
"
}
}
}
check
()
{
check
()
{
cargo
test
--release
--locked
--no-default-features
--features
=
"
$_features
"
cargo
test
--release
--locked
--no-default-features
${
_features
:+
--features
=
"
$_features
"
}
}
}
package
()
{
package
()
{
cargo
install
--path
.
--root
=
"
$pkgdir
/usr"
--no-default-features
--features
"
$_features
"
cargo
install
--path
.
--root
=
"
$pkgdir
/usr"
--no-default-features
${
_features
:+
--features
"
$_features
"
}
rm
"
$pkgdir
"
/usr/.crates.toml
rm
"
$pkgdir
"
/usr/.crates.toml
}
}
sha512sums
=
"
6376e374f5846590c8813b89852e110834f712f7d3e2fe24bb4ddb02a3c6f584
50
b
20
6a665ba9ab2bcc0fdd802004dcc5fe61e13dd424932cafae2c62b5704ac
b3sum-0.
2.3
.tar.gz"
sha512sums
=
"
3da4ea06e2db87f37c0f2f2f7b7c016bd25a8b692f96e2927094c3331b2ee494a8db138
50
7
20
783db67a3965fd7de9928b80feeb0e24bd1ef4cf2b917ddbc091
b3sum-0.
3.0
.tar.gz"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment