Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
8b820f2b
Commit
8b820f2b
authored
3 years ago
by
Bart Ribbers
Browse files
Options
Downloads
Patches
Plain Diff
community/glacier-settings: upgrade to 0.4
parent
c7c8b87f
No related branches found
No related tags found
1 merge request
!27871
community/glacier-settings: upgrade to 0.4
Pipeline
#101087
canceled
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/glacier-settings/0001-Make-developer-mode-and-example-plugins-optional.patch
+0
-62
0 additions, 62 deletions
...01-Make-developer-mode-and-example-plugins-optional.patch
community/glacier-settings/APKBUILD
+5
-7
5 additions, 7 deletions
community/glacier-settings/APKBUILD
with
5 additions
and
69 deletions
community/glacier-settings/0001-Make-developer-mode-and-example-plugins-optional.patch
deleted
100644 → 0
+
0
−
62
View file @
c7c8b87f
From 0a847a32663a4867f3521c838170d1b838c88e87 Mon Sep 17 00:00:00 2001
From: Chupligin Sergey <neochapay@gmail.com>
Date: Wed, 23 Jun 2021 15:07:00 +0300
Subject: [PATCH] Make developer mode and example plugins optional. Fixed #18
---
CMakeLists.txt | 3 +++
src/CMakeLists.txt | 22 +++++++++++++++++++---
2 files changed, 22 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e97de5..0a93da9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,9 @@
set(QT_MIN_VERSION "5.6.0")
find_package(Qt5 COMPONENTS Qml Quick Positioning LinguistTools REQUIRED)
find_package(Glacier COMPONENTS App REQUIRED)
+option(MER_DEVMODE "Install mer developer mode plugin" OFF)
+option(BUILD_EXAMPLES "Install example plugin" OFF)
+
add_subdirectory(src)
# Translations
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d0a20dc..becd57d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,9 +7,7 @@
set(SRC
models/settingsmodel.cpp
models/settingsmodel.h)
set(QML_PLUGINS
- qml/plugins/example/example.json
qml/plugins/bluez/bluez.json
- qml/plugins/developermode/developermode.json
qml/plugins/display/display.json
qml/plugins/datetime/datetime.json
qml/plugins/wifi/wifi.json
@@ -38,4 +36,22 @@
install(FILES ${QML_PLUGINS}
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings/plugins)
install(DIRECTORY qml
DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings
- PATTERN "*.json" EXCLUDE)
+ PATTERN "*.json" EXCLUDE
+ PATTERN "example" EXCLUDE
+ PATTERN "developermode" EXCLUDE)
+
+if(MER_DEVMODE)
+ install(FILES qml/plugins/developermode/developermode.json
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings/plugins)
+ install(DIRECTORY qml/plugins/developermode
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings/qml/plugins
+ PATTERN "*.json" EXCLUDE)
+endif()
+
+if(BUILD_EXAMPLES)
+ install(FILES qml/plugins/example/example.json
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings/plugins)
+ install(DIRECTORY qml/plugins/example
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/glacier-settings/qml/plugins
+ PATTERN "*.json" EXCLUDE)
+endif()
This diff is collapsed.
Click to expand it.
community/glacier-settings/APKBUILD
+
5
−
7
View file @
8b820f2b
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
glacier-settings
pkgver
=
0.
1.
4
pkgrel
=
2
pkgver
=
0.4
pkgrel
=
0
pkgdesc
=
"The Glacier settings application"
url
=
"https://github.com/nemomobile-ux/glacier-settings"
# armhf blocked by qtquickcontrols-nemo
...
...
@@ -20,14 +20,13 @@ depends="
makedepends
=
"
cmake
libglacierapp-dev
nemo-qml-plugin-systemsettings-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtlocation-dev
qt5-qttools-dev
"
source
=
"https://github.com/nemomobile-ux/glacier-settings/archive/
$pkgver
/glacier-settings-
$pkgver
.tar.gz
0001-Make-developer-mode-and-example-plugins-optional.patch
"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/nemomobile-ux/glacier-settings/archive/
$pkgver
.tar.gz"
options
=
"!check"
# No tests
build
()
{
...
...
@@ -42,6 +41,5 @@ package() {
}
sha512sums
=
"
2385e7b75ecf9034f09bb1429546cc4d6737ddde6a56c8545a2cf1a75026ddae7f0ca376d552fc6cfcf86561dce56f46e522980b9400a1503fcd376f4447b192 glacier-settings-0.1.4.tar.gz
943dc6315a70d3dd8446c30b6d9598171c2f82afba51ebc1d6713465e0ed53c66381e5f2ec32c2562cafb24e7cc30a08c436211e64df37c5baf2fa73e40a7e4f 0001-Make-developer-mode-and-example-plugins-optional.patch
a2eafa04189f01e0dcb42975b914891fbbb1cf03be2e4758b4bdf81332faae2a664eff7d221cd775a7740e1e65cfb2df15838efdb591e0af11169d53fa7f4113 glacier-settings-0.4.tar.gz
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment