Skip to content
Snippets Groups Projects
Commit 886b5617 authored by Bart Ribbers's avatar Bart Ribbers Committed by Rasmus Thomsen
Browse files

testing/sink: new aport

parent 12a8e88d
No related branches found
No related tags found
3 merge requests!11958community/rclone: upgrade to 1.52.3,!9763[3.12] community/znc: upgrade to 1.8.1,!9703testing/sink: new aport
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=sink
pkgver=0.8.0
pkgrel=0
pkgdesc="Offline caching, synchronization and indexing system for PIM data"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by flatbuffers
arch="all !armhf !s390x"
url="https://community.kde.org/KDE_PIM"
license="LicenseRef-KDE-Accepted-GPL"
depends_dev="qt5-qtbase-dev kmime-dev kcontacts-dev kcalendarcore-dev xapian-core-dev lmdb-dev kasync-dev kimap2-dev kdav2-dev curl-dev flatbuffers-dev libexecinfo-dev"
makedepends="$depends_dev extra-cmake-modules"
source="https://download.kde.org/unstable/sink/$pkgver/src/sink-$pkgver.tar.xz
fix-build-failures.patch
"
subpackages="$pkgname-dev"
options="!check" # Tests compilation is broken
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
sha512sums="008ca8355ffbed2bf89a906510aac4c505c8e44de49f445db283aa565e233e7652f2e46c5bcf37e680dec940a8c0f1525e6a8f708e1b4742db62522255c8bad6 sink-0.8.0.tar.xz
b4a68367f1866e67aa8787b1d54ba27464a92b4a0c096944ad691fbd883fe70e5829cc886e04ec287e8be71808bd70bd3c7ffafb9de8e46e4c3193af2cd918dd fix-build-failures.patch"
Required to make Sink build.
The function "printStacktrace" makes use of backtrace which is not available on Alpine.
https://invent.kde.org/pim/sink/-/issues/2
Building of the examples and tests are broken
https://invent.kde.org/pim/sink/-/issues/1
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 178b0293..9d320f40 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,11 +150,15 @@ add_subdirectory(common)
# the synchronizer
add_subdirectory(synchronizer)
-# example implementations
-add_subdirectory(examples)
+if(BUILD_EXAMPLES)
+ # example implementations
+ add_subdirectory(examples)
+endif()
-# some tests
-add_subdirectory(tests)
+if(BUILD_TESTS)
+ # some tests
+ add_subdirectory(tests)
+endif()
# cli
add_subdirectory(sinksh)
diff --git a/synchronizer/backtrace.cpp b/synchronizer/backtrace.cpp
index bd993ccb..597694bf 100644
--- a/synchronizer/backtrace.cpp
+++ b/synchronizer/backtrace.cpp
@@ -250,7 +250,9 @@ static void crashHandler(int signal)
std::cerr << "Unexpected signal " << signal << " received\n";
}
+#if defined(__GLIBC__)
printStacktrace();
+#endif // __GLIBC__
//Get the word out that we're going down
if (sListener) {
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment