Skip to content
Snippets Groups Projects
Verified Commit 85e93cec authored by NekoCWD's avatar NekoCWD Committed by Patrycja Rosa
Browse files

community/fragments: use cargo auditable build instead of cargo build

parent 92e21342
No related branches found
No related tags found
1 merge request!64586community/fragments: move from testing
Pipeline #231818 skipped
diff --git a/src/meson.build b/src/meson.build
index 96f692d..ee77d26 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -49,9 +49,9 @@ cargo_release = custom_target(
command: [
'env',
cargo_env,
- cargo, 'build',
+ cargo, 'auditable', 'build',
cargo_options,
'&&',
'cp', 'target' / rust_target / meson.project_name(), '@OUTPUT@',
]
diff --git a/src/meson.build b/src/meson.build
index bf2da60..8c1069d 100644
index ee77d26..f9bb03e 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -55,8 +55,6 @@ cargo_release = custom_target(
@@ -47,8 +47,6 @@ cargo_release = custom_target(
install: true,
install_dir: get_option('bindir'),
install_dir: bindir,
command: [
- 'env',
- cargo_env,
cargo, 'build',
cargo, 'auditable', 'build',
cargo_options,
'&&',
......@@ -2,7 +2,7 @@
# Maintainer: NekoCWD <nekodevelopper@gmail.com>
pkgname=fragments
pkgver=3.0.0
pkgrel=0
pkgrel=1
pkgdesc="A BitTorrent Client"
url="https://gitlab.gnome.org/World/Fragments"
# s390x fails to build
......@@ -12,6 +12,7 @@ license="GPL-3.0-or-later"
depends="transmission-daemon"
makedepends="
cargo
cargo-auditable
dbus-dev
desktop-file-utils
libadwaita-dev
......@@ -22,7 +23,8 @@ makedepends="
subpackages="$pkgname-lang"
source="
https://gitlab.gnome.org/World/Fragments/-/archive/$pkgver/Fragments-$pkgver.tar.gz
no-cargo-home.patch
0001-Use-cargo-auditable-build-instead-of-cargo-build.patch
0002-Remove-cargo-home.patch
"
options="net" # needed for downloading dependencies
builddir="$srcdir/Fragments-$pkgver" # Name starts with capital letter
......@@ -51,5 +53,6 @@ package() {
sha512sums="
bb0f30249bcba9c8bec2245443faf91acccca47af755383e339d9e22b2a4e8ea4173b3596c7c202226724dfefb806ec125e5b74903041aa599507bdaac5e0060 Fragments-3.0.0.tar.gz
2c4b7433f27b18bbb428bdc2053cda53f10e958a2045499ab7af6102df9610822cf36a82636cd5b9501ba4e204aeddc18fcdb79aff773657a9a5a3c1aeba8e95 no-cargo-home.patch
56d76e2d50a20472e26aed22db48b9bcf5ea001e237976dd9b39900e409591a085fae8205162ed0f1cc63f9c37b59bf7af10a156755a0c067d42fcaab8e3c589 0001-Use-cargo-auditable-build-instead-of-cargo-build.patch
c79144a2139129a8b67838d308c7fb552fe56baa3c63ee0fcdaa95dd9bdeca76089a66e7c8b584848b3bb6b2dc1394ea7123ab8e2412bd3f389819ae6fdd9924 0002-Remove-cargo-home.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment