Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
858c3b68
Verified
Commit
858c3b68
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/serf: remove missing openssl3 function
parent
c3634fd5
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!39304
[3.16] main/expat: security upgrade to 2.4.9
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/serf/APKBUILD
+7
-3
7 additions, 3 deletions
main/serf/APKBUILD
main/serf/openssl3.patch
+14
-0
14 additions, 0 deletions
main/serf/openssl3.patch
with
21 additions
and
3 deletions
main/serf/APKBUILD
+
7
−
3
View file @
858c3b68
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
serf
pkgver
=
1.3.9
pkgrel
=
8
pkgrel
=
9
pkgdesc
=
"High-Performance Asynchronous HTTP Client Library"
url
=
"http://serf.apache.org/"
arch
=
"all"
...
...
@@ -10,6 +10,7 @@ makedepends="apr-util-dev apr-dev openssl-dev>3 zlib-dev scons chrpath"
subpackages
=
"
$pkgname
-dev"
source
=
"https://archive.apache.org/dist/serf/serf-
$pkgver
.tar.bz2
scons-py3.patch
openssl3.patch
"
build
()
{
...
...
@@ -23,5 +24,8 @@ package() {
chrpath
-d
"
$pkgdir
"
/usr/lib/libserf-1.so
*
}
sha512sums
=
"9f5418d991840a08d293d1ecba70cd9534a207696d002f22dbe62354e7b005955112a0d144a76c89c7f7ad3b4c882e54974441fafa0c09c4aa25c49c021ca75d serf-1.3.9.tar.bz2
61547b360d92c29569d60c1e137f009c214e95cffd2edd20a7374da5b659c258d34759252d6ad6958eb7da0aa58fbb374153ee92323f0b84dc4b350f2ede17a1 scons-py3.patch"
sha512sums
=
"
9f5418d991840a08d293d1ecba70cd9534a207696d002f22dbe62354e7b005955112a0d144a76c89c7f7ad3b4c882e54974441fafa0c09c4aa25c49c021ca75d serf-1.3.9.tar.bz2
61547b360d92c29569d60c1e137f009c214e95cffd2edd20a7374da5b659c258d34759252d6ad6958eb7da0aa58fbb374153ee92323f0b84dc4b350f2ede17a1 scons-py3.patch
9cfd29517210566ccd0d86de35dcdca01869edcd9d4ffd1faeb67198f45f10568ca0f7dfff5b0affc126cfb0c807c0686ceb67cdcc7023ffd9e74304111a305e openssl3.patch
"
This diff is collapsed.
Click to expand it.
main/serf/openssl3.patch
0 → 100644
+
14
−
0
View file @
858c3b68
diff --git a/buckets/ssl_buckets.c b/buckets/ssl_buckets.c
index b01e535..9801f87 100644
--- a/buckets/ssl_buckets.c
+++ b/buckets/ssl_buckets.c
@@ -1325,8 +1325,7 @@
static int ssl_need_client_cert(SSL *ssl, X509 **cert, EVP_PKEY **pkey)
return 0;
}
else {
- printf("OpenSSL cert error: %d %d %d\n", ERR_GET_LIB(err),
- ERR_GET_FUNC(err),
+ printf("OpenSSL cert error: %d %d\n", ERR_GET_LIB(err),
ERR_GET_REASON(err));
PKCS12_free(p12);
bio_meth_free(biom);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment