Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
83ad7b0b
Commit
83ad7b0b
authored
1 month ago
by
achill (fossdd)
Committed by
Kevin Daudt
1 week ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/melange: improve
parent
b7c86305
No related branches found
No related tags found
1 merge request
!80161
testing/melange: upgrade to 0.20.1
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
testing/melange/APKBUILD
+7
-11
7 additions, 11 deletions
testing/melange/APKBUILD
with
7 additions
and
11 deletions
testing/melange/APKBUILD
+
7
−
11
View file @
83ad7b0b
...
...
@@ -14,29 +14,25 @@ subpackages="
"
source
=
"https://github.com/chainguard-dev/melange/archive/v
$pkgver
/melange-
$pkgver
.tar.gz"
export
GOCACHE
=
"
${
GOCACHE
:-
"
$srcdir
/go-cache"
}
"
export
GOTMPDIR
=
"
${
GOTMPDIR
:-
"
$srcdir
"
}
"
export
GOMODCACHE
=
"
${
GOMODCACHE
:-
"
$srcdir
/go"
}
"
build
()
{
mkdir
build
go build
-o
build/
"
$builddir
"
/..
.
go build
-o
build/
.
for
i
in
bash fish zsh
;
do
"
$builddir
"
/build/melange completion
$i
>
"
$builddir
"
/
melange.
$i
.
/build/melange completion
$i
>
melange.
$i
done
}
check
()
{
(
unset
SOURCE_DATE_EPOCH
;
go
test
"
$builddir
"
/...
)
(
unset
SOURCE_DATE_EPOCH
;
go
test
.
/...
)
}
package
()
{
install
-Dm755
"
$builddir
"
/
build/melange
"
$pkgdir
"
/usr/bin/
melange
install
-Dm755
build/melange
-t
"
$pkgdir
"
/usr/bin/
install
-Dm644
"
$builddir
"
/
melange.bash
"
$pkgdir
"
/usr/share/bash-completion/completions/melange
install
-Dm644
"
$builddir
"
/
melange.fish
"
$pkgdir
"
/usr/share/fish/vendor_completions.d/melange.fish
install
-Dm644
"
$builddir
"
/
melange.zsh
"
$pkgdir
"
/usr/share/zsh/site-functions/_melange
install
-Dm644
melange.bash
"
$pkgdir
"
/usr/share/bash-completion/completions/melange
install
-Dm644
melange.fish
"
$pkgdir
"
/usr/share/fish/vendor_completions.d/melange.fish
install
-Dm644
melange.zsh
"
$pkgdir
"
/usr/share/zsh/site-functions/_melange
}
sha512sums
=
"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment