Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
81e24164
Commit
81e24164
authored
6 years ago
by
Carlo Landmeter
Browse files
Options
Downloads
Patches
Plain Diff
main/abuild: allow forcing of colored output
parent
308a9de1
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/abuild/0001-Allow-forcing-of-colored-output.patch
+29
-0
29 additions, 0 deletions
main/abuild/0001-Allow-forcing-of-colored-output.patch
main/abuild/APKBUILD
+4
-2
4 additions, 2 deletions
main/abuild/APKBUILD
with
33 additions
and
2 deletions
main/abuild/0001-Allow-forcing-of-colored-output.patch
0 → 100644
+
29
−
0
View file @
81e24164
From 0a79fc62c9d0aa30eb42ff4251701eee2368309d Mon Sep 17 00:00:00 2001
From: Carlo Landmeter <clandmeter@alpinelinux.org>
Date: Mon, 25 Feb 2019 23:02:09 +0000
Subject: [PATCH] Allow forcing of colored output
In some cases (ie drone ci) there is no tty available but its still
possible to display colors in the webui.
---
functions.sh.in | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/functions.sh.in b/functions.sh.in
index 4f2c023..ea21f25 100644
--- a/functions.sh.in
+++ b/functions.sh.in
@@ -243,7 +243,9 @@
enable_colors() {
BLUE="\033[1;34m"
}
-if [ -n "$USE_COLORS" ] && [ -t 1 ]; then
+if [ "$USE_COLORS" = force ]; then
+ enable_colors
+elif [ -n "$USE_COLORS" ] && [ -t 1 ]; then
enable_colors
else
disable_colors
--
2.21.0
This diff is collapsed.
Click to expand it.
main/abuild/APKBUILD
+
4
−
2
View file @
81e24164
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
pkgname
=
abuild
pkgname
=
abuild
pkgver
=
3.3.0
pkgver
=
3.3.0
_ver
=
${
pkgver
%_git*
}
_ver
=
${
pkgver
%_git*
}
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Script to build Alpine Packages"
pkgdesc
=
"Script to build Alpine Packages"
url
=
"https://git.alpinelinux.org/cgit/abuild/"
url
=
"https://git.alpinelinux.org/cgit/abuild/"
arch
=
"all"
arch
=
"all"
...
@@ -22,6 +22,7 @@ options="suid !check"
...
@@ -22,6 +22,7 @@ options="suid !check"
pkggroups
=
"abuild"
pkggroups
=
"abuild"
source
=
"https://dev.alpinelinux.org/archive/abuild/abuild-
$_ver
.tar.xz
source
=
"https://dev.alpinelinux.org/archive/abuild/abuild-
$_ver
.tar.xz
0001-abuild-add-support-for-pkg-config-prefix-pcprefix.patch
0001-abuild-add-support-for-pkg-config-prefix-pcprefix.patch
0001-Allow-forcing-of-colored-output.patch
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
...
@@ -70,4 +71,5 @@ _rootbld() {
...
@@ -70,4 +71,5 @@ _rootbld() {
}
}
sha512sums
=
"c109a63107a0816117d781c1d3e664dd8d36648b0dc46a9e61d720c9813d50134cd8db4b282a8d27e546b5bd544296088c6d1b6996b230304d5db009f4ba4d52 abuild-3.3.0.tar.xz
sha512sums
=
"c109a63107a0816117d781c1d3e664dd8d36648b0dc46a9e61d720c9813d50134cd8db4b282a8d27e546b5bd544296088c6d1b6996b230304d5db009f4ba4d52 abuild-3.3.0.tar.xz
fc33c946b969b6f862c85582f7ec63cea2fa47d1d13dd10374c7376f297926bea2e0864509235b1c7118d6dc759ca5cfc6487612877f97568f9294e6c67fb86c 0001-abuild-add-support-for-pkg-config-prefix-pcprefix.patch"
fc33c946b969b6f862c85582f7ec63cea2fa47d1d13dd10374c7376f297926bea2e0864509235b1c7118d6dc759ca5cfc6487612877f97568f9294e6c67fb86c 0001-abuild-add-support-for-pkg-config-prefix-pcprefix.patch
0a64bec454b076f2db1667f9812ee454d1c2d94ef0171d5bc2f3e324557bdc50dadca28710a3b76d557c585ec0f2d5f3e0b96f0320d99505542ca5ad6b004a72 0001-Allow-forcing-of-colored-output.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment