Skip to content
Snippets Groups Projects
Commit 7f7bde08 authored by Patrycja Rosa's avatar Patrycja Rosa 🐱 Committed by alice
Browse files

main/py3-py: upgrade to 1.11.0

parent f373f8ef
No related branches found
No related tags found
1 merge request!40188main/py3-py: upgrade to 1.11.0
Pipeline #140147 passed with stage
in 49 seconds
diff --git a/setup.py b/setup.py
index d097daa..672c6d4 100644
index 5948ef0..97d5f10 100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,15 @@
@@ -1,13 +1,13 @@
from setuptools import setup, find_packages
+from py._version import version
+ver = {}
+with open("py/_version.py") as f:
+ exec(f.read(), ver)
def main():
setup(
name='py',
+ version=ver['version'],
+ version=version,
description='library with cross-python path, ini-parsing, io, code, log facilities',
long_description=open('README.rst').read(),
- use_scm_version={"write_to": "py/_version.py"},
- setup_requires=["setuptools-scm"],
- setup_requires=["setuptools_scm"],
url='https://py.readthedocs.io/',
license='MIT license',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-py
pkgver=1.10.0
pkgrel=3
pkgver=1.11.0
pkgrel=0
pkgdesc="Python3 library with cross-python path, ini-parsing, io, code, log facilities"
url="https://py.readthedocs.io"
arch="noarch"
......@@ -45,6 +45,6 @@ package() {
}
sha512sums="
7a0eb964067bc01fa4f8ffe70b043abfd4619134fbee2935713e28382085d0b8972c319ed665a643b879b18ce662db8a9bd722937af7cf36c233214eea211dd1 py-1.10.0.tar.gz
387457b20851c86a4e5198eb9c43ddf3ab8e4a9461a2b1ff7cd3813ce4f713769e08a2e1ce15901b7762f6fd0863d1736ffc7733673f251470653000f678f43b 0001-remove-setuptools_scm.patch
ce8dd791f9f6dd7e60a6caad32ff5cb816389a0840436efdedf4e0d4b0bfa09f7aea9e7c31d89903c72fe6ef17170a85af480525ba92c458ed73501a0420f2c4 py-1.11.0.tar.gz
eedb84da521cda62ccca158faaae39f7e5915ec11123d8083a4a5817766e388e4b3ed2ca09c0f91fe2b6f7efd3f0212fd8b73e54097ea444c2c4b7da0151d0e7 0001-remove-setuptools_scm.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment