Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
1.2k
Issue boards
Milestones
Code
Merge requests
646
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
7f7bde08
Commit
7f7bde08
authored
2 years ago
by
Patrycja Rosa
🐱
Committed by
alice
2 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/py3-py: upgrade to 1.11.0
parent
f373f8ef
No related branches found
No related tags found
1 merge request
!40188
main/py3-py: upgrade to 1.11.0
Pipeline
#140147
passed with stage
in 49 seconds
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/py3-py/0001-remove-setuptools_scm.patch
+5
-7
5 additions, 7 deletions
main/py3-py/0001-remove-setuptools_scm.patch
main/py3-py/APKBUILD
+4
-4
4 additions, 4 deletions
main/py3-py/APKBUILD
with
9 additions
and
11 deletions
main/py3-py/0001-remove-setuptools_scm.patch
+
5
−
7
View file @
7f7bde08
diff --git a/setup.py b/setup.py
index
d097daa..672c6d4
100644
index
5948ef0..97d5f10
100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,1
5
@@
@@ -1,13 +1,1
3
@@
from setuptools import setup, find_packages
+from py._version import version
+ver = {}
+with open("py/_version.py") as f:
+ exec(f.read(), ver)
def main():
setup(
name='py',
+ version=
ver['
version
']
,
+ version=version,
description='library with cross-python path, ini-parsing, io, code, log facilities',
long_description=open('README.rst').read(),
- use_scm_version={"write_to": "py/_version.py"},
- setup_requires=["setuptools
-
scm"],
- setup_requires=["setuptools
_
scm"],
url='https://py.readthedocs.io/',
license='MIT license',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
This diff is collapsed.
Click to expand it.
main/py3-py/APKBUILD
+
4
−
4
View file @
7f7bde08
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname
=
py3-py
pkgver
=
1.1
0
.0
pkgrel
=
3
pkgver
=
1.1
1
.0
pkgrel
=
0
pkgdesc
=
"Python3 library with cross-python path, ini-parsing, io, code, log facilities"
url
=
"https://py.readthedocs.io"
arch
=
"noarch"
...
...
@@ -45,6 +45,6 @@ package() {
}
sha512sums
=
"
7a0eb964067bc01fa4f8ffe70b043abfd4619134fbee2935713e28382085d0b8972c319ed665a643b879b18ce662db8a9bd722937af7cf36c233214eea211dd1
py-1.1
0
.0.tar.gz
387457b20851c86a4e5198eb9c43ddf3ab8e4a9461a2b1ff7cd3813ce4f713769e08a2e1ce15901b7762f6fd0863d1736ffc7733673f251470653000f678f43b
0001-remove-setuptools_scm.patch
ce8dd791f9f6dd7e60a6caad32ff5cb816389a0840436efdedf4e0d4b0bfa09f7aea9e7c31d89903c72fe6ef17170a85af480525ba92c458ed73501a0420f2c4
py-1.1
1
.0.tar.gz
eedb84da521cda62ccca158faaae39f7e5915ec11123d8083a4a5817766e388e4b3ed2ca09c0f91fe2b6f7efd3f0212fd8b73e54097ea444c2c4b7da0151d0e7
0001-remove-setuptools_scm.patch
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment