Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
7f3241b6
Commit
7f3241b6
authored
4 years ago
by
Kevin Daudt
Browse files
Options
Downloads
Patches
Plain Diff
main/slang: disable slsh process test
This test fails on the builder
parent
5b90bd90
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/slang/APKBUILD
+3
-1
3 additions, 1 deletion
main/slang/APKBUILD
main/slang/skip-slsh-process-test.patch
+15
-0
15 additions, 0 deletions
main/slang/skip-slsh-process-test.patch
with
18 additions
and
1 deletion
main/slang/APKBUILD
+
3
−
1
View file @
7f3241b6
...
...
@@ -12,6 +12,7 @@ source="https://www.jedsoft.org/releases/slang/slang-$pkgver.tar.bz2
disable-rpath.patch
fix-slarray-32bit.patch
terminfo-in-etc.patch
skip-slsh-process-test.patch
"
build
()
{
...
...
@@ -36,4 +37,5 @@ package() {
sha512sums
=
"35cdfe8af66dac62ee89cca60fa87ddbd02cae63b30d5c0e3786e77b1893c45697ace4ac7e82d9832b8a9ac342560bc35997674846c5022341481013e76f74b5 slang-2.3.2.tar.bz2
6cc7ee4493131e2c9ec48db1b5f97c5db9288e96c5073507307454dd02437b9076ffe1a4853097a7912fa7f47e694145ac1e7f7b17a29e642a8866af521cd940 disable-rpath.patch
3a4d7c27734b6d29ce029000275a536744f6127c9bcb9eee168a63666e9b134bf72d3a27e0b6cfb90b968420a7778284b7cf1f1871031f0240f6394392e0b66c fix-slarray-32bit.patch
a9fe12d220ec3458932784f1f7d40816cad9664ad5a3e19fe684e8f32eccc67ffc48acfa9852fccbe6741519f2acadbafc4b72817ae70804f93e2d913831d786 terminfo-in-etc.patch"
a9fe12d220ec3458932784f1f7d40816cad9664ad5a3e19fe684e8f32eccc67ffc48acfa9852fccbe6741519f2acadbafc4b72817ae70804f93e2d913831d786 terminfo-in-etc.patch
4a499a61a0abf119a362c46e761a4cd659a0de03f22acd2004a09fce339cde848f114a3a0beca176e3a42beeb8d0d2cd73ba788ccb01330b741afe9d8528164c skip-slsh-process-test.patch"
This diff is collapsed.
Click to expand it.
main/slang/skip-slsh-process-test.patch
0 → 100644
+
15
−
0
View file @
7f3241b6
Upstream: no
Reason: this test fails only on builders with "wc: standard input: Bad file descriptor"
diff --git a/slsh/lib/test/test_process.sl b/slsh/lib/test/test_process.sl
index d72b232..54d0796 100644
--- a/slsh/lib/test/test_process.sl
+++ b/slsh/lib/test/test_process.sl
@@ -37,6 +37,8 @@
private define test_process ()
define slsh_main ()
{
start_test ("process");
+ () = fprintf(stdout, "Skipped\n");
+ return;
test_process ();
end_test ();
}
This diff is collapsed.
Click to expand it.
Kevin Daudt
@kdaudt
mentioned in issue
#11463 (closed)
·
4 years ago
mentioned in issue
#11463 (closed)
mentioned in issue #11463
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment