Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
7be72c23
Commit
7be72c23
authored
3 years ago
by
Peter van Dijk
Committed by
Leo
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/pdns-recursor: add patch to fix container exceptions in boost 1.76
parent
1b6cfb11
Loading
Loading
1 merge request
!20762
community/pdns-recursor: add patch to fix container exceptions in boost 1.76
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/pdns-recursor/APKBUILD
+4
-3
4 additions, 3 deletions
community/pdns-recursor/APKBUILD
community/pdns-recursor/pdns-boost-containers-exceptions.patch
+36
-0
36 additions, 0 deletions
...nity/pdns-recursor/pdns-boost-containers-exceptions.patch
with
40 additions
and
3 deletions
community/pdns-recursor/APKBUILD
+
4
−
3
View file @
7be72c23
...
@@ -3,9 +3,8 @@
...
@@ -3,9 +3,8 @@
_pkgname
=
pdns-recursor
# upstream package name
_pkgname
=
pdns-recursor
# upstream package name
pkgname
=
pdns-recursor
pkgname
=
pdns-recursor
pkgver
=
4.4.3
pkgver
=
4.4.3
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"PowerDNS Recursive Server"
pkgdesc
=
"PowerDNS Recursive Server"
options
=
"!check"
# Tests fail with boost1.76
url
=
"https://www.powerdns.com/"
url
=
"https://www.powerdns.com/"
arch
=
"all !s390x !mips !mips64"
# broken context
arch
=
"all !s390x !mips !mips64"
# broken context
license
=
"GPL-2.0-only WITH OpenSSL-Exception"
license
=
"GPL-2.0-only WITH OpenSSL-Exception"
...
@@ -20,6 +19,7 @@ source="https://downloads.powerdns.com/releases/$_pkgname-$pkgver.tar.bz2
...
@@ -20,6 +19,7 @@ source="https://downloads.powerdns.com/releases/$_pkgname-$pkgver.tar.bz2
$pkgname
-GPGKEYS::https://www.powerdns.com/powerdns-keyblock.asc
$pkgname
-GPGKEYS::https://www.powerdns.com/powerdns-keyblock.asc
$_pkgname
.initd
$_pkgname
.initd
recursor.conf
recursor.conf
pdns-boost-containers-exceptions.patch
"
"
# secfixes:
# secfixes:
# 4.3.5-r0:
# 4.3.5-r0:
...
@@ -92,4 +92,5 @@ sha512sums="bac69cbaabc1b0de0def681e07f7e77954e0d487732cb46dc722f7869576a8a477a4
...
@@ -92,4 +92,5 @@ sha512sums="bac69cbaabc1b0de0def681e07f7e77954e0d487732cb46dc722f7869576a8a477a4
490e1afd940bfd3ffe0c3e32d778eaf08ef5c92cb46fc09b527b7b2bac6fc2aba1afbcc0e8e88481809330d701679126b1c1ed81d2770bc605d3b000e177c561 boost.m4
490e1afd940bfd3ffe0c3e32d778eaf08ef5c92cb46fc09b527b7b2bac6fc2aba1afbcc0e8e88481809330d701679126b1c1ed81d2770bc605d3b000e177c561 boost.m4
7027c12c450ecdf4fa569e882eebdb437f166c71090f867928fddb08c558df452922ee3b33fa1dad3097b322bdb79a2096e07d9d2e9f15423464a64df6a9cde3 pdns-recursor-GPGKEYS
7027c12c450ecdf4fa569e882eebdb437f166c71090f867928fddb08c558df452922ee3b33fa1dad3097b322bdb79a2096e07d9d2e9f15423464a64df6a9cde3 pdns-recursor-GPGKEYS
71f7be51d3a9a78f22f3946e95534d4f5b37b3bcbd1891ad3a17095be545fdb0eaf239d58c9f40ccc642542150c0b35ed025bf69acabfa779c0ab10c67a5e796 pdns-recursor.initd
71f7be51d3a9a78f22f3946e95534d4f5b37b3bcbd1891ad3a17095be545fdb0eaf239d58c9f40ccc642542150c0b35ed025bf69acabfa779c0ab10c67a5e796 pdns-recursor.initd
9eb82b86ba75af71ef49a510f087bbefaaacafb4c06dde9124c0fa74b27456d59dd246cc8bffd35394fcf4840995375c9004827bbc3b527d419f54fd65bf632a recursor.conf"
9eb82b86ba75af71ef49a510f087bbefaaacafb4c06dde9124c0fa74b27456d59dd246cc8bffd35394fcf4840995375c9004827bbc3b527d419f54fd65bf632a recursor.conf
34ed1e7bcb99f5c6ffa0d2151c9d0ec7423ba52eccd76f7c55f1093227f761d33fc8e54fa93791ed1f9ecd1bc3212cb1b41fc482a09cec9bd92a2ed598dd4f1c pdns-boost-containers-exceptions.patch"
This diff is collapsed.
Click to expand it.
community/pdns-recursor/pdns-boost-containers-exceptions.patch
0 → 100644
+
36
−
0
View file @
7be72c23
diff --git a/pdns/dnsname.hh b/pdns/dnsname.hh
index 20d1994b2..b65ef8eed 100644
--- a/dnsname.hh
+++ b/dnsname.hh
@@ -35,6 +35,7 @@
// it crashes on OSX and doesn't compile on OpenBSD
#if BOOST_VERSION >= 105300 && ! defined( __APPLE__ ) && ! defined(__OpenBSD__)
+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
#include <boost/container/string.hpp>
#endif
diff --git a/pdns/dnswriter.cc b/pdns/dnswriter.cc
index 1cbd2b219..b3f2fdd16 100644
--- a/dnswriter.cc
+++ b/dnswriter.cc
@@ -24,6 +24,7 @@
#endif
#include <boost/version.hpp>
#if BOOST_VERSION >= 105400
+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
#include <boost/container/static_vector.hpp>
#endif
#include "dnswriter.hh"
diff --git a/pdns/pdns_recursor.cc b/pdns/pdns_recursor.cc
index 4a2e9e561..a686470f0 100644
--- a/pdns_recursor.cc
+++ b/pdns_recursor.cc
@@ -27,6 +27,7 @@
#include <sys/stat.h>
#include <unistd.h>
#ifdef HAVE_BOOST_CONTAINER_FLAT_SET_HPP
+#define BOOST_CONTAINER_USE_STD_EXCEPTIONS
#include <boost/container/flat_set.hpp>
#endif
#include "ws-recursor.hh"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment