Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
7991eb4d
Commit
7991eb4d
authored
7 years ago
by
Síle Ekaterin Liszka
Committed by
Ariadne Conill
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/tf: new package
parent
6e9f01dc
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/tf/0001-Add-DESTDIR-support.patch
+80
-33
80 additions, 33 deletions
testing/tf/0001-Add-DESTDIR-support.patch
testing/tf/APKBUILD
+2
-2
2 additions, 2 deletions
testing/tf/APKBUILD
with
82 additions
and
35 deletions
testing/tf/0001-Add-DESTDIR-support.patch
+
80
−
33
View file @
7991eb4d
diff -Nurd tf-50b8/unix/unix.mak tf-50b8.new/unix/unix.mak
--- tf-50b8/unix/unix.mak
--- tf-50b8/unix/unix.mak 2007-01-13 23:12:39.000000000 +0000
+++ tf-50b8.new/unix/unix.mak
+++ tf-50b8.new/unix/unix.mak 2018-01-24 09:55:28.039801506 +0000
@@ -87,57 +87,65 @@
@@ -87,46 +87,38 @@
-test -z "$(STRIP)" || $(STRIP) tf$(X) || true
-test -z "$(STRIP)" || $(STRIP) tf$(X) || true
PREFIXDIRS:
PREFIXDIRS:
- test -d "$(bindir)" || mkdir $(bindir)
- test -d "$(bindir)" || mkdir $(bindir)
- test -d "$(datadir)" || mkdir $(datadir)
- test -d "$(datadir)" || mkdir $(datadir)
+ test -d "$(DESTDIR)$(bindir)" || mkdir -p $(DESTDIR)$(bindir)
+ test -d "$(DESTDIR)$(datadir)" || mkdir -p $(DESTDIR)$(datadir)
install_TF $(TF): tf$(X) $(BUILDERS)
install_TF $(TF): tf$(X) $(BUILDERS)
-@rm -f $(TF)
-
-@rm -f $(TF)
- cp tf$(X) $(TF)
- cp tf$(X) $(TF)
- chmod $(MODE) $(TF)
- chmod $(MODE) $(TF)
+ cp tf$(X) $(DESTDIR)$(TF)
+ install -Dm755 tf$(X) $(DESTDIR)$(bindir)/tf
+ chmod $(MODE) $(DESTDIR)$(TF)
SYMLINK $(SYMLINK): $(TF)
SYMLINK $(SYMLINK): $(TF)
- test -z "$(SYMLINK)" || { rm -f $(SYMLINK) && ln -s $(TF) $(SYMLINK); }
- test -z "$(SYMLINK)" || { rm -f $(SYMLINK) && ln -s $(TF) $(SYMLINK); }
+ cd $(DESTDIR)$(bindir)
+ ln -s tf tf5
LIBRARY $(TF_LIBDIR): ../tf-lib/tf-help ../tf-lib/tf-help.idx
LIBRARY $(TF_LIBDIR): ../tf-lib/tf-help ../tf-lib/tf-help.idx
@echo '## Creating library directory...'
-
@echo '## Creating library directory...'
-# @# Overly simplified shell commands, to avoid problems on ultrix
-# @# Overly simplified shell commands, to avoid problems on ultrix
- -@test -n "$(TF_LIBDIR)" || echo "TF_LIBDIR is undefined."
- -@test -n "$(TF_LIBDIR)" || echo "TF_LIBDIR is undefined."
- test -n "$(TF_LIBDIR)"
- test -n "$(TF_LIBDIR)"
...
@@ -33,34 +27,87 @@ diff -Nurd tf-50b8/unix/unix.mak tf-50b8.new/unix/unix.mak
...
@@ -33,34 +27,87 @@ diff -Nurd tf-50b8/unix/unix.mak tf-50b8.new/unix/unix.mak
- test -d "$(TF_LIBDIR)"
- test -d "$(TF_LIBDIR)"
-#
-#
-# @#rm -f $(TF_LIBDIR)/*; # wrong: this would remove local.tf, etc.
-# @#rm -f $(TF_LIBDIR)/*; # wrong: this would remove local.tf, etc.
+ test -d "$(DESTDIR)$(TF_LIBDIR)" || mkdir $(DESTDIR)$(TF_LIBDIR)
- @echo '## Copying library files...'
@echo '## Copying library files...'
- cd ../tf-lib; \
cd ../tf-lib; \
- for f in *; do test -f $$f && files="$$files $$f"; done; \
for f in *; do test -f $$f && files="$$files $$f"; done; \
- ( cd $(TF_LIBDIR); rm -f $$files tf.help tf.help.index; ); \
- ( cd $(TF_LIBDIR); rm -f $$files tf.help tf.help.index; ); \
- cp $$files $(TF_LIBDIR); \
- cp $$files $(TF_LIBDIR); \
- cd $(TF_LIBDIR); \
- cd $(TF_LIBDIR); \
+ ( cd $(DESTDIR)$(TF_LIBDIR); rm -f $$files tf.help tf.help.index; ); \
- chmod $(MODE) $$files; chmod ugo-wx $$files
+ cp $$files $(DESTDIR)$(TF_LIBDIR); \
+ cd $(DESTDIR)$(TF_LIBDIR); \
chmod $(MODE) $$files; chmod ugo-wx $$files
- -rm -f $(TF_LIBDIR)/CHANGES
- -rm -f $(TF_LIBDIR)/CHANGES
- cp ../CHANGES $(TF_LIBDIR)
- cp ../CHANGES $(TF_LIBDIR)
- chmod $(MODE) $(TF_LIBDIR)/CHANGES; chmod ugo-wx $(TF_LIBDIR)/CHANGES
- chmod $(MODE) $(TF_LIBDIR)/CHANGES; chmod ugo-wx $(TF_LIBDIR)/CHANGES
- chmod $(MODE) $(TF_LIBDIR)
- chmod $(MODE) $(TF_LIBDIR)
- -@cd $(TF_LIBDIR); old=`ls replace.tf 2>/dev/null`; \
- -@cd $(TF_LIBDIR); old=`ls replace.tf 2>/dev/null`; \
+ -rm -f $(DESTDIR)$(TF_LIBDIR)/CHANGES
- if [ -n "$$old" ]; then \
+ cp ../CHANGES $(DESTDIR)$(TF_LIBDIR)
- echo "## WARNING: Obsolete files found in $(TF_LIBDIR): $$old"; \
+ chmod $(MODE) $(DESTDIR)$(TF_LIBDIR)/CHANGES; chmod ugo-wx $(DESTDIR)$(TF_LIBDIR)/CHANGES
- fi
+ chmod $(MODE) $(DESTDIR)$(TF_LIBDIR)
- @echo '## Creating links so old library names still work...'
+ -@cd $(DESTDIR)$(TF_LIBDIR); old=`ls replace.tf 2>/dev/null`; \
if [ -n "$$old" ]; then \
echo "## WARNING: Obsolete files found in $(TF_LIBDIR): $$old"; \
fi
@echo '## Creating links so old library names still work...'
-# @# note: ln -sf isn't portable.
-# @# note: ln -sf isn't portable.
- @cd $(TF_LIBDIR); \
- @cd $(TF_LIBDIR); \
+ @cd $(DESTDIR)$(TF_LIBDIR); \
- rm -f bind-bash.tf; ln -s kb-bash.tf bind-bash.tf; \
rm -f bind-bash.tf; ln -s kb-bash.tf bind-bash.tf; \
- rm -f bind-emacs.tf; ln -s kb-emacs.tf bind-emacs.tf; \
rm -f bind-emacs.tf; ln -s kb-emacs.tf bind-emacs.tf; \
- rm -f completion.tf; ln -s complete.tf completion.tf; \
rm -f completion.tf; ln -s complete.tf completion.tf; \
- rm -f factorial.tf; ln -s factoral.tf factorial.tf; \
- rm -f file-xfer.tf; ln -s filexfer.tf file-xfer.tf; \
- rm -f local.tf.sample; ln -s local-eg.tf local.tf.sample; \
- rm -f pref-shell.tf; ln -s psh.tf pref-shell.tf; \
- rm -f space_page.tf; ln -s spc-page.tf space_page.tf; \
- rm -f speedwalk.tf; ln -s spedwalk.tf speedwalk.tf; \
- rm -f stack_queue.tf; ln -s stack-q.tf stack_queue.tf; \
- rm -f worldqueue.tf; ln -s world-q.tf worldqueue.tf;
+ install -Dm644 ../tf-lib/lisp.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/hanoi.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/spell.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/spedwalk.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kb-emacs.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tf-help.idx $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tools.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/watch.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kb_badterm.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/world-q.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/changes.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/stack-q.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/factoral.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/cylon.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/quoter.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/psh.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/textutil.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/finger.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/savehist.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/textencode.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/spc-page.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/teraterm.keyboard.cnf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/testcolor.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tintin.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/grep.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tfrc $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/rwho.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/alias.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kbbind.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/complete.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kbregion.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/color.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kb-bash.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kbstack.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/filexfer.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/activity_status.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tfstatus.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/relog.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/local-eg.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/stdlib.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/at.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tick.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kb-os2.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kbfunc.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/pcmd.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/map.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/activity_status2.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/kb-old.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/tr.tf $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../CHANGES $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../README $(DESTDIR)$(datadir)/tf-lib
+ install -Dm644 ../tf-lib/examples.old $(DESTDIR)$(datadir)/tf-lib
makehelp: makehelp.c
$(CC) $(CFLAGS) -o makehelp makehelp.c
This diff is collapsed.
Click to expand it.
testing/tf/APKBUILD
+
2
−
2
View file @
7991eb4d
...
@@ -6,7 +6,7 @@ _pkgver=50b8
...
@@ -6,7 +6,7 @@ _pkgver=50b8
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"Powerful curses-based MUD client"
pkgdesc
=
"Powerful curses-based MUD client"
url
=
"http://tinyfugue.sourceforge.net/"
url
=
"http://tinyfugue.sourceforge.net/"
arch
=
""
arch
=
"
all
"
license
=
"GPL-2.0+"
license
=
"GPL-2.0+"
depends
=
""
depends
=
""
depends_dev
=
""
depends_dev
=
""
...
@@ -42,7 +42,7 @@ package() {
...
@@ -42,7 +42,7 @@ package() {
}
}
sha512sums
=
"3b99c039d7a9c6ab7ee7b1040ff7c99fe39cbe991f373333ea7c130d54383f102f14ae33303a415f5419cd43238caffc46114e842c6964329c0999e0f506e3d0 tf-50b8.tar.gz
sha512sums
=
"3b99c039d7a9c6ab7ee7b1040ff7c99fe39cbe991f373333ea7c130d54383f102f14ae33303a415f5419cd43238caffc46114e842c6964329c0999e0f506e3d0 tf-50b8.tar.gz
9fb762886bfbe9e6c205e7a5cde6b17c516711daafba3999bdc4f2d1aa427043d95c6d6fa0a8b057e04222726b7692f0b35622c9d5fe063cfae50d3d9429cb25
0001-Add-DESTDIR-support.patch
edb921058e6a99493743a268fc2a95418f47fb3bb6d814c3187a0fc99cb615a3d6d7354deb0c9aac730dc3820a45f705fb26d5f477aa4a57266ed3f8248b28e7
0001-Add-DESTDIR-support.patch
7d2b2da0f4213fcfbce86eb9042cb83751c80aba5881861d5f49d4604a4eba52d60b5254c8b119528f0890ae7a68dfe4fea7eb2c94dd0d01676b194bca4db219 0002-Correct-use-of-va_list.patch
7d2b2da0f4213fcfbce86eb9042cb83751c80aba5881861d5f49d4604a4eba52d60b5254c8b119528f0890ae7a68dfe4fea7eb2c94dd0d01676b194bca4db219 0002-Correct-use-of-va_list.patch
1e8f05d2744b60cc78f494283bb5f9ef7a804a6811d16028d5486a7394658a03aed04962adfd5bc60fe1517d3831b41f4ca1c3956a624f09a2a4b14f5ab91608 0003-Minor-man-page-fixes.patch
1e8f05d2744b60cc78f494283bb5f9ef7a804a6811d16028d5486a7394658a03aed04962adfd5bc60fe1517d3831b41f4ca1c3956a624f09a2a4b14f5ab91608 0003-Minor-man-page-fixes.patch
0066bbb3919e6b157eb276c3975cadc258a195037c0f199c3f9db83868d6035f81b79b9a41a743c99f317fd253a2f670dcf122d5f7c449fc1677c56cfaa8bb6a 0006-Fix-library-install-path.patch
0066bbb3919e6b157eb276c3975cadc258a195037c0f199c3f9db83868d6035f81b79b9a41a743c99f317fd253a2f670dcf122d5f7c449fc1677c56cfaa8bb6a 0006-Fix-library-install-path.patch
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment