Skip to content
Snippets Groups Projects
Commit 77c1700c authored by alice's avatar alice
Browse files

community/py3-aiohttp: upgrade to 3.8.3

parent 5f20abe3
No related branches found
No related tags found
1 merge request!40590main/py3-charset-normalizer: upgrade to 3.0.0
...@@ -2,8 +2,8 @@ ...@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org> # Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-aiohttp pkgname=py3-aiohttp
_pkgname=aiohttp _pkgname=aiohttp
pkgver=3.8.1 pkgver=3.8.3
pkgrel=2 pkgrel=0
pkgdesc="HTTP client/server for asyncio" pkgdesc="HTTP client/server for asyncio"
url="https://pypi.python.org/pypi/aiohttp" url="https://pypi.python.org/pypi/aiohttp"
arch="all" arch="all"
...@@ -22,9 +22,8 @@ depends=" ...@@ -22,9 +22,8 @@ depends="
" "
makedepends="python3-dev py3-setuptools" makedepends="python3-dev py3-setuptools"
checkdepends="py3-pytest py3-pytest-cov py3-pytest-mock py3-async_generator py3-freezegun" checkdepends="py3-pytest py3-pytest-cov py3-pytest-mock py3-async_generator py3-freezegun"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
fix-tests.patch charset-normaliser-3.patch
" "
builddir="$srcdir/$_pkgname-$pkgver" builddir="$srcdir/$_pkgname-$pkgver"
...@@ -44,13 +43,16 @@ build() { ...@@ -44,13 +43,16 @@ build() {
} }
check() { check() {
PYTHONPATH="$(echo build/lib.*)" pytest PYTHONPATH="$(echo build/lib.*)" \
pytest -W ignore::DeprecationWarning -v \
-k 'not test_no_warnings and not test_set_loop_default_loop and not test_default_loop'
} }
package() { package() {
python3 setup.py install --root="$pkgdir" --optimize=1 python3 setup.py install --root="$pkgdir" --skip-build
} }
sha512sums=" sha512sums="
3611549393e50c8d30426aee9ddd23794a71ddefe4384eb549049b93e452fafb38de7ad900737213b61fbe717bd85035a780c1622593eae250328f17d484a0a7 py3-aiohttp-3.8.1.tar.gz 248c232604c91442b2fc9fa55fbf7df8e3af56dcf4cd9c516414a3a738c5c60a8a06395cd9c6e2c8ea9884728aea757423735c7b9be889e6f17e3ee6395a2f64 py3-aiohttp-3.8.3.tar.gz
9523bb6031ed6799d431a8b4f5ee29412dc52a0b72f9404909183b024ffa4836ed9387a0b52b288c0d699c31915192216bdd9fe32532073d699cfc4cf925d820 fix-tests.patch 86a2d8cf6de6277d1ddc808d6ba9fdbb0ef4f318b7569a45fd75e1f01dff091074b01b2429735af1470e1be1e704386893fcf3c84d00a3b09655ceeb32ffde07 charset-normaliser-3.patch
" "
Patch-Source: https://github.com/aio-libs/aiohttp/commit/cf8e25d0175f1d4874781b67c0dd466557be8e69
From cf8e25d0175f1d4874781b67c0dd466557be8e69 Mon Sep 17 00:00:00 2001
From: Sam Bull <aa6bs0@sambull.org>
Date: Sat, 29 Oct 2022 01:04:08 +0100
Subject: [PATCH] Raise allowed charset version (#7057)
Fixes #7050.
---
setup.cfg | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.cfg b/setup.cfg
index 83b0a2c..758f447 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -47,7 +47,7 @@ zip_safe = False
include_package_data = True
install_requires =
attrs >= 17.3.0
- charset-normalizer >=2.0, < 3.0
+ charset-normalizer >=2.0, < 4.0
multidict >=4.5, < 7.0
async_timeout >= 4.0.0a3, < 5.0
asynctest == 0.13.0; python_version<"3.8"
pytest.warns(None) was deprecated - use the alternative suggested by pytest:
https://docs.pytest.org/en/latest/how-to/capture-warnings.html#additional-use-cases-of-warnings-in-tests
diff --git a/tests/test_client_functional.py b/tests/test_client_functional.py
index 77126e1..72901f7 100644
--- a/tests/test_client_functional.py
+++ b/tests/test_client_functional.py
@@ -11,6 +11,7 @@ import ssl
from unittest import mock
import pytest
+import warnings
from async_generator import async_generator, yield_
from multidict import MultiDict
from yarl import URL
@@ -2428,19 +2429,19 @@ async def test_drop_auth_on_redirect_to_other_host(
async def test_async_with_session() -> None:
- with pytest.warns(None) as cm:
+ with warnings.catch_warnings():
+ warnings.simplefilter("error")
async with aiohttp.ClientSession() as session:
pass
- assert len(cm.list) == 0
assert session.closed
async def test_session_close_awaitable() -> None:
session = aiohttp.ClientSession()
- with pytest.warns(None) as cm:
+ with warnings.catch_warnings():
+ warnings.simplefilter("error")
await session.close()
- assert len(cm.list) == 0
assert session.closed
@@ -2448,11 +2449,10 @@ async def test_session_close_awaitable() -> None:
async def test_close_run_until_complete_not_deprecated() -> None:
session = aiohttp.ClientSession()
- with pytest.warns(None) as cm:
+ with warnings.catch_warnings():
+ warnings.simplefilter("error")
await session.close()
- assert len(cm.list) == 0
-
async def test_close_resp_on_error_async_with_session(aiohttp_server) -> None:
async def handler(request):
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment