Skip to content
Snippets Groups Projects
Commit 775474dc authored by alice's avatar alice Committed by alice
Browse files

main/numactl: upgrade to 2.0.15

parent dfa311ae
No related branches found
No related tags found
2 merge requests!39304[3.16] main/expat: security upgrade to 2.4.9,!38848main/numactl: upgrade to 2.0.15
Pipeline #135925 passed
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=numactl
pkgver=2.0.14
pkgver=2.0.15
pkgrel=0
pkgdesc="Simple NUMA policy support"
url="https://github.com/numactl/numactl"
......@@ -8,12 +8,15 @@ arch="all"
license="LGPL-2.1-only"
makedepends="autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="numactl-$pkgver.tar.gz::https://github.com/numactl/numactl/archive/v$pkgver.tar.gz
musl.patch"
source="numactl-$pkgver.tar.gz::https://github.com/numactl/numactl/archive/refs/tags/v$pkgver.tar.gz
version.patch
"
case "$CARCH" in
s390x) options="!check";; # FAIL: distance test
mips*) options="!check";; # XXX: numa support not enabled on builder
x86)
# test-distance fails
options="$options !check"
;;
esac
prepare() {
......@@ -22,17 +25,21 @@ prepare() {
./autogen.sh
}
check() {
make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
}
build() {
CFLAGS="$CFLAGS -flto=auto"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man
make
}
check() {
make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
}
package() {
make DESTDIR="$pkgdir" install
......@@ -44,9 +51,10 @@ tools() {
pkgdesc="NUMA policy control tools"
license="GPL-2.0-only"
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
amove usr/bin
}
sha512sums="adaf405f092fd9653f26d00f8c80cb83852c56ebd5d00e714e20d505008e74aa7105b0fb7aa55a605deac0d1491ceff57de931037d33e7944fca105bc6510ed4 numactl-2.0.14.tar.gz
c24affa5a8a8ea83d7f0ee384dc0629e17a5c4201357132f770f894ad4236772116d96d8389d54fb99095af40d1ccbffc3170b5fb9cc88cfca39179f50bee9c9 musl.patch"
sha512sums="
dcc76b8d36698a740e04206471352013b39bd61357d6090fc062681fa2f31e5f0b40c8582c06fd1a97919f494002bef1fa8330b6a6784b516c39961caa2a4320 numactl-2.0.15.tar.gz
965d8b4020578a6fd1d4ff0d85d6fd941534c3b26446e10529dc9c78ab331ce9dbc129e01e34282bbf615c9b3a606434079cc830bc4024b04f6273e676f2ade7 version.patch
"
--- numactl-2.0.11/syscall.c.orig
+++ numactl-2.0.11/syscall.c
@@ -115,14 +115,16 @@
#endif
-#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
+#if defined(__GLIBC__)
+# if __GLIBC_PREREQ(2,11)
/* glibc 2.11 seems to have working 6 argument sycall. Use the
glibc supplied syscall in this case.
The version cut-off is rather arbitary and could be probably
earlier. */
-#define syscall6 syscall
+# define syscall6 syscall
+#endif
#elif defined(__x86_64__)
/* 6 argument calls on x86-64 are often buggy in both glibc and
asm/unistd.h. Add a working version here. */
diff --git a/configure.ac b/configure.ac
index 1c34a1e..8709ff3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ([2.64])
-AC_INIT([numactl], [2.0.14])
+AC_INIT([numactl], [2.0.15])
AC_CONFIG_SRCDIR([numactl.c])
AC_CONFIG_MACRO_DIR([m4])
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment