Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
75b4dd28
Commit
75b4dd28
authored
6 months ago
by
mio
Committed by
Celeste
6 months ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/rmlint: fix build with gcc 14
parent
0a54e4f4
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!72665
testing/rmlint: fix build with gcc 14
Pipeline
#262044
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/rmlint/APKBUILD
+3
-1
3 additions, 1 deletion
testing/rmlint/APKBUILD
testing/rmlint/gcc14-remove-header-in-checkfunc.patch
+55
-0
55 additions, 0 deletions
testing/rmlint/gcc14-remove-header-in-checkfunc.patch
with
58 additions
and
1 deletion
testing/rmlint/APKBUILD
+
3
−
1
View file @
75b4dd28
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Maintainer: Edd Salkield <edd@salkield.uk>
# Maintainer: Edd Salkield <edd@salkield.uk>
pkgname
=
rmlint
pkgname
=
rmlint
pkgver
=
2.10.2
pkgver
=
2.10.2
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Remove duplicates and other lint from your filesystem"
pkgdesc
=
"Remove duplicates and other lint from your filesystem"
url
=
"https://rmlint.readthedocs.io/en/latest/"
url
=
"https://rmlint.readthedocs.io/en/latest/"
arch
=
"all"
arch
=
"all"
...
@@ -12,6 +12,7 @@ checkdepends="dash py3-nose py3-parameterized py3-psutil"
...
@@ -12,6 +12,7 @@ checkdepends="dash py3-nose py3-parameterized py3-psutil"
subpackages
=
"
$pkgname
-doc
$pkgname
-lang
$pkgname
-shredder-pyc
$pkgname
-shredder:shredder:noarch"
subpackages
=
"
$pkgname
-doc
$pkgname
-lang
$pkgname
-shredder-pyc
$pkgname
-shredder:shredder:noarch"
source
=
"https://github.com/sahib/rmlint/archive/v
$pkgver
/rmlint-v
$pkgver
.tar.gz
source
=
"https://github.com/sahib/rmlint/archive/v
$pkgver
/rmlint-v
$pkgver
.tar.gz
remove-usage-of-lseek64.patch
remove-usage-of-lseek64.patch
gcc14-remove-header-in-checkfunc.patch
"
"
options
=
"!check"
# awaiting upstream fixes to test suite
options
=
"!check"
# awaiting upstream fixes to test suite
# https://github.com/sahib/rmlint/issues/593
# https://github.com/sahib/rmlint/issues/593
...
@@ -41,4 +42,5 @@ shredder() {
...
@@ -41,4 +42,5 @@ shredder() {
sha512sums
=
"
sha512sums
=
"
8f8d58892785e9012cb15f3e89480d9d04772fa3f923064520bf17afcc8948b1a24d6f8399176a1a26bd5036553c605958f3720e40cf6cba135a4f3381131180 rmlint-v2.10.2.tar.gz
8f8d58892785e9012cb15f3e89480d9d04772fa3f923064520bf17afcc8948b1a24d6f8399176a1a26bd5036553c605958f3720e40cf6cba135a4f3381131180 rmlint-v2.10.2.tar.gz
f77bf8d77bf7d7c83a91a97ed79733b11ea55bd1814ba13262349a4ebd29bf8de4e76b0a082676c634ef83106953097dae1d6faddfa6aa9866a7cf41ed158b18 remove-usage-of-lseek64.patch
f77bf8d77bf7d7c83a91a97ed79733b11ea55bd1814ba13262349a4ebd29bf8de4e76b0a082676c634ef83106953097dae1d6faddfa6aa9866a7cf41ed158b18 remove-usage-of-lseek64.patch
fe3e496de332975bbb26127c2dd6eef9e71d8f442c4ee301cb47d2cdac409c7803b76f74b26f9958b5849e26a2ef6098901284938f43de291af31e775eda69eb gcc14-remove-header-in-checkfunc.patch
"
"
This diff is collapsed.
Click to expand it.
testing/rmlint/gcc14-remove-header-in-checkfunc.patch
0 → 100644
+
55
−
0
View file @
75b4dd28
Source: https://github.com/sahib/rmlint/pull/605.patch
--
From 2911558726338ea447ba310321f2f0a090d00cb4 Mon Sep 17 00:00:00 2001
From: Alex Fan <alex.fan.q@gmail.com>
Date: Sat, 7 Jan 2023 02:14:17 +1100
Subject: [PATCH] remove header in CheckFunc
this is the proper way suggested by upstream
https://pairlist4.pair.net/pipermail/scons-users/2023-January/009150.html
---
SConstruct | 17 +++--------------
1 file changed, 3 insertions(+), 14 deletions(-)
diff --git a/SConstruct b/SConstruct
index 7e12d4134..83af15e12 100755
--- a/SConstruct
+++ b/SConstruct
@@ -196,12 +196,7 @@
def check_bigfiles(context):
have_stat64 = True
if tests.CheckFunc(
- context, 'stat64',
- header=
- '#include <sys/types.h>'
- '#include <sys/stat.h>'
- '#include <unistd.h>'
-
+ context, 'stat64'
):
have_stat64 = False
@@ -269,10 +264,7 @@
def check_xattr(context):
for func in ['getxattr', 'setxattr', 'removexattr', 'listxattr']:
if tests.CheckFunc(
- context, func,
- header=
- '#include <sys/types.h>'
- '#include <sys/xattr.h>'
+ context, func
):
rc = 0
break
@@ -290,10 +282,7 @@
def check_lxattr(context):
for func in ['lgetxattr', 'lsetxattr', 'lremovexattr', 'llistxattr']:
if tests.CheckFunc(
- context, func,
- header=
- '#include <sys/types.h>'
- '#include <sys/xattr.h>'
+ context, func
):
rc = 0
break
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment