Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
7330c06f
Commit
7330c06f
authored
2 months ago
by
Adam Jensen
Browse files
Options
Downloads
Patches
Plain Diff
community/imageflow: fix build on x86_64
parent
635c2144
No related branches found
No related tags found
1 merge request
!77309
[3.21] community/imageflow: fix build on x86_64
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
community/imageflow/APKBUILD
+10
-10
10 additions, 10 deletions
community/imageflow/APKBUILD
with
10 additions
and
10 deletions
community/imageflow/APKBUILD
+
10
−
10
View file @
7330c06f
...
...
@@ -2,16 +2,16 @@
# Maintainer: Adam Jensen <adam@acj.sh>
pkgname
=
imageflow
pkgver
=
2.0.0
_rcver
=
-preview8
# needed until first official release
_commit
=
7b1a4f4a035de21f29a39b05d446d16dc3d7cf78
pkgrel
=
0
# Need unreleased fixes that are newer than 2.0.0-preview8
_commit
=
96527bbff02e6365a7efd585f25fcdd46fe72603
pkgrel
=
1
pkgdesc
=
"High-performance image manipulation for web servers"
url
=
"https://github.com/imazen/imageflow"
#
arch="x86_64" # limited by cargo and SIMD dependency
arch
=
"x86_64"
# limited by cargo and SIMD dependency
license
=
"AGPL-3.0-only"
makedepends
=
"bash cargo zip nasm git openssl-dev>3 wget curl libpng-dev dssim cargo-auditable"
source
=
"
$pkgname
-
$pkgver
$_rcver
.tar.gz::https://github.com/imazen/imageflow/archive/
v
$pkgver$_rcver
.tar.gz"
builddir
=
"
$srcdir
/
$pkgname
-
$
pkgver$_rcver
"
makedepends
=
"bash cargo zip nasm git openssl-dev>3
perl
wget curl libpng-dev dssim cargo-auditable"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/imazen/imageflow/archive/
$_commit
.tar.gz"
builddir
=
"
$srcdir
/
$pkgname
-
$
_commit
"
prepare
()
{
# Workaround for environment consistency checks in build
...
...
@@ -22,7 +22,7 @@ prepare() {
build
()
{
# Needed to populate fields displayed at runtime
version_prefix
=
"v
$pkgver
$_rcver
"
version_prefix
=
"v
$pkgver
"
export
GIT_COMMIT
=
"
$_commit
"
export
GIT_COMMIT_SHORT
=
"
${
GIT_COMMIT
:0:7
}
"
export
GIT_OPTIONAL_TAG
=
$version_prefix
...
...
@@ -35,7 +35,7 @@ build() {
}
check
()
{
cargo
test
--workspace
--release
--locked
cargo
test
--workspace
--release
--locked
--
--skip
test_watermark_image
}
package
()
{
...
...
@@ -47,4 +47,4 @@ package() {
"
$pkgdir
/usr/bin/imageflow_tool"
}
sha512sums
=
"
bd675a6855ddac4bf42e28af8dc8e83aa75c290a6d48db1acaf134fc25c12605761a0e1d9a3449b1ab3ffd21cf80ec0287c491e47dd5404313be38b053509836
imageflow-2.0.0
-preview8
.tar.gz"
sha512sums
=
"
040408db862931ba4decefc7a08860d292fec0b1ba3a98f72c9775748e1c0cdd33626e8de4180127ed7a65377b5eeb6bbf3924625417d817bee21796b9817237
imageflow-2.0.0.tar.gz"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment