Skip to content
Snippets Groups Projects
Commit 70e44ca4 authored by Kevin Daudt's avatar Kevin Daudt :computer:
Browse files

community/py3-cligj: work with click 8.x

parent 9a2cef2a
No related branches found
No related tags found
No related merge requests found
......@@ -20,6 +20,7 @@ checkdepends="
"
source="
py3-cligj-$pkgver.tar.gz::https://github.com/mapbox/cligj/archive/$pkgver.tar.gz
click-is-version-8.patch
"
builddir="$srcdir/cligj-$pkgver"
......@@ -35,4 +36,7 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
}
sha512sums="34cd6c6a2ff1e268443d74694608e2acf92a31b93ffd53bd0f7280b8e0a18d3c25f98b9206638ee50793b714bea01593bb67becfd7d70322ad6d609d552465a9 py3-cligj-0.7.1.tar.gz"
sha512sums="
34cd6c6a2ff1e268443d74694608e2acf92a31b93ffd53bd0f7280b8e0a18d3c25f98b9206638ee50793b714bea01593bb67becfd7d70322ad6d609d552465a9 py3-cligj-0.7.1.tar.gz
87adce2427d00715bc071f1399f3dba76d07d4a13a3b944dd348d1606fdf3bc061e3bda2ee0c8066c055cf34b3ca0d2986db00bbc38185ced688399678ed0e58 click-is-version-8.patch
"
diff --git a/setup.py b/setup.py
index a12dde1..2ccaa62 100755
--- a/setup.py
+++ b/setup.py
@@ -27,6 +27,6 @@ setup(
include_package_data=True,
zip_safe=False,
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, <4",
- install_requires=["click >= 4.0, < 8"],
+ install_requires=["click >= 4.0, < 9"],
extras_require={"test": ["pytest-cov"],},
)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment