Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
6a60630d
Commit
6a60630d
authored
7 years ago
by
Mike Sullivan
Committed by
Natanael Copa
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/ocaml-cppo allow textrels and fix asr
parent
2fd76197
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/ocaml-cppo/APKBUILD
+8
-3
8 additions, 3 deletions
testing/ocaml-cppo/APKBUILD
testing/ocaml-cppo/ppc64le-asr.patch
+11
-0
11 additions, 0 deletions
testing/ocaml-cppo/ppc64le-asr.patch
with
19 additions
and
3 deletions
testing/ocaml-cppo/APKBUILD
+
8
−
3
View file @
6a60630d
...
...
@@ -8,11 +8,15 @@ pkgdesc="C-style preprocessor for OCaml"
url
=
"https://github.com/mjambon/cppo"
# ocaml is not avail for x86, armhf, s390x
# test fails on ppc64le
arch
=
"all !x86 !armhf !s390x
!ppc64le
"
arch
=
"all !x86 !armhf !s390x"
license
=
"BSD-3-Clause"
makedepends
=
"dune ocaml ocamlbuild ocaml-findlib opam"
options
=
"textrels"
subpackages
=
"
$pkgname
-dev
$pkgname
-ocamlbuild"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/mjambon/
$_pkgname
/archive/v
$pkgver
.tar.gz"
subpackages
=
"
$pkgname
-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/mjambon/
$_pkgname
/archive/v
$pkgver
.tar.gz
ppc64le-asr.patch
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
build
()
{
...
...
@@ -63,4 +67,5 @@ dev() {
mv
*
.cmx
*
.cmxa
*
.mli
"
$subpkgdir
"
/
$sitelib
/
}
sha512sums
=
"89c6df66d597d929be7532ad82f0206b028bdbd79a0b4b39451bce3fa5bd63a80dce931d575f69bd7066de829347498c736657dfe9610b20700a652b9b542a4d ocaml-cppo-1.6.4.tar.gz"
sha512sums
=
"89c6df66d597d929be7532ad82f0206b028bdbd79a0b4b39451bce3fa5bd63a80dce931d575f69bd7066de829347498c736657dfe9610b20700a652b9b542a4d ocaml-cppo-1.6.4.tar.gz
718b0bfb4c0106e153bde9cf9a52f79858f113b3a8ffd6c9f887c2b2fec16dd330e952786e322a3532200e34ae533828d9d98c3fa784910cd3f92fec56250533 ppc64le-asr.patch"
This diff is collapsed.
Click to expand it.
testing/ocaml-cppo/ppc64le-asr.patch
0 → 100644
+
11
−
0
View file @
6a60630d
--- a/src/cppo_parser.mly
+++ b/src/cppo_parser.mly
@@ -252,7 +252,7 @@
| aexpr MOD aexpr { `Mod ($2, $1, $3) }
| aexpr LSL aexpr { `Lsl ($1, $3) }
| aexpr LSR aexpr { `Lsr ($1, $3) }
- | aexpr ASR aexpr { `Lsr ($1, $3) }
+ | aexpr ASR aexpr { `Asr ($1, $3) }
| aexpr LAND aexpr { `Land ($1, $3) }
| aexpr LOR aexpr { `Lor ($1, $3) }
| aexpr LXOR aexpr { `Lxor ($1, $3) }
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment