Commit 66f28b64 authored by Timo Teräs's avatar Timo Teräs

main/apk-tools: upgrade to 2.10.6

parent 695dc71c
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.10.5
pkgrel=3
pkgver=2.10.6
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
arch="all"
url="https://gitlab.alpinelinux.org/alpine/apk-tools"
......@@ -14,8 +14,8 @@ if [ "$CBUILD" = "$CHOST" ]; then
subpackages="$subpackages lua5.3-apk:luaapk"
makedepends="$makedepends lua5.3-dev"
fi
source="https://dev.alpinelinux.org/archive/apk-tools/apk-tools-$pkgver.tar.xz"
source="https://gitlab.alpinelinux.org/alpine/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
default_prepare
......@@ -50,7 +50,7 @@ package() {
static() {
pkgdesc="Alpine Package Keeper - static binary"
install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
install -Dm755 "$builddir"/src/apk.static \
"$subpkgdir"/sbin/apk.static
# lets sign the static binary so it can be vefified from distros
......@@ -74,4 +74,4 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
sha512sums="0f85ec7c734f2ffc671007fa029f3c96eacfb196c45e465e33aa65c32a6fbcd7523153b6441fdf826a5b4d2e66de02d338620474d333c28cb1ce0233f1120495 apk-tools-2.10.5.tar.xz"
sha512sums="81e51fdaf7976d589c847850dc3494a6bb91847f14a756e1dd9afe7f526b672e6aab743965506ef89e3229084bc92c9041a49796b400f454a2c912efebd44b4f apk-tools-v2.10.6.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment