Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
667b36a6
Commit
667b36a6
authored
5 months ago
by
Alex Denes
Committed by
Sören Tempel
4 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/mblaze: upgrade to 1.3
parent
a52931f7
No related branches found
No related tags found
1 merge request
!72142
community/mblaze: upgrade to 1.3
Pipeline
#260156
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/mblaze/APKBUILD
+7
-8
7 additions, 8 deletions
community/mblaze/APKBUILD
community/mblaze/mlist.patch
+0
-27
0 additions, 27 deletions
community/mblaze/mlist.patch
with
7 additions
and
35 deletions
community/mblaze/APKBUILD
+
7
−
8
View file @
667b36a6
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname
=
mblaze
pkgver
=
1.
2
pkgrel
=
2
pkgver
=
1.
3
pkgrel
=
0
pkgdesc
=
"Unix utilities to deal with Maildir"
url
=
"https://git
hub.com/leahneukirchen
/mblaze"
url
=
"https://git
.vuxu.org
/mblaze
/
"
arch
=
"all"
license
=
"CC0-1.0"
depends
=
"file"
checkdepends
=
"perl-utils"
subpackages
=
"
$pkgname
-doc
$pkgname
-crypto::noarch"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/leahneukirchen/mblaze/archive/v
$pkgver
.tar.gz
mlist.patch
subpackages
=
"
$pkgname
-doc
$pkgname
-crypto::noarch
$pkgname
-zsh-completion"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://git.vuxu.org/mblaze/snapshot/mblaze-
$pkgver
.tar.gz
"
build
()
{
...
...
@@ -29,6 +28,7 @@ package() {
install
-m644
./
*
.example
"
$pkgdir
"
/usr/share/doc/
$pkgname
/examples/
install
-m644
NEWS.md VIOLATIONS.md README
\
"
$pkgdir
"
/usr/share/doc/
$pkgname
/
install
-Dm644
./contrib/_mblaze
"
$pkgdir
"
/usr/share/zsh/site-functions/_mblaze
}
crypto
()
{
...
...
@@ -42,6 +42,5 @@ crypto() {
}
sha512sums
=
"
32f1ed6332d3b481d501e6f4f64fbd9b74ac26aabf55862da8b2444144e9a39f908143c3ec77b0adce90f08455e7544af9f19458d4e628c36c06ee407d81548a mblaze-1.2.tar.gz
882cebb308209ffeb4e10ddd7c5a61ed13e8c22fa42d6a437e347aa1b095718fee17f87f3bbedffb43b9ac8bdf422c8acd9b2bc9bf18bf836abeb513cb106509 mlist.patch
65acc92654fe2f32328b57969930711128138067c9c23def025eb55b82a237d635b5923e9106ada394954b63eb6cd1e4e55f875aafc6201f21f83e8142905470 mblaze-1.3.tar.gz
"
This diff is collapsed.
Click to expand it.
community/mblaze/mlist.patch
deleted
100644 → 0
+
0
−
27
View file @
a52931f7
Patch-Source: https://github.com/leahneukirchen/mblaze/commit/1babebc12c3ea8d3395f00c9607e863866c190fc.patch
--
From 1babebc12c3ea8d3395f00c9607e863866c190fc Mon Sep 17 00:00:00 2001
From: Michael Forney <mforney@mforney.org>
Date: Wed, 7 Dec 2022 13:11:58 -0800
Subject: [PATCH] mlist: use fixed-width integer types for struct
linux_dirent64 d_ino and d_off
---
mlist.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/mlist.c b/mlist.c
index 5debf99..20061d9 100644
--- a/mlist.c
+++ b/mlist.c
@@ -111,8 +111,8 @@
list(char *prefix, char *file)
#include <sys/syscall.h>
struct linux_dirent64 {
- ino64_t d_ino; /* 64-bit inode number */
- off64_t d_off; /* 64-bit offset to next structure */
+ uint64_t d_ino; /* 64-bit inode number */
+ int64_t d_off; /* 64-bit offset to next structure */
unsigned short d_reclen; /* Size of this dirent */
unsigned char d_type; /* File type */
char d_name[]; /* Filename (null-terminated) */
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment