Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
62b4011f
Commit
62b4011f
authored
5 months ago
by
Antoine Martin
Committed by
omni
5 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-vine: upgrade to 5.1.0
parent
9a08bb0c
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!74237
community/py3-vine: upgrade to 5.1.0
Pipeline
#268908
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-vine/105_tests-replace-deprecated-setup-method.patch
+28
-0
28 additions, 0 deletions
.../py3-vine/105_tests-replace-deprecated-setup-method.patch
community/py3-vine/APKBUILD
+8
-4
8 additions, 4 deletions
community/py3-vine/APKBUILD
with
36 additions
and
4 deletions
community/py3-vine/105_tests-replace-deprecated-setup-method.patch
0 → 100644
+
28
−
0
View file @
62b4011f
From 8b41bf0052de96672c69a8c297cb24f1dd9c0d69 Mon Sep 17 00:00:00 2001
From: Stanislav Levin <slev@altlinux.org>
Date: Tue, 27 Feb 2024 20:09:28 +0300
Subject: [PATCH] tests: Replace deprecated setup method
Nose's `setup` method is deprecated since Pytest 7.2.
See https://docs.pytest.org/en/stable/deprecations.html#support-for-tests-written-for-nose for details.
Fixes: https://github.com/celery/vine/issues/104
Signed-off-by: Stanislav Levin <slev@altlinux.org>
---
t/unit/test_synchronization.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/t/unit/test_synchronization.py b/t/unit/test_synchronization.py
index 87335b6..47b7a10 100644
--- a/t/unit/test_synchronization.py
+++ b/t/unit/test_synchronization.py
@@ -8,7 +8,7 @@
class test_barrier:
- def setup(self):
+ def setup_method(self):
self.m1, self.m2, self.m3 = Mock(), Mock(), Mock()
self.ps = [promise(self.m1), promise(self.m2), promise(self.m3)]
This diff is collapsed.
Click to expand it.
community/py3-vine/APKBUILD
+
8
−
4
View file @
62b4011f
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname
=
py3-vine
pkgver
=
5.
0
.0
pkgrel
=
3
pkgver
=
5.
1
.0
pkgrel
=
0
pkgdesc
=
"futures and promises implementation for python"
url
=
"https://github.com/celery/vine"
arch
=
"noarch"
...
...
@@ -10,7 +10,10 @@ depends="python3"
makedepends
=
"py3-setuptools py3-gpep517 py3-wheel"
checkdepends
=
"py3-pytest py3-case py3-nose"
subpackages
=
"
$pkgname
-pyc"
source
=
"https://files.pythonhosted.org/packages/source/v/vine/vine-
$pkgver
.tar.gz"
source
=
"
https://files.pythonhosted.org/packages/source/v/vine/vine-
$pkgver
.tar.gz
105_tests-replace-deprecated-setup-method.patch
"
builddir
=
"
$srcdir
/vine-
$pkgver
"
replaces
=
"py-vine"
# Backwards compatibility
...
...
@@ -32,5 +35,6 @@ package() {
}
sha512sums
=
"
ff8f4b3f675220772ed0523e468eedbaec4aca793877b984e9a215603d1288cc3cc71dfeb152219d22f98de0ac7e9f9fa0cc35c2424ff36044cfc8f28192c159 vine-5.0.0.tar.gz
899a494d26ce8236ba12451e8da42fad03803df0a9cf69829f650c23c0d4f6232b9246230fd984fa6616edbad8b2c08f0efe95e3692bee756dfc094f14e3432d vine-5.1.0.tar.gz
6a70026e9f4cc8a6b49e9322fad143d378cbc9c09763e1c742fbf93e83b3451b9ad436e5ddc4b392b4f9cb5b266e173d64a1471a98245088dac9c0002b53710e 105_tests-replace-deprecated-setup-method.patch
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment