Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
6051096e
Commit
6051096e
authored
3 years ago
by
Dermot Bradley
Committed by
Andy Postnikov
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/step-cli: upgrade to 0.17.6
Remove patch fix-certificate-tests.patch as no longer required.
parent
1790d3a5
Loading
Loading
1 merge request
!26075
community/step-cli: upgrade to 0.17.6
Pipeline
#95545
canceled
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/step-cli/APKBUILD
+2
-4
2 additions, 4 deletions
community/step-cli/APKBUILD
community/step-cli/fix-certificate-tests.patch
+0
-46
0 additions, 46 deletions
community/step-cli/fix-certificate-tests.patch
with
2 additions
and
50 deletions
community/step-cli/APKBUILD
+
2
−
4
View file @
6051096e
...
...
@@ -3,7 +3,7 @@
# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
pkgname
=
step-cli
pkgver
=
0.17.
2
pkgver
=
0.17.
6
pkgrel
=
0
pkgdesc
=
"Zero trust swiss army knife that integrates with step-ca for automated certificate management"
url
=
"https://github.com/smallstep/cli"
...
...
@@ -20,7 +20,6 @@ subpackages="
"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/smallstep/cli/archive/v
$pkgver
.tar.gz
fix-certificate-tests.patch
"
builddir
=
"
$srcdir
/cli-
$pkgver
"
...
...
@@ -43,6 +42,5 @@ package() {
}
sha512sums
=
"
30c53a393636cb997686941534c146e7fb2b15e6183ce68eef96eb8969b0cc57e5e9f2139aa21132da31375b694b2866c13d6e552f98f2652be3584420e7f9dd step-cli-0.17.2.tar.gz
b3226046764984c67a7e9b489d043e360560633b637778a9eed359ce26c3d23087b4ba5ab18d7467348e5086a68e0a588f50a5f99078dc1da59ad01ab0e8226a fix-certificate-tests.patch
873abfd6a09619d1cb42d253394f95ad18abaaee320b1d436daf0dd1111e0c03b206d9826796dd802845628798e7d162ca38dce4663502f584407ff6351b96ac step-cli-0.17.6.tar.gz
"
This diff is collapsed.
Click to expand it.
community/step-cli/fix-certificate-tests.patch
deleted
100644 → 0
+
0
−
46
View file @
1790d3a5
From 3bf37e55ffecfd9b76e736e91ccdae0b37a8b2ca Mon Sep 17 00:00:00 2001
From: David Eger <david.eger@gmail.com>
Date: Fri, 3 Sep 2021 14:04:31 -0700
Subject: [PATCH] Update tests to match current exception strings for malformed
certs.
---
crypto/pemutil/pem_test.go | 4 ++--
crypto/x509util/identity_test.go | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/crypto/pemutil/pem_test.go b/crypto/pemutil/pem_test.go
index 30851dcc..3c4249e2 100644
--- a/crypto/pemutil/pem_test.go
+++ b/crypto/pemutil/pem_test.go
@@ -230,7 +230,7 @@
func TestReadCertificate(t *testing.T) {
{"testdata/notexists.crt", errors.New("open testdata/notexists.crt failed: no such file or directory")},
{"testdata/badca.crt", errors.New("error parsing testdata/badca.crt")},
{"testdata/badpem.crt", errors.New("error decoding testdata/badpem.crt: not a valid PEM encoded block")},
- {"testdata/badder.crt", errors.New("error parsing testdata/badder.crt: asn1: syntax error: data truncated")},
+ {"testdata/badder.crt", errors.New("error parsing testdata/badder.crt: x509:")},
{"testdata/openssl.p256.pem", errors.New("error decoding PEM: file 'testdata/openssl.p256.pem' does not contain a certificate")},
}
@@ -259,7 +259,7 @@
func TestReadCertificateBundle(t *testing.T) {
{"testdata/notexists.crt", 0, errors.New("open testdata/notexists.crt failed: no such file or directory")},
{"testdata/badca.crt", 0, errors.New("error parsing testdata/badca.crt")},
{"testdata/badpem.crt", 0, errors.New("error decoding PEM: file 'testdata/badpem.crt' contains unexpected data")},
- {"testdata/badder.crt", 0, errors.New("error parsing testdata/badder.crt: asn1: syntax error: data truncated")},
+ {"testdata/badder.crt", 0, errors.New("error parsing testdata/badder.crt: x509:")},
{"testdata/openssl.p256.pem", 0, errors.New("error decoding PEM: file 'testdata/openssl.p256.pem' is not a certificate bundle")},
}
diff --git a/crypto/x509util/identity_test.go b/crypto/x509util/identity_test.go
index 06020356..4e9ba728 100644
--- a/crypto/x509util/identity_test.go
+++ b/crypto/x509util/identity_test.go
@@ -26,7 +26,7 @@
func TestLoadIdentityFromDisk(t *testing.T) {
crtPath: testBadCert,
keyPath: "",
pass: "",
- err: errors.Errorf("error parsing %s: asn1: syntax error: trailing data",
+ err: errors.Errorf("error parsing %s: x509: trailing data",
testBadCert),
},
"error parsing rsa key": {
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment